Вход | Регистрация
 

заполнение субконто

заполнение субконто
Я
   Adilgeriy
 
30.04.19 - 21:37
документ ввод начальных остатков
хочу заполнить субконтно документы расчетов
Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.ДокументыРасчетов]    = Регистратор.Ссылка;
также делал
Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.ДокументыРасчетов]    = Регистратор;
поле регистратор элемент формы обработки
используется:
Проводки = РегистрыБухгалтерии.ЖурналПроводокЕПСБУ.СоздатьНаборЗаписей();
Проводки.Отбор.Регистратор.Установить(Регистратор);
Проводки.Прочитать();

поле точно не пустое
почему не заполняется не понятно. эти субконто заполняются
Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты]        = Контрагент;
Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Договоры]            = Договор;
нужно явно указать из какого вида документов берется ссылка?
 
 
   Cyberhawk
 
1 - 30.04.19 - 21:54
Посмотри как это делается в ОМ БухгалтерскийУчет.УстановитьСубконто
   Adilgeriy
 
2 - 30.04.19 - 22:14
Процедура УстановитьСубконто(Проводка, ДтКт, ИмяСубконто, ЗначениеСубконто) Экспорт

    Если НЕ ЗначениеЗаполнено(ИмяСубконто) Тогда
        Возврат;
    КонецЕсли;
    
    СвойстваСчета = БухгалтерскийУчетПовтИсп.ПолучитьСвойстваСчета(Проводка["Счет"+ДтКт]);
    
    Если ТипЗнч(ИмяСубконто) = Тип("ПланВидовХарактеристикСсылка.ВидыСубконто") Тогда
        
        ВидСубконто = ИмяСубконто;
        
    ИначеЕсли ТипЗнч(ИмяСубконто) = Тип("Число") Тогда

        Если ИмяСубконто > СвойстваСчета.КоличествоСубконто Тогда
            Возврат;
        КонецЕсли;

        ВидСубконто = СвойстваСчета["ВидСубконто" + ИмяСубконто];

    Иначе

        ВидСубконто = ПланыВидовХарактеристик.ВидыСубконто[ИмяСубконто];

    КонецЕсли;
    
    Если СвойстваСчета.ВидСубконто1 = ВидСубконто Тогда
        НомерСубконто = 1;
    ИначеЕсли СвойстваСчета.ВидСубконто2 = ВидСубконто Тогда
        НомерСубконто = 2;
    ИначеЕсли СвойстваСчета.ВидСубконто3 = ВидСубконто Тогда
        НомерСубконто = 3;
    Иначе
        Возврат;
    КонецЕсли;
    Если ВидСубконто.ТипЗначения.СодержитТип(ТипЗнч(ЗначениеСубконто)) Тогда
        Проводка["ВидСубконто"+ДтКт+НомерСубконто] = ВидСубконто;
        Проводка["Субконто"+ДтКт+НомерСубконто]    = ЗначениеСубконто;
    КонецЕсли;
КонецПроцедуры// УстановитьСубконто()
   Adilgeriy
 
3 - 30.04.19 - 22:17
не вижу как работать с составным типом субконто
   Adilgeriy
 
4 - 01.05.19 - 03:31
Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.ДокументыРасчетов]    = Документы.ВводНачальныхОстатков;
    Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.ДокументыРасчетов]    = Регистратор.Ссылка;
   Adilgeriy
 
5 - 01.05.19 - 03:32
(4) так заполняется
   Adilgeriy
 
6 - 01.05.19 - 03:36
странно. первая строчка стала не обязательной. я походу какой то глюк поймал:(

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.