Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с открытием пдф документа в поле HTML

Проблема с  открытием пдф документа в поле HTML
Я
   asder117
 
30.04.19 - 14:06
Доброго времени суток. С наступающими.
Делаю собственную конфигурацию под свои нужды. появилась необходимость отображения документа (в будущем и других)  в поле HTML.
На толстом клиенте все отображается замышательно
когда открываю на web клиенте то ничего не отображается пишет "Не удалось загрузить PDF-документ."
в поле html передается ссылка <html><EMBED id='PDF' width=100% height=100% type="application/pdf" src="e1cib/data/Документ.РаботаСКандидатом.ДанныеРезюме?ref=b8fab42e991711d511e96b2bd81ec6db"></EMBED></html>

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    АдресМ = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"ДанныеРезюме");
    //#Если ВебКлиент Тогда
    //АдресМ = ПолучитьНавигационнуюСсылкуИнформационнойБазы()+"/#"+ ПолучитьНавигационнуюСсылку(Объект.Ссылка,"ДанныеРезюме");
    //#КонецЕсли
    //сообщить (АдресМ);
    #Если ВебКлиент Тогда
       Если Не ПодключитьРасширениеРаботыСФайлами() Тогда
        УстановитьРасширениеРаботыСФайлами();
        ПодключитьРасширениеРаботыСФайлами();
       КонецЕсли;
    #КонецЕсли
    Реквизит1 = "<html><EMBED id='PDF' width=100% height=100% type=""application/pdf"" src="""+АдресМ+"""></EMBED></html>";
    сообщить (Реквизит1);

    //Реквизит1 = АдресМ;
КонецПроцедуры
В чем может быть проблема, может кто сталкивался. Спасибо заранее.
 
 
   ptiz
 
1 - 30.04.19 - 14:09
(0) "на web клиенте" - браузер какой? IE не показывает?
   asder117
 
2 - 30.04.19 - 14:12
(1) hrom? в мозиле пустое поле, опера тоже пустое поле
   asder117
 
3 - 30.04.19 - 21:58
так никто с такой проблемой не встречался?
   Garykom
 
4 - 30.04.19 - 22:29
https://ru.wikipedia.org/wiki/PDF.js уже пробовал?
   asder117
 
5 - 30.04.19 - 23:13
(4) нет. а есть что-то по совместной работе скрипта и 1с?
   Garykom
 
6 - 30.04.19 - 23:15
(5) В старых версиях 1С работало вполне
   Garykom
 
7 - 30.04.19 - 23:17
В крайнем случае можно отдельно на сервере pdf в картинки или html конвертить и на веб-клиенте 1С показывать

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.