Вход | Регистрация
 

Вопрос по обработчику ОбработкаПолученияПредставления документа

Вопрос по обработчику ОбработкаПолученияПредставления документа
Я
   OldCondom
 
26.04.19 - 18:24
В чем смысл этого обработчика?
Читаю ИТС: С помощью данных обработчиков модуля менеджера объекта можно переопределить представление объекта информационной базы, которое выводится в полях форм и в списках.

Написал в обработчике
СтандартнаяОбработка =  Ложь;
Представление = Данные.своеПоле;

И... и ничего. В списке выводится именно код. В отчете тоже код документа.
Есть задача по смене стандартного номера документов, хотел сделать отдельное поле и не трогать типовые механизмы, но вот что-то не выходит.
 
 
   OldCondom
 
1 - 26.04.19 - 18:36
Полный код

Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    
    
    Представление = Данные.моеполе;
    СтандартнаяОбработка = Ложь;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    
    
    Поля.Добавить("моеполе");
    СтандартнаяОбработка = Ложь;
    
КонецПроцедуры

Отладчик показывает, что все ок. В пользовательском варианте - не ок.
типовая ЗУП последняя версия
   hhhh
 
2 - 26.04.19 - 19:20
(1) Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    
    
    Поля.Добавить("моеполе");
    
КонецПроцедуры
   OldCondom
 
3 - 26.04.19 - 19:28
Хм, точно. Дома посмотрю, спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.