Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Удаление записи в регистре сведений.

Удаление записи в регистре сведений.
Я
   zvonky
 
26.04.19 - 18:15
Помогите разобраться. Есть код в ПередЗаписью документа:

    Если ПометкаУдаления тогда
        выб = РегистрыСведений.Доставка.Выбрать( новый Структура("Основание",Ссылка));
        пока выб.Следующий() цикл
            выб.ПолучитьМенеджерЗаписи().Удалить();
        КонецЦикла;

            выб2 = РегистрыСведений.СтруктураПодчинённости.Выбрать( новый Структура("Подчиненный", Ссылка));
        Пока выб2.Следующий() Цикл
            выб2.ПолучитьМенеджерЗаписи().Удалить();
        КонецЦикла;
    КонецЕсли;    

Оба регистра непериодические, независимые. В первом случае одно измерение у регистра - "Основание", все отрабатывает, запись удаляется. Во втором случае измерений 2, запись находится(проверял в отладчике), но не удаляется. Почему?
 
 
   Alres
 
1 - 26.04.19 - 18:27
РегистрСведенийМенеджерЗаписи.<Имя регистра сведений> (InformationRegisterRecordManager.<Имя регистра сведений>)
Удалить (Delete)
Синтаксис:

Удалить()
Описание:

Удаляет запись из набора записей с установленными значениями ключевых полей.

Очевидно не установил значения ключевых полей
   zvonky
 
2 - 26.04.19 - 19:05
Но запись находиться. Причём забыл добавить, пробовал через СоздатьНаборЗаписей/МенеджерЗаписи, установив для отбора значения обоих измерений, так же запись находится, но удалить не могу.
   palsergeich
 
3 - 26.04.19 - 20:58
(2) Код покажи, там есть ньюанс
   kokstik
 
4 - 27.04.19 - 00:18
(2) Попробуй через набор записей работать.
Это будет быстрее чем по одной записи в цикле перебирать. Особенно если записей много.

Создаешь набор записей, устанавливаешь отборы, а потом:
НаборЗаписей.Прочитать();
НаборЗаписей.Очистить();      
НаборЗаписей.Записать();
   Chameleon1980
 
5 - 27.04.19 - 05:52
только осторожнее с набором
не убей регистр
   Cyberhawk
 
6 - 27.04.19 - 08:02
(4) Первые две строки лишние
   zvonky
 
7 - 29.04.19 - 13:16
Всем спасибо. Забыл написать, решил проблему. А была она в том, что запись в регистр добавлялась в ПриЗаписи. То есть я ПередЗаписью ее удалял, а потом срабатывало ПриЗаписи и она создавалась заного - видимо перегрелся за неделю :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.