Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Редактирование ТОРГ 12

Редактирование ТОРГ 12
Я
   Mahazbek
 
25.04.19 - 15:23
Народ, здравствуйте! Выручайте! // очередной начинающий суперодинэсник.
Платформа 8.3.13.1644, УСХП 1.3 (1.3.120.1)

Нужно в имеющуюся ТОРГ 12 добавить новые поля:

1. Вес бетона на м3 (из справочника), то есть его плотность
2. Объем реализации в м3 (с округлением до 1 знака после запятой)
3. Цена за 1 м3 в руб.коп.

В номенклатуре, в единицах измерения, указано - "по классификатору" м3, "наименование" м3, "коэффициент" 1. Продавался по метрам кубическим. Хотят видеть и вес.
Есть реквизит "Вес(кг)", там, как я понимаю, и нужно указать?
Но...

Как вывести в печатную форму? Запрос, установка параметров?
//Поля в макете-то я добавил, это самое сложное. Осталось самое простое )))) humour
 
 
   Mahazbek
 
1 - 25.04.19 - 15:31
   Mahazbek
 
2 - 26.04.19 - 08:41
Подскажите, пожалуйста. Основное - это как вывести единицу измерения. А остальное, думаю, разберусь.
   Mahazbek
 
3 - 15.05.19 - 14:55
Продолжаю ветку )

Запрос = Новый Запрос;
    Запрос.Текст =   "ВЫБРАТЬ
                     |    РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Вес КАК ЕдиницаИзмеренияВес
                     |ИЗ
                     |    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                     |ГДЕ
                     |    РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Вес = &Вес
                     |
                     |СГРУППИРОВАТЬ ПО
                     |    РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Вес
                     |
                     |УПОРЯДОЧИТЬ ПО
                     |    ЕдиницаИзмеренияВес
                     |ИТОГИ ПО
                     |    ЕдиницаИзмеренияВес";
                    
                    Результат = Запрос.Выполнить();
                    ВыборкаДетальныеЗаписи = Результат.Выбрать();
                            
                     Макет.Параметры.Вес = ВыборкаДетальныеЗаписи.Вес;

Ошибка - Не задано значение параметра "Вес"
РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Вес = <<?>>&Вес

Спасибо всем, кто просто даже прочел.
   Mahazbek
 
4 - 15.05.19 - 14:58
Я полагаю, необходимо примерно следующее:
Запрос.УстановитьПараметр("Вес", и какой-то параметр, который не знаю с чем связан и где его брать);
   KILL_OFF_COBECTb
 
5 - 15.05.19 - 15:04
Результат = Запрос.Выполнить();
                    ВыборкаДетальныеЗаписи = Результат.Выбрать();
                      
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
                     Макет.Параметры.Вес = ВыборкаДетальныеЗаписи.Вес;
КонецЦикла;
   KILL_OFF_COBECTb
 
6 - 15.05.19 - 15:06
прошу прощения не заметил, НЕ ВыборкаДетальныеЗаписи.Вес; а ВыборкаДетальныеЗаписи.ЕдиницаИзмеренияВес; конечно же
и Запрос.УстановитьПараметр("Вес", Вес); не хватает.
   lodger
 
7 - 15.05.19 - 15:07
(3) запрос перепиши для начала.
чтобы начать понимать запросы - их надо пробовать исполнить.
делается это в Консоли запросов. поищи в интернете.
   KILL_OFF_COBECTb
 
8 - 15.05.19 - 15:13
(0) как я понял вообще тебе сначала надо найти основной запрос который формирует данные для печатной формы торг12, дописать в него нужный реквизит и в том цикле где заполняются параметры формы добавить еще твой параметр Вес
   Mahazbek
 
9 - 15.05.19 - 15:39
(8) KILL_OFF_COBECTb, Спасибо за растолкование сути! Я вручную дописал в строки основного запроса

ВЫБРАТЬ
    
|               ВложенныйЗапрос.ЕдиницаИзмерения.Вес                            КАК Вес,    
|        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Вес             КАК Вес,
|            NULL                                                            КАК Вес,

И вес появился!
   Mahazbek
 
10 - 15.05.19 - 15:41
(7)  lodger, запрос делал в конструкторе. А что с ним не так? Много лишнего или просто неправильный?
   Mahazbek
 
11 - 15.05.19 - 15:42
(6) Кстати, теперь это не понадобилось, Вес теперь подставляется без параметра ¯\_(ツ)_/¯
   KILL_OFF_COBECTb
 
12 - 15.05.19 - 15:56
(11) ну если ты имеешь ввиду что в печатной форме у тебя теперь подставляется, тогда наверное у тебя там есть что-то типа ОбластьМакета.Параметры.Заполнить(Выборка);
и автоматом заполняются параметры макета которые совпадают с именами в выборке. в макете ты параметр обозвал "Вес" и в тексте запросы ты указал синоним КАК  Вес, вот он и заполняется сам.
а если ты имеешь ввиду результат запроса, то тебе не надо параметром Вес в него передавать вообще, ведь как раз его то ты и хочешь получить. в основном запросе(для торг12) уже все нужные параметры давно указаны (ссылка на документ или что-то вроде...).
   Mahazbek
 
13 - 15.05.19 - 16:23
(12) Да, речь о выводе в печатную форму. Могу весь код выложить.
   Mahazbek
 
14 - 20.05.19 - 11:22
Что-то намудрил, теперь каждая позиция выводится на отдельную страницу. Подскажите, пожалуйста, где это находится в коде?

Картинка: http://www.picshare.ru/view/10060759/
   Mahazbek
 
15 - 20.05.19 - 11:23
Функция ПечатьТОРГ12()
    МассивОбъектов = Новый Массив;
    МассивОбъектов.Добавить(СсылкаНаОбъект);
    ОбъектыПечати = Новый СписокЗначений;
    БезУслуг = Истина;
    мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
    
    мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");
    ЕдиницаИзмеренияВеса = Константы.ЕдиницаИзмеренияВеса.Получить();
    
    ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
        ТоварКод = "Артикул";
    Иначе
        ТоварКод = "Код";
    КонецЕсли;
    
    ТекстЗапросаШапка = "ВЫБРАТЬ
    |    Номер,
    |    Дата КАК ДатаДокумента,
    |    РеализацияТоваровУслуг.Организация,
    |    РеализацияТоваровУслуг.Организация КАК ЮрФизЛицо,
    |    РеализацияТоваровУслуг.Организация КАК Поставщик,
    |    РеализацияТоваровУслуг.Организация КАК Контрагент,
    |    РеализацияТоваровУслуг.Организация КАК Руководители,
    |    АдресДоставки КАК АдресДоставки,
    |    ВЫБОР КОГДА Грузополучатель = &ПустойКонтрагент
    |          ТОГДА Контрагент
    |          ИНАЧЕ Грузополучатель КОНЕЦ КАК Грузополучатель,
    |    ВЫБОР КОГДА Грузоотправитель = &ПустойКонтрагент
    |          ТОГДА РеализацияТоваровУслуг.Организация
    |          ИНАЧЕ Грузоотправитель КОНЕЦ КАК Грузоотправитель,
    |    БанковскийСчетОрганизации КАК БанковскийСчет,
    |    Контрагент КАК Покупатель,
    |    Контрагент КАК Плательщик,
    |    Сделка,
    |    ДоговорКонтрагента.Ссылка  КАК Основание,
    |    ДоговорКонтрагента.ВедениеВзаиморасчетов КАК ВедениеВзаиморасчетов,
    |    ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
    |    ПРЕДСТАВЛЕНИЕ(
    |    ВЫБОР    КОГДА РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете
    |            ТОГДА ЕСТЬNULL(ТаблицаСоответствиеОрганизации.ПодразделениеОрганизации, """")
    |            ИНАЧЕ РеализацияТоваровУслуг.Подразделение
    |    КОНЕЦ) КАК ПредставлениеПодразделения,
    |    ВЫБОР    КОГДА РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете
    |            ТОГДА ЕСТЬNULL(ТаблицаСоответствиеОрганизации.ПодразделениеОрганизации, """")
    |            ИНАЧЕ РеализацияТоваровУслуг.Подразделение
    |    КОНЕЦ КАК Подразделение,
    |    ВалютаДокумента,
    |    КурсВзаиморасчетов      КАК Курс,
    |    КратностьВзаиморасчетов КАК Кратность,
    |    УчитыватьНДС,
    |    СуммаВключаетНДС,
    |    ОтпускРазрешил,
    |    ОтпускПроизвел,
    |    ДоверенностьНомер,
    |    ДоверенностьДата,
    |    ДоверенностьВыдана,
    |    ДоверенностьЧерезКого
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |    РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |ПО
    |    ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |(
    |    ВЫБРАТЬ
    |        СоответсвиеПодразделений.Подразделение,
    |        СоответсвиеПодразделений.Организация,
    |        МИНИМУМ(СоответсвиеПодразделений.ПодразделениеОрганизации) КАК ПодразделениеОрганизации,
    |        МАКСИМУМ(СоответсвиеПодразделений.ПодразделениеОрганизации) КАК ПодразделениеОрг
    |    ИЗ
    |        РегистрСведений.СоответствиеПодразделенийИПодразделенийОрганизаций КАК СоответсвиеПодразделений
    |    ГДЕ
    |        Подразделение = &Подразделение
    |        И Организация = &Организация
    |        И Организация <> ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
    |        И Подразделение <> ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)
    |    СГРУППИРОВАТЬ ПО
    |        Подразделение,
    |        Организация
    |    ИМЕЮЩИЕ
    |        КОЛИЧЕСТВО(*) = 1
    |) ТаблицаСоответствиеОрганизации
    |ПО
    |    ТаблицаСоответствиеОрганизации.Подразделение = РеализацияТоваровУслуг.Подразделение
    |    И ТаблицаСоответствиеОрганизации.Организация = РеализацияТоваровУслуг.Организация
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |";

    ТекстЗапросаТовары =     "ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура                                  КАК Номенклатура,
    |    ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
    |    ВложенныйЗапрос.Номенклатура." + ТоварКод + "                 КАК ТоварКод,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление                КАК БазоваяЕдиницаНаименование,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Вес                КАК Вес,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код  КАК БазоваяЕдиницаКодПоОКЕИ,
    |    ВложенныйЗапрос.ЕдиницаИзмерения     КАК ЕдиницаИзмерения,
    |    ВложенныйЗапрос.ЕдиницаИзмеренияМест.Представление            КАК ВидУпаковки,
    |    ВложенныйЗапрос.КоэффициентМест / ВложенныйЗапрос.Коэффициент КАК КоличествоВОдномМесте,
    |    ВЫБОР
    |        КОГДА ВложенныйЗапрос.КоличествоМест > 0 ТОГДА ВложенныйЗапрос.КоличествоМест * ВложенныйЗапрос.ЕдиницаИзмеренияМест.Вес
    |        ИНАЧЕ ВложенныйЗапрос.Количество * ВложенныйЗапрос.ЕдиницаИзмерения.Вес
    |    КОНЕЦ КАК МассаБрутто,
    |    ВложенныйЗапрос.Характеристика       КАК Характеристика,
    |    ВложенныйЗапрос.Серия                КАК Серия,
    |    ВложенныйЗапрос.СтавкаНДС            КАК СтавкаНДС,
    |    ВложенныйЗапрос.Цена                 КАК Цена,
    |    ВЫБОР
    |        КОГДА((ВложенныйЗапрос.ПроцентСкидкиНаценки = 0) И 
    |              (ВложенныйЗапрос.ПроцентАвтоматическихСкидок = 0))
    |    ТОГДА ЛОЖЬ
    |    ИНАЧЕ Истина
    |    КОНЕЦ                                КАК ЕстьСкидкиПоСтроке,
    |    ВложенныйЗапрос.Количество           КАК Количество,
    |    ВложенныйЗапрос.КоличествоМест       КАК КоличествоМест,
    |    ВложенныйЗапрос.Сумма                КАК Сумма,
    |    ВложенныйЗапрос.СуммаНДС             КАК СуммаНДС,
    |    ВложенныйЗапрос.НомерСтроки          КАК НомерСтроки,
    |    ВложенныйЗапрос.Метка                КАК Метка
    |ИЗ
    |
    |    (
    |    ВЫБРАТЬ
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Вес             КАК Вес,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Коэффициент     КАК КоэффициентМест,
    |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры           КАК Характеристика,
    |        РеализацияТоваровУслуг.СерияНоменклатуры                    КАК Серия,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность            КАК Цена,
    |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
    |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок,
    |        СУММА(РеализацияТоваровУслуг.Количество)                    КАК Количество,
    |        СУММА(РеализацияТоваровУслуг.КоличествоМест)                КАК КоличествоМест,
    |        СУММА(РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность) КАК Сумма,
    |        СУММА(РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,
    |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)                 КАК НомерСтроки,
    |        0.00                                                        КАК Метка
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |    ГДЕ
    |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры,
    |        РеализацияТоваровУслуг.СерияНоменклатуры,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена,
    |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
    |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок
    |    ) КАК ВложенныйЗапрос
    |";
    СтрокаВыборкиПоляСодержания = ОбработкаТабличныхЧастей.ПолучитьЧастьЗапросаДляВыбораСодержания("РеализацияТоваровУслуг");
    ТекстЗапросаТовары = ТекстЗапросаТовары + "
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                  КАК Номенклатура,
    |    " + СтрокаВыборкиПоляСодержания + "                  КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + " КАК ТоварКод,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК БазоваяЕдиницаНаименование,
    |    NULL                                                 КАК Вес,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаИзмерения,
    |    NULL                                                 КАК ВидУпаковки,
    |    NULL                                                 КАК КоличествоВОдномМесте,
    |    0.00                                                 КАК МассаБрутто,
    |    NULL                                                 КАК Характеристика,
    |    NULL                                                 КАК Серия,
    |    РеализацияТоваровУслуг.СтавкаНДС                     КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность     КАК Цена,
    |    ВЫБОР    КОГДА(РеализацияТоваровУслуг.ПроцентСкидкиНаценки = 0.00)
    |            ТОГДА ЛОЖЬ
    |            ИНАЧЕ Истина
    |    КОНЕЦ                                                КАК ЕстьСкидкиПоСтроке,
    |    РеализацияТоваровУслуг.Количество                    КАК Количество,
    |    NULL                                                 КАК КоличествоМест,
    |    РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность КАК Сумма,
    |    РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                   КАК НомерСтроки,
    |    1.00                                                 КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |";
    ТекстЗапросаТовары = ТекстЗапросаТовары + "
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                    КАК Номенклатура,
    |    ВЫРАЗИТЬ(РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + "   КАК ТоварКод,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление               КАК БазоваяЕдиницаНаименование,
    |    NULL                                                 КАК Вес,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков                             КАК ЕдиницаИзмерения,
    |    NULL                                                  КАК ВидУпаковки,
    |    NULL                                                  КАК КоличествоВОдномМесте,
    |    РеализацияТоваровУслуг.Количество * РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Вес КАК МассаБрутто,
    |    NULL                                                  КАК Характеристика,
    |    NULL                                                  КАК Серия,
    |    ""Без НДС""                                           КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность      КАК Цена,
    |    Ложь                                                  КАК ЕстьСкидкиПоСтроке,
    |    РеализацияТоваровУслуг.Количество                     КАК Количество,
    |    NULL                                                  КАК КоличествоМест,
    |    РеализацияТоваровУслуг.Сумма * &Курс / &Кратность     КАК Сумма,
    |    0.00                                                  КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                    КАК НомерСтроки,
    |    2.00                                                  КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |
    |УПОРЯДОЧИТЬ ПО Метка ВОЗР, НомерСтроки ВОЗР
    |
    |";
    
    ТабДокумент  = Новый ТабличныйДокумент;
    
    // Зададим параметры печатной формы по умолчанию

    ТабДокумент.РазмерКолонтитулаСверху = 0;
    ТабДокумент.РазмерКолонтитулаСнизу  = 0;
    ТабДокумент.АвтоМасштаб             = Истина;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;
    
    // Восстановим установленные пользователем параметры печатной формы

    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12";
    
    Макет = ПолучитьМакет("ТОРГ12");
    
    ПервыйДокумент = Истина;
    
    Для каждого Ссылка Из МассивОбъектов Цикл
        
        //Если Не ПервыйДокумент Тогда

        //    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();

        //КонецЕсли;

        ПервыйДокумент = Ложь;
        
        НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;

        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("ДатаСреза",          Ссылка.Дата);
        Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Ссылка.Склад);
        Запрос.УстановитьПараметр("ТекущийДокумент",    Ссылка);
        Запрос.УстановитьПараметр("ПустойКонтрагент",   Справочники.Контрагенты.ПустаяСсылка());
        Запрос.УстановитьПараметр("Организация",        Ссылка.Организация);
        Запрос.УстановитьПараметр("Подразделение",      Ссылка.Подразделение);

        Запрос.Текст = ТекстЗапросаШапка;
        
        Шапка = Запрос.Выполнить().Выбрать();
        Шапка.Следующий();
        
        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("ТекущийДокумент", Ссылка);
        
        Запрос.УстановитьПараметр("Курс",            ЗаполнениеДокументов.КурсДокумента(Ссылка, мВалютаРегламентированногоУчета));
        Запрос.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(Ссылка, мВалютаРегламентированногоУчета));
        Запрос.Текст = ТекстЗапросаТовары;
        ЗапросТовары = Запрос.Выполнить().Выгрузить();
        
        
        
        // Вычислим курс документа для печати

        Если Ссылка.ВалютаДокумента <> мВалютаРегламентированногоУчета
           И (Ссылка.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах
           ИЛИ Ссылка.Дата >= '20090101000000') Тогда
            
            ЗапросКурсАванса = Новый Запрос;
            ЗапросКурсАванса.УстановитьПараметр("ДокументСсылка", Ссылка);
            ЗапросКурсАванса.Текст =
            "ВЫБРАТЬ
            |    Док.СуммаВзаиморасчетов,
            |    Док.СуммаРегл
            |ИЗ 
            |    Документ.РеализацияТоваровУслуг.ДокументыРасчетовСКонтрагентом КАК Док
            |ГДЕ Док.Ссылка = &ДокументСсылка
            |ИТОГИ СУММА(СуммаВзаиморасчетов), СУММА(СуммаРегл) ПО ОБЩИЕ";
            
            Выборка = ЗапросКурсАванса.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
            Если Выборка.Следующий() Тогда
                ВыборкаСуммаВзаиморасчетов = Выборка.СуммаВзаиморасчетов;
                ВыборкаСуммаРегл           = Выборка.СуммаРегл;
            Иначе
                ВыборкаСуммаВзаиморасчетов = 0;
                ВыборкаСуммаРегл           = 0;
            КонецЕсли;
            
            РасчетСуммыНДСПоСтавке =  УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.ДатаДокумента);
            
            СуммаВзаиморасчетов = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(УчетНДС.ПолучитьСуммуДокументаСНДС(Ссылка),
                                                                Ссылка.ВалютаДокумента, Ссылка.ДоговорКонтрагента.ВалютаВзаиморасчетов,
                                                                ЗаполнениеДокументов.КурсДокумента(Ссылка, мВалютаРегламентированногоУчета), Ссылка.КурсВзаиморасчетов,
                                                                ЗаполнениеДокументов.КратностьДокумента(Ссылка, мВалютаРегламентированногоУчета), Ссылка.КратностьВзаиморасчетов);
            НеоплаченнаяСумма = СуммаВзаиморасчетов - ВыборкаСуммаВзаиморасчетов;
            
            НеоплаченнаяСуммаРегл = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(НеоплаченнаяСумма,
                                                                Ссылка.ДоговорКонтрагента.ВалютаВзаиморасчетов, мВалютаРегламентированногоУчета,
                                                                Ссылка.КурсВзаиморасчетов, 1,
                                                                Ссылка.КратностьВзаиморасчетов, 1);
                                                                
            СуммаРегл = ВыборкаСуммаРегл + НеоплаченнаяСуммаРегл;
            
            Если НЕ СуммаРегл = 0 Тогда
                
                ЗапросТовары.Колонки.Добавить("СуммаБезНДС");
                МассивРаспределения = Новый Массив;
                
                Для Каждого СтрокаТовар Из ЗапросТовары Цикл
                    Если (СтрокаТовар.Метка = 2) Тогда
                        Продолжить;
                    КонецЕсли;
                    СуммаСНДС = СтрокаТовар.Сумма + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);
                    СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;
                    МассивРаспределения.Добавить(СуммаСНДС);
                    СтрокаТовар.СуммаБезНДС = СуммаБезНДС;
                КонецЦикла;
                
                ЗапросТовары.Колонки.Добавить("СуммаРублевая");
                УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаРегл, ЗапросТовары, "СуммаРублевая");
                
                Для Каждого СтрокаТовар Из ЗапросТовары Цикл
                    Если (СтрокаТовар.Метка = 2) Тогда
                        Продолжить;
                    КонецЕсли;
                    Если РасчетСуммыНДСПоСтавке Тогда
                        //Выделение суммы НДС, Расчет суммы без НДС

                        ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);
                        СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));
                        СтрокаТовар.Сумма = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;
                    Иначе
                        МассивРаспределения.Очистить();
                        МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);
                        МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);
                        МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);
                        Если МассивРаспределенныхСумм <> Неопределено Тогда
                            СтрокаТовар.Сумма = МассивРаспределенныхСумм[0];
                            СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];
                        КонецЕсли;
                    КонецЕсли;
                    
                    Если Шапка.СуммаВключаетНДС Тогда
                        СтрокаТовар.Сумма = СтрокаТовар.Сумма+СтрокаТовар.СуммаНДС;
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЕсли;
     
        // Выводим общие реквизиты шапки

        СведенияОПоставщике       = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.ЮрФизЛицо,        Шапка.ДатаДокумента,, Шапка.БанковскийСчет);
        СведенияОПокупателе       = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Покупатель,       Шапка.ДатаДокумента);
        СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Грузополучатель,  Шапка.ДатаДокумента);
        СведенияОГрузоотправитель = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);
        
        ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
        ОбластьМакета.Параметры.Заполнить(Шапка);
        ОбластьМакета.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка);
        ОбластьМакета.Параметры.ДатаДокумента  = Шапка.ДатаДокумента;
        
        Если Шапка.ЮрФизЛицо = Шапка.Грузоотправитель Тогда
            ОбластьМакета.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОПоставщике);
        Иначе
            ОбластьМакета.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");
        КонецЕсли;
        
        ОбластьМакета.Параметры.ПредставлениеПодразделения = Шапка.Подразделение;
        
        
        Если СокрЛП(Шапка.АдресДоставки) <> "" Тогда
            ОбластьМакета.Параметры.АдресДоставки = УправлениеКонтактнойИнформацией.ПолучитьПредставлениеАдресаПоСтрока(Шапка.АдресДоставки);
            ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ИНН") + ", "
                                                                    + УправлениеКонтактнойИнформацией.ПолучитьПредставлениеАдресаПоСтрока(Шапка.АдресДоставки) + ", "
                                                                    + ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузополучателе, "Телефоны,НомерСчета,Банк,БИК,КоррСчет");
        Иначе
            ОбластьМакета.Параметры.АдресДоставки = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузополучателе, "ФактическийАдрес");
            ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");
        КонецЕсли;
        
        ОбластьМакета.Параметры.ПредставлениеПоставщика  = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОПоставщике);
        ОбластьМакета.Параметры.ПредставлениеПлательщика = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОПокупателе);
        
        Если Шапка.ВедениеВзаиморасчетов <> Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоЗаказам
            И Шапка.ВедениеВзаиморасчетов <> Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоСчетам Тогда
            ОбластьМакета.Параметры.Основание = Шапка.Основание.Наименование;
        Иначе
            Если ЗначениеЗаполнено(Шапка.Сделка) Тогда
                ОбластьМакета.Параметры.Основание = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка.Сделка, Строка(Шапка.Сделка.Метаданные().Синоним));
            КонецЕсли;
        КонецЕсли;
        //ОбластьМакета.Параметры.Основание = "К-03906/13";

        // Выводим всевозможные коды

        ОбластьМакета.Параметры.ОрганизацияПоОКПО     = СведенияОГрузоотправитель.КодПоОКПО;
        ОбластьМакета.Параметры.ВидДеятельностиПоОКДП = "";
        ОбластьМакета.Параметры.ГрузополучательПоОКПО = СведенияОГрузополучателе.КодПоОКПО;
        ОбластьМакета.Параметры.ПоставщикПоОКПО       = СведенияОПоставщике.КодПоОКПО;
        ОбластьМакета.Параметры.ПлательщикПоОКПО      = СведенияОПокупателе.КодПоОКПО;
        ОбластьМакета.Параметры.ОснованиеНомер        = Шапка.Основание.Номер;
        ОбластьМакета.Параметры.ОснованиеДата         = Шапка.Основание.Дата;
        ОбластьМакета.Параметры.ТранспортнаяНакладнаяНомер = "";
        ОбластьМакета.Параметры.ТранспортнаяНакладнаяДата  = "";
        
        ТабДокумент.Вывести(ОбластьМакета);
        
        НомерСтраницы   = 1;
        
        НомерСтроки     = 0;
        КоличествоСтрок = ЗапросТовары.Количество();
        
        Если БезУслуг Тогда
            Для Инд = 1 По КоличествоСтрок Цикл
                СтрокаТовара = ЗапросТовары[КоличествоСтрок - Инд];
                Если (СтрокаТовара.Метка = 1) Тогда
                    ЗапросТовары.Удалить(СтрокаТовара);
                КонецЕсли;
            КонецЦикла;
            
            КоличествоСтрок = ЗапросТовары.Количество();        
        КонецЕсли;
        
                
        
        // инициализация итогов по странице

        ИтогоМассаБруттоНаСтранице = 0;
        ИтогоМестНаСтранице        = 0;
        ИтогоКоличествоНаСтранице  = 0;
        ИтогоСуммаНаСтранице       = 0;
        ИтогоНДСНаСтранице         = 0;
        ИтогоСуммаСНДСНаСтранице   = 0;
        
        // инициализация итогов по документу

        ИтогоМассаБрутто = 0;
        ИтогоМест        = 0;
        ИтогоКоличество  = 0;
        ИтогоСуммаСНДС   = 0;
        ИтогоСумма       = 0;
        ИтогоНДС         = 0;
        
        // Создаем массив для проверки вывода

        МассивВыводимыхОбластей = Новый Массив;
        
        // Выводим многострочную часть докмента

        ЗаголовокТаблицы        = Макет.ПолучитьОбласть("ЗаголовокТаб");
        ОбластьМакета           = Макет.ПолучитьОбласть("Строка");
        ОбластьИтоговПоСтранице = Макет.ПолучитьОбласть("ИтогоПоСтранице");
        МакетПодвала             = ПолучитьМакет("ТОРГ12");
        ОбластьПодвала          = МакетПодвала.ПолучитьОбласть("Подвал");
        ОбластьМакетаВсего      = Макет.ПолучитьОбласть("Всего");
        КоличествоНеттоПрописью = 0;
        Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл
            
            Если НЕ ЗначениеЗаполнено(ВыборкаСтрок.Номенклатура) Тогда
                Продолжить;
            КонецЕсли;
            
            НомерСтроки = НомерСтроки + 1;
            
            ОбластьМакета.Параметры.Заполнить(ВыборкаСтрок);
            ОбластьМакета.Параметры.Номер             = ЗапросТовары.Индекс(ВыборкаСтрок) + 1;
            ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрок.ТоварНаименование)
            + ПредставлениеСерий(ВыборкаСтрок)
            + ?(ВыборкаСтрок.Метка = 2, " (возвратная тара)", "");
            
            Если НЕ ЗначениеЗаполнено(ЕдиницаИзмеренияВеса) Тогда
                МассаБрутто = 0;
            Иначе
                МассаБрутто = ВыборкаСтрок.МассаБрутто;
                МассаБрутто = ?(МассаБрутто <> Неопределено И МассаБрутто <> NULL, МассаБрутто, 0);
            КонецЕсли;
            
            Мест        = ВыборкаСтрок.КоличествоМест;
            Мест        = ?(Мест <> Неопределено И Мест <> NULL, Мест, 0);
            
            Количество  = ВыборкаСтрок.Количество;
            Если СокрЛП(ВыборкаСтрок.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код) = "166" 
                 ИЛИ СокрЛП(ВыборкаСтрок.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код) = "168" Тогда
                 КоличествоНеттоПрописью = КоличествоНеттоПрописью + Количество * ВыборкаСтрок.ЕдиницаИзмерения.Коэффициент;
            КонецЕсли;
            СуммаСНДС   = Окр((ВыборкаСтрок.Сумма + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС)), 2);
            СуммаНДС    = Окр(ВыборкаСтрок.СуммаНДС, 2);
            СуммаБезНДС = СуммаСНДС  - СуммаНДС;
            
            ОбластьМакета.Параметры.МассаБрутто = МассаБрутто;
            ОбластьМакета.Параметры.СуммаСНДС   = СуммаСНДС;
            ОбластьМакета.Параметры.СуммаНДС    = СуммаНДС;
            ОбластьМакета.Параметры.СтавкаНДС   = ВыборкаСтрок.СтавкаНДС;
            ОбластьМакета.Параметры.СуммаБезНДС = СуммаБезНДС;
            
            Если Шапка.СуммаВключаетНДС
                Или ВыборкаСтрок.ЕстьСкидкиПоСтроке Тогда
                ОбластьМакета.Параметры.Цена = ?(Количество = 0, 0, СуммаБезНДС / Количество);
            Иначе
                ОбластьМакета.Параметры.Цена = ВыборкаСтрок.Цена;
            КонецЕсли;
            
            
            ///////////////////////////////////////////////////////  АРТЕМ

            
            Вес = ВыборкаСтрок.ЕдиницаИзмерения.Вес;
             
             Если Вес >= 1 Тогда
             Объем = Вес * Количество;
             ОбластьМакета.Параметры.Объем = Объем;     
            КонецЕсли; 
            
                        
            ///////////////////////////////////////////////////////

            
            Если НомерСтроки = 1 Тогда// первая срока

                
                ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы; 
                ТабДокумент.Вывести(ЗаголовокТаблицы);
                
            Иначе
                
                МассивВыводимыхОбластей.Очистить();
                МассивВыводимыхОбластей.Добавить(ОбластьМакета);
                МассивВыводимыхОбластей.Добавить(ОбластьИтоговПоСтранице);
                Если НомерСтроки = КоличествоСтрок Тогда
                    МассивВыводимыхОбластей.Добавить(ОбластьПодвала);
                    МассивВыводимыхОбластей.Добавить(ОбластьМакетаВсего);
                КонецЕсли;        
                
                Если НомерСтроки <> 1 И НЕ ПроверитьВыводТабличногоДокумента(ТабДокумент, МассивВыводимыхОбластей) Тогда
                    
                    ОбластьИтоговПоСтранице.Параметры.ИтогМассаБруттоПоСтранице = ИтогоМассаБруттоНаСтранице;
                    ОбластьИтоговПоСтранице.Параметры.ИтогМестПоСтранице        = ИтогоМестНаСтранице;
                    ОбластьИтоговПоСтранице.Параметры.ИтогКоличествоПоСтранице  = ИтогоКоличествоНаСтранице;
                    ОбластьИтоговПоСтранице.Параметры.ИтогСуммыПоСтранице       = ИтогоСуммаНаСтранице;
                    ОбластьИтоговПоСтранице.Параметры.ИтогНДСПоСтранице         = ИтогоНДСНаСтранице;
                    ОбластьИтоговПоСтранице.Параметры.ИтогСуммыСНДСПоСтранице   = ИтогоСуммаСНДСНаСтранице;
                    
                    ТабДокумент.Вывести(ОбластьИтоговПоСтранице);
                    
                    // очистим итоги по странице

                    ИтогоМассаБруттоНаСтранице = 0;
                    ИтогоМестНаСтранице        = 0;
                    ИтогоКоличествоНаСтранице  = 0;
                    ИтогоСуммаНаСтранице       = 0;
                    ИтогоНДСНаСтранице         = 0;
                    ИтогоСуммаСНДСНаСтранице   = 0;
                    
                    НомерСтраницы = НомерСтраницы + 1;
                    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                    ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;
                    ТабДокумент.Вывести(ЗаголовокТаблицы);
                    
                КонецЕсли;
                                 
                       //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


    
                 
                 
                 
КонецЕсли;

            
                    
                                                
                     


             Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗначенияСвойствОбъектов.Значение
        |ИЗ
        |    РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
        |ГДЕ
        |    ЗначенияСвойствОбъектов.Объект = &Объект
        |    И ЗначенияСвойствОбъектов.Свойство = &Свойство";

    Запрос.УстановитьПараметр("Объект", ВыборкаСтрок.Характеристика);
    Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоКоду("00000000119"));

    Результат = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СтороннийАртикул = ВыборкаДетальныеЗаписи.Значение;
    КонецЦикла;
    Если ЗначениеЗаполнено(СтороннийАртикул) тогда
    ОбластьМакета.Параметры.ТоварКод = СтороннийАртикул;
    КонецЕсли;
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


            ТабДокумент.Вывести(ОбластьМакета);
            
            // увеличим итоги по странице

            ИтогоМассаБруттоНаСтранице = ИтогоМассаБруттоНаСтранице + МассаБрутто;
            ИтогоМестНаСтранице        = ИтогоМестНаСтранице        + Мест;
            ИтогоКоличествоНаСтранице  = ИтогоКоличествоНаСтранице  + Количество;
            ИтогоСуммаНаСтранице       = ИтогоСуммаНаСтранице       + СуммаБезНДС;
            ИтогоНДСНаСтранице         = ИтогоНДСНаСтранице         + СуммаНДС;
            ИтогоСуммаСНДСНаСтранице   = ИтогоСуммаСНДСНаСтранице   + СуммаСНДС;
            
            // увеличим итоги по дукументу

            ИтогоМассаБрутто = ИтогоМассаБрутто + МассаБрутто;
            ИтогоМест        = ИтогоМест        + Мест;
            ИтогоКоличество  = ИтогоКоличество  + Количество;
            ИтогоСумма       = ИтогоСумма       + СуммаБезНДС;
            ИтогоНДС         = ИтогоНДС         + СуммаНДС;
            ИтогоСуммаСНДС   = ИтогоСуммаСНДС   + СуммаСНДС;
            
        КонецЦикла;
        
        // Выводим итоги по последней странице

        ОбластьИтоговПоСтранице.Параметры.ИтогМассаБруттоПоСтранице = ИтогоМассаБруттоНаСтранице;
        ОбластьИтоговПоСтранице.Параметры.ИтогМестПоСтранице        = ИтогоМестНаСтранице;
        ОбластьИтоговПоСтранице.Параметры.ИтогКоличествоПоСтранице  = ИтогоКоличествоНаСтранице;
        ОбластьИтоговПоСтранице.Параметры.ИтогСуммыПоСтранице       = ИтогоСуммаНаСтранице;
        ОбластьИтоговПоСтранице.Параметры.ИтогНДСПоСтранице         = ИтогоНДСНаСтранице;
        ОбластьИтоговПоСтранице.Параметры.ИтогСуммыСНДСПоСтранице   = ИтогоСуммаСНДСНаСтранице;
        
        ТабДокумент.Вывести(ОбластьИтоговПоСтранице);
        
        // Выводим итоги по документу в целом

        ОбластьМакетаВсего.Параметры.ИтогМассаБрутто = ИтогоМассаБрутто;
        ОбластьМакетаВсего.Параметры.ИтогМест        = ИтогоМест;
        ОбластьМакетаВсего.Параметры.ИтогКоличество  = ИтогоКоличество;
        ОбластьМакетаВсего.Параметры.ИтогСуммы       = ИтогоСумма;
        ОбластьМакетаВсего.Параметры.ИтогНДС         = ИтогоНДС;
        ОбластьМакетаВсего.Параметры.ИтогСуммыСНДС   = ИтогоСуммаСНДС;
        
        ТабДокумент.Вывести(ОбластьМакетаВсего);
        
        // Выводим подвал документа

        ПолнаяДатаДокумента = Формат(Шапка.ДатаДокумента, "ДФ=""дд ММММ гггг """"года""""""");
        ДлинаСтроки = СтрДлина(ПолнаяДатаДокумента);
        ПервыйРазделитель = Найти(ПолнаяДатаДокумента," ");
        ВторойРазделитель = Найти(Прав(ПолнаяДатаДокумента,ДлинаСтроки-Пер
   Mahazbek
 
16 - 20.05.19 - 11:25
// Выводим подвал документа

        ПолнаяДатаДокумента = Формат(Шапка.ДатаДокумента, "ДФ=""дд ММММ гггг """"года""""""");
        ДлинаСтроки = СтрДлина(ПолнаяДатаДокумента);
        ПервыйРазделитель = Найти(ПолнаяДатаДокумента," ");
        ВторойРазделитель = Найти(Прав(ПолнаяДатаДокумента,ДлинаСтроки-ПервыйРазделитель)," ")+ПервыйРазделитель;
        ОбластьПодвала.Параметры.ДатаДокументаДень     = """"+Лев(ПолнаяДатаДокумента,ПервыйРазделитель-1)+"""";
        ОбластьПодвала.Параметры.ДатаДокументаМесяц    = Сред(ПолнаяДатаДокумента,ПервыйРазделитель+1,ВторойРазделитель-ПервыйРазделитель-1);
        ОбластьПодвала.Параметры.ДатаДокументаГод      = Прав(ПолнаяДатаДокумента,ДлинаСтроки-ВторойРазделитель);    
        
        Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Шапка.Руководители, Шапка.ДатаДокумента,);
        Руководитель = Руководители.Руководитель;
        Бухгалтер    = Руководители.ГлавныйБухгалтер;
        
        // Главный бухгалтер

        ОбластьПодвала.Параметры.ФИОГлавБухгалтера = Бухгалтер;
        
        // Отпуск товара разрешил

        Если НЕ ЗначениеЗаполнено(Шапка.ОтпускРазрешил) Тогда
            ФИООтпускРазрешил       = Руководитель;
            ДолжностьОтпускРазрешил = Руководители.РуководительДолжность;
        Иначе
            ФамилияИмяОтчествоФизЛица        = ФормированиеПечатныхФормСервер.ФамилияИмяОтчество(Шапка.ОтпускРазрешил, Шапка.ДатаДокумента);
            ПодразделениеДолжностьФизЛица    = ПолныеПрава.СведенияОСотруднике(Шапка.ОтпускРазрешил, Шапка.ДатаДокумента, Шапка.Организация);
            ФамилияИмяОтчествоОтпускРазрешил = ФамилияИмяОтчествоФизЛица.Фамилия + " " + ФамилияИмяОтчествоФизЛица.Имя + " " + ФамилияИмяОтчествоФизЛица.Отчество;
            ФИООтпускРазрешил                = ОбщегоНазначения.ФамилияИнициалыФизЛица(ФамилияИмяОтчествоОтпускРазрешил);
            ДолжностьОтпускРазрешил          = ПодразделениеДолжностьФизЛица.Должность;
        КонецЕсли;
        
        ОбластьПодвала.Параметры.ФИОРуководителя       = ФИООтпускРазрешил;
        ОбластьПодвала.Параметры.ДолжностьРуководителя = ДолжностьОтпускРазрешил;
        
        // Отпуск товара произвел

        Если НЕ ЗначениеЗаполнено(Шапка.ОтпускПроизвел) Тогда
            ФамилияИмяОтчествоФизЛица     = ФормированиеПечатныхФормСервер.ФамилияИмяОтчество(Шапка.ОтветственноеЛицо, Шапка.ДатаДокумента);
            ПодразделениеДолжностьФизЛица = ПолныеПрава.СведенияОСотруднике(Шапка.ОтветственноеЛицо, Шапка.ДатаДокумента, Шапка.Организация);
        Иначе
            ФамилияИмяОтчествоФизЛица     = ФормированиеПечатныхФормСервер.ФамилияИмяОтчество(Шапка.ОтпускПроизвел, Шапка.ДатаДокумента);
            ПодразделениеДолжностьФизЛица = ПолныеПрава.СведенияОСотруднике(Шапка.ОтпускПроизвел, Шапка.ДатаДокумента, Шапка.Организация);
        КонецЕсли;
        
        ФамилияИмяОтчествоОтпускПроизвел = ФамилияИмяОтчествоФизЛица.Фамилия + " " + ФамилияИмяОтчествоФизЛица.Имя + " " + ФамилияИмяОтчествоФизЛица.Отчество;
        ФИООтпускПроизвел                = ОбщегоНазначения.ФамилияИнициалыФизЛица(ФамилияИмяОтчествоОтпускПроизвел);
        ДолжностьОтпускПроизвел          = ПодразделениеДолжностьФизЛица.Должность;
        
        ОбластьПодвала.Параметры.ФИОКладовщика       = ФИООтпускПроизвел;
        ОбластьПодвала.Параметры.ДолжностьКладовщика = ДолжностьОтпускПроизвел;
        
        // Доверенность

        ОбластьПодвала.Параметры.ДоверенностьНомер     = Шапка.ДоверенностьНомер;
        ОбластьПодвала.Параметры.ДоверенностьДата      = Формат(Шапка.ДоверенностьДата, "ДФ='дд ММММ гггг'");
        ОбластьПодвала.Параметры.ДоверенностьВыдана    = Шапка.ДоверенностьВыдана;
        ОбластьПодвала.Параметры.ДоверенностьЧерезКого = Шапка.ДоверенностьЧерезКого;
        
        Если ЗначениеЗаполнено(ЕдиницаИзмеренияВеса) И ИтогоМассаБрутто > 0 Тогда
            ОбластьПодвала.Параметры.МассаГрузаПрописью = ЧислоПрописью(ИтогоМассаБрутто, ,",,,,,,,,0")+ " " +ЕдиницаИзмеренияВеса.Наименование + ".";
        КонецЕсли;
        
        Если ИтогоМест > 0 Тогда
            ОбластьПодвала.Параметры.ВсегоМестПрописью = ЧислоПрописью(ИтогоМест, ,",,,,,,,,0");
        КонецЕсли;
        
        ОбластьПодвала.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(КоличествоСтрок, ,",,,,,,,,0");
        КоличествоНеттоПрописью1 = ОбщегоНазначения.СформироватьСуммуПрописью(КоличествоНеттоПрописью, мВалютаРегламентированногоУчета);
        КоличествоНеттоПрописью = Лев(КоличествоНеттоПрописью1,(Найти(КоличествоНеттоПрописью1, "руб"))-1);
        ОбластьПодвала.Параметры.КоличествоНеттоПрописью = КоличествоНеттоПрописью + "килограмм";
        ОбластьПодвала.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(ИтогоСуммаСНДС, мВалютаРегламентированногоУчета);
        ТабДокумент.Вывести(ОбластьПодвала);
        ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, ОбъектыПечати, Ссылка);
    КонецЦикла;
    //ТабДокумент.Показать();

    Возврат ТабДокумент;
КонецФункции
   Джинн
 
17 - 20.05.19 - 11:27
Это что за бред?
Найти(КоличествоНеттоПрописью1, "руб") и КоличествоНеттоПрописью + "килограмм"
   Mahazbek
 
18 - 20.05.19 - 11:36
Это было уже ))
   Mahazbek
 
19 - 20.05.19 - 11:37
(14) Нашел:

//Иначе

            //    

            //    МассивВыводимыхОбластей.Очистить();

            //    МассивВыводимыхОбластей.Добавить(ОбластьМакета);

            //    МассивВыводимыхОбластей.Добавить(ОбластьИтоговПоСтранице);

            //    Если НомерСтроки = КоличествоСтрок Тогда

            //        МассивВыводимыхОбластей.Добавить(ОбластьПодвала);

            //        МассивВыводимыхОбластей.Добавить(ОбластьМакетаВсего);

            //    КонецЕсли;        

            //    

            //    Если НомерСтроки <> 1 И НЕ ПроверитьВыводТабличногоДокумента(ТабДокумент, МассивВыводимыхОбластей) Тогда

            //        

            //        ОбластьИтоговПоСтранице.Параметры.ИтогМассаБруттоПоСтранице = ИтогоМассаБруттоНаСтранице;

            //        ОбластьИтоговПоСтранице.Параметры.ИтогМестПоСтранице        = ИтогоМестНаСтранице;

            //        ОбластьИтоговПоСтранице.Параметры.ИтогКоличествоПоСтранице  = ИтогоКоличествоНаСтранице;

            //        ОбластьИтоговПоСтранице.Параметры.ИтогСуммыПоСтранице       = ИтогоСуммаНаСтранице;

            //        ОбластьИтоговПоСтранице.Параметры.ИтогНДСПоСтранице         = ИтогоНДСНаСтранице;

            //        ОбластьИтоговПоСтранице.Параметры.ИтогСуммыСНДСПоСтранице   = ИтогоСуммаСНДСНаСтранице;

            //        

            //        ТабДокумент.Вывести(ОбластьИтоговПоСтранице);

            //        

            //        // очистим итоги по странице

            //        ИтогоМассаБруттоНаСтранице = 0;

            //        ИтогоМестНаСтранице        = 0;

            //        ИтогоКоличествоНаСтранице  = 0;

            //        ИтогоСуммаНаСтранице       = 0;

            //        ИтогоНДСНаСтранице         = 0;

            //        ИтогоСуммаСНДСНаСтранице   = 0;

            //        

            //        НомерСтраницы = НомерСтраницы + 1;

            //        ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();

            //        ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;

            //        ТабДокумент.Вывести(ЗаголовокТаблицы);

                    
                //КонецЕсли;


Закоментировал, стало норм
   Mahazbek
 
20 - 20.05.19 - 14:45
Друзья (народ, ребятушки, господа, ув. специалисты, товарищи), я понимаю, что здесь не место исполнения желаний и у каждого своих дел по горло, но все же, если найдется еще пару минут на меня, выручите, пожалуйста!
Бетон продается в метрах кубических. В ТОРГ12 должно отражаться количество килограмм (масса нетто).

Рассчитывается так: количество метров кубических * коэффициент. Коэффициент вносится в единицах измерения бетона (Изображение 1).

Изображение 1: http://www.picshare.ru/view/10061083/

Все вроде сделал:
КОД
Вес = ВыборкаСтрок.ЕдиницаИзмерения.Вес;
             
             Если Вес >= 1 Тогда 
             Объем = Вес * Количество;
             ОбластьМакета.Параметры.Объем = Объем;     
            КонецЕсли; 
            
Заработало, появилась масса нетто, НО теперь количество килограмм попадает во все строки (Изображение 2).

Изображение 2: http://www.picshare.ru/view/10061086/

Как сделать, чтобы килограммы отражались только в позициях бетона, то есть там, где введен коэффициент?
   Mahazbek
 
21 - 20.05.19 - 14:48
Макет ТОРГ12 с параметрами:
Изображение 3: http://www.picshare.ru/view/10061087/
   Eg0rkas
 
22 - 20.05.19 - 14:55
можно добавить еще одно условие, по коду товара или на м3, типа если м3, тогда объем = вес*количество иначе объем=""
   Mahazbek
 
23 - 20.05.19 - 15:41
(22) Не осилил, еще сложнее стало (
   Eg0rkas
 
24 - 20.05.19 - 15:56
(23) покажи еще раз запрос откуда берется вес, количество, товаркод, единицанаименование
   Mahazbek
 
25 - 20.05.19 - 16:03
ТекстЗапросаШапка = "ВЫБРАТЬ
    |    Номер,
    |    Дата КАК ДатаДокумента,
    |    РеализацияТоваровУслуг.Организация,
    |    РеализацияТоваровУслуг.Организация КАК ЮрФизЛицо,
    |    РеализацияТоваровУслуг.Организация КАК Поставщик,
    |    РеализацияТоваровУслуг.Организация КАК Контрагент,
    |    РеализацияТоваровУслуг.Организация КАК Руководители,
    |    АдресДоставки КАК АдресДоставки,
    |    ВЫБОР КОГДА Грузополучатель = &ПустойКонтрагент
    |          ТОГДА Контрагент
    |          ИНАЧЕ Грузополучатель КОНЕЦ КАК Грузополучатель,
    |    ВЫБОР КОГДА Грузоотправитель = &ПустойКонтрагент
    |          ТОГДА РеализацияТоваровУслуг.Организация
    |          ИНАЧЕ Грузоотправитель КОНЕЦ КАК Грузоотправитель,
    |    БанковскийСчетОрганизации КАК БанковскийСчет,
    |    Контрагент КАК Покупатель,
    |    Контрагент КАК Плательщик,
    |    Сделка,
    |    ДоговорКонтрагента.Ссылка  КАК Основание,
    |    ДоговорКонтрагента.ВедениеВзаиморасчетов КАК ВедениеВзаиморасчетов,
    |    ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
    |    ПРЕДСТАВЛЕНИЕ(
    |    ВЫБОР    КОГДА РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете
    |            ТОГДА ЕСТЬNULL(ТаблицаСоответствиеОрганизации.ПодразделениеОрганизации, """")
    |            ИНАЧЕ РеализацияТоваровУслуг.Подразделение
    |    КОНЕЦ) КАК ПредставлениеПодразделения,
    |    ВЫБОР    КОГДА РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете
    |            ТОГДА ЕСТЬNULL(ТаблицаСоответствиеОрганизации.ПодразделениеОрганизации, """")
    |            ИНАЧЕ РеализацияТоваровУслуг.Подразделение
    |    КОНЕЦ КАК Подразделение,
    |    ВалютаДокумента,
    |    КурсВзаиморасчетов      КАК Курс,
    |    КратностьВзаиморасчетов КАК Кратность,
    |    УчитыватьНДС,
    |    СуммаВключаетНДС,
    |    ОтпускРазрешил,
    |    ОтпускПроизвел,
    |    ДоверенностьНомер,
    |    ДоверенностьДата,
    |    ДоверенностьВыдана,
    |    ДоверенностьЧерезКого
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |    РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |ПО
    |    ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |(
    |    ВЫБРАТЬ
    |        СоответсвиеПодразделений.Подразделение,
    |        СоответсвиеПодразделений.Организация,
    |        МИНИМУМ(СоответсвиеПодразделений.ПодразделениеОрганизации) КАК ПодразделениеОрганизации,
    |        МАКСИМУМ(СоответсвиеПодразделений.ПодразделениеОрганизации) КАК ПодразделениеОрг
    |    ИЗ
    |        РегистрСведений.СоответствиеПодразделенийИПодразделенийОрганизаций КАК СоответсвиеПодразделений
    |    ГДЕ
    |        Подразделение = &Подразделение
    |        И Организация = &Организация
    |        И Организация <> ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
    |        И Подразделение <> ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)
    |    СГРУППИРОВАТЬ ПО
    |        Подразделение,
    |        Организация
    |    ИМЕЮЩИЕ
    |        КОЛИЧЕСТВО(*) = 1
    |) ТаблицаСоответствиеОрганизации
    |ПО
    |    ТаблицаСоответствиеОрганизации.Подразделение = РеализацияТоваровУслуг.Подразделение
    |    И ТаблицаСоответствиеОрганизации.Организация = РеализацияТоваровУслуг.Организация
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |";

    ТекстЗапросаТовары =     "ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура                                  КАК Номенклатура,
    |    ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
    |    ВложенныйЗапрос.Номенклатура." + ТоварКод + "                 КАК ТоварКод,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление                КАК БазоваяЕдиницаНаименование,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Вес                КАК Вес,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код  КАК БазоваяЕдиницаКодПоОКЕИ,
    |    ВложенныйЗапрос.ЕдиницаИзмерения     КАК ЕдиницаИзмерения,
    |    ВложенныйЗапрос.ЕдиницаИзмеренияМест.Представление            КАК ВидУпаковки,
    |    ВложенныйЗапрос.КоэффициентМест / ВложенныйЗапрос.Коэффициент КАК КоличествоВОдномМесте,
    |    ВЫБОР
    |        КОГДА ВложенныйЗапрос.КоличествоМест > 0 ТОГДА ВложенныйЗапрос.КоличествоМест * ВложенныйЗапрос.ЕдиницаИзмеренияМест.Вес
    |        ИНАЧЕ ВложенныйЗапрос.Количество * ВложенныйЗапрос.ЕдиницаИзмерения.Вес
    |    КОНЕЦ КАК МассаБрутто,
    |    ВложенныйЗапрос.Характеристика       КАК Характеристика,
    |    ВложенныйЗапрос.Серия                КАК Серия,
    |    ВложенныйЗапрос.СтавкаНДС            КАК СтавкаНДС,
    |    ВложенныйЗапрос.Цена                 КАК Цена,
    |    ВЫБОР
    |        КОГДА((ВложенныйЗапрос.ПроцентСкидкиНаценки = 0) И 
    |              (ВложенныйЗапрос.ПроцентАвтоматическихСкидок = 0))
    |    ТОГДА ЛОЖЬ
    |    ИНАЧЕ Истина
    |    КОНЕЦ                                КАК ЕстьСкидкиПоСтроке,
    |    ВложенныйЗапрос.Количество           КАК Количество,
    |    ВложенныйЗапрос.КоличествоМест       КАК КоличествоМест,
    |    ВложенныйЗапрос.Сумма                КАК Сумма,
    |    ВложенныйЗапрос.СуммаНДС             КАК СуммаНДС,
    |    ВложенныйЗапрос.НомерСтроки          КАК НомерСтроки,
    |    ВложенныйЗапрос.Метка                КАК Метка
    |ИЗ
    |
    |    (
    |    ВЫБРАТЬ
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Вес             КАК Вес,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест.Коэффициент     КАК КоэффициентМест,
    |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры           КАК Характеристика,
    |        РеализацияТоваровУслуг.СерияНоменклатуры                    КАК Серия,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность            КАК Цена,
    |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
    |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок,
    |        СУММА(РеализацияТоваровУслуг.Количество)                    КАК Количество,
    |        СУММА(РеализацияТоваровУслуг.КоличествоМест)                КАК КоличествоМест,
    |        СУММА(РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность) КАК Сумма,
    |        СУММА(РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,
    |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)                 КАК НомерСтроки,
    |        0.00                                                        КАК Метка
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |    ГДЕ
    |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.ХарактеристикаНоменклатуры,
    |        РеализацияТоваровУслуг.СерияНоменклатуры,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена,
    |        РеализацияТоваровУслуг.ПроцентСкидкиНаценки,
    |        РеализацияТоваровУслуг.ПроцентАвтоматическихСкидок
    |    ) КАК ВложенныйЗапрос
    |";
    СтрокаВыборкиПоляСодержания = ОбработкаТабличныхЧастей.ПолучитьЧастьЗапросаДляВыбораСодержания("РеализацияТоваровУслуг");
    ТекстЗапросаТовары = ТекстЗапросаТовары + "
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                  КАК Номенклатура,
    |    " + СтрокаВыборкиПоляСодержания + "                  КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + " КАК ТоварКод,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК БазоваяЕдиницаНаименование,
    |    NULL                                                 КАК Вес,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаИзмерения,
    |    NULL                                                 КАК ВидУпаковки,
    |    NULL                                                 КАК КоличествоВОдномМесте,
    |    0.00                                                 КАК МассаБрутто,
    |    NULL                                                 КАК Характеристика,
    |    NULL                                                 КАК Серия,
    |    РеализацияТоваровУслуг.СтавкаНДС                     КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность     КАК Цена,
    |    ВЫБОР    КОГДА(РеализацияТоваровУслуг.ПроцентСкидкиНаценки = 0.00)
    |            ТОГДА ЛОЖЬ
    |            ИНАЧЕ Истина
    |    КОНЕЦ                                                КАК ЕстьСкидкиПоСтроке,
    |    РеализацияТоваровУслуг.Количество                    КАК Количество,
    |    NULL                                                 КАК КоличествоМест,
    |    РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность КАК Сумма,
    |    РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                   КАК НомерСтроки,
    |    1.00                                                 КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |";
    ТекстЗапросаТовары = ТекстЗапросаТовары + "
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                    КАК Номенклатура,
    |    ВЫРАЗИТЬ(РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура." + ТоварКод + "   КАК ТоварКод,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Представление               КАК БазоваяЕдиницаНаименование,
    |    NULL                                                 КАК Вес,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.ЕдиницаПоКлассификатору.Код КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков                             КАК ЕдиницаИзмерения,
    |    NULL                                                  КАК ВидУпаковки,
    |    NULL                                                  КАК КоличествоВОдномМесте,
    |    РеализацияТоваровУслуг.Количество * РеализацияТоваровУслуг.Номенклатура.ЕдиницаХраненияОстатков.Вес КАК МассаБрутто,
    |    NULL                                                  КАК Характеристика,
    |    NULL                                                  КАК Серия,
    |    ""Без НДС""                                           КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность      КАК Цена,
    |    Ложь                                                  КАК ЕстьСкидкиПоСтроке,
    |    РеализацияТоваровУслуг.Количество                     КАК Количество,
    |    NULL                                                  КАК КоличествоМест,
    |    РеализацияТоваровУслуг.Сумма * &Курс / &Кратность     КАК Сумма,
    |    0.00                                                  КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                    КАК НомерСтроки,
    |    2.00                                                  КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |
    |УПОРЯДОЧИТЬ ПО Метка ВОЗР, НомерСтроки ВОЗР
    |
    |";
   Eg0rkas
 
26 - 20.05.19 - 16:25
Если Вес >= 1 И ТоварКод = 00000025250 Тогда 
             Объем = Вес * Количество;
             ОбластьМакета.Параметры.Объем = Объем;     
            КонецЕсли;

но это условие будет работать только на товар "Бетон М-300", можно наложить условие, на БазоваяЕдиницаНаименование, если она равна м3 (единица измерения). Ты уже сам реши, на что лучше условие накладывать, на один конкретный товар или на конкретную единицу измерения или еще на какое-то общее свойство, у которого объем считается по твоей формуле
   Mahazbek
 
27 - 20.05.19 - 16:56
(26) Если Вес >= 1 И БазоваяЕдиницаНаименование = м3 Тогда 
             Объем = Вес * Количество;
             ОбластьМакета.Параметры.Объем = Объем;     
            КонецЕсли;

ОШИБКА: {ВнешняяОбработка.ТОРГ12_КАПС_новая.МодульОбъекта(566,20)}: Переменная не определена (БазоваяЕдиницаНаименование)
            Если Вес >= 1 И <<?>>БазоваяЕдиницаНаименование = м3 Тогда  (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.ТОРГ12_КАПС_новая.МодульОбъекта(566,49)}: Переменная не определена (м3)
            Если Вес >= 1 И БазоваяЕдиницаНаименование = <<?>>м3 Тогда  (Проверка: Толстый клиент (обычное приложение))
   Mahazbek
 
28 - 20.05.19 - 16:57
Лучше будет по условию м3
   hhhh
 
29 - 20.05.19 - 17:02
(27) тебе общую схему нарисовали, а прямо этот кусок прямо в программу захреначил.
   Eg0rkas
 
30 - 20.05.19 - 17:10
(28) по твоей ссылке http://www.picshare.ru/view/10061087/ колонка 4, какой там параметр? не видно название полностью.
м3 это же не переменная у тебя, а значение из справочника наверное. ты в коде хоть немного разбираешься?
 
 
   Mahazbek
 
31 - 21.05.19 - 08:12
(30) На самом примитивном уровне. Только начал
   Mahazbek
 
32 - 21.05.19 - 08:13
(30) Колонка 4 БазоваяЕдиницаНаименование
   Mahazbek
 
33 - 21.05.19 - 09:15
Решил так:

Вес = ВыборкаСтрок.ЕдиницаИзмерения.Вес;
        
            Масса = Вес * Количество;
            ОбластьМакета.Параметры.Масса = Масса;
   Mahazbek
 
34 - 21.05.19 - 09:17
   Mahazbek
 
35 - 21.05.19 - 09:18
Как же непросто это дается..
   Mahazbek
 
36 - 21.05.19 - 09:18
Спасибо Вам всем, что не проходите мимо!


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.