Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1С 8.2 как посчитать итоговую сумму Итого, оклад, начисления, премия?

1С 8.2 как посчитать итоговую сумму Итого, оклад, начисления, премия?
Я
   lada0807
 
25.04.19 - 14:00
У меня есть документ начисление ЗП в  табличной части которого есть реквизиты оклад, начисление, премия, итого у меня не получается рассчитывать итоговую сумму автоматически
в модуле объекта я пишу Итого = ТабличнаяЧасть1.Итог("Оклад") + ТабличнаяЧасть1.Итог("Начисление") + ТабличнаяЧасть1.Итог("Премия");
 
 
   sqr4
 
1 - 25.04.19 - 14:02
какое событие? Итого это реквизит документа?
   lada0807
 
2 - 25.04.19 - 14:03
(1)Итого это реквизит документа
   runoff_runoff
 
3 - 25.04.19 - 14:09
ПередЗаписью можно
   lada0807
 
4 - 25.04.19 - 14:12
(3) не рассчитывается
   runoff_runoff
 
5 - 25.04.19 - 14:20
(4) так не бывает
   lada0807
 
6 - 25.04.19 - 14:22
(5) что не бывает?))))
   Simod
 
7 - 25.04.19 - 14:25
"Оклад", "Начисление", "Премия" - тип "Число" ?
   lada0807
 
8 - 25.04.19 - 14:27
(7) да число
   runoff_runoff
 
9 - 25.04.19 - 14:29
дайте 3 строки кода.. включащие в себя слова Процедура и КонецПроцедуры, в которой идет вычисление выражения
   user1114234
 
10 - 25.04.19 - 14:30
А откуда 1с знает, что Итого это не просто переменная?
   lada0807
 
11 - 25.04.19 - 14:34
(9) Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    СуммаДокумента = ТабличнаяЧасть1.Итог("Оклад") + ТабличнаяЧасть1.Итог("Начисление") + ТабличнаяЧасть1.Итог("Премия");
КонецПроцедуры
   Filippov
 
12 - 25.04.19 - 14:37
(11) Итого или СуммаДокумента?
   user1114234
 
13 - 25.04.19 - 14:39
(11) СуммаДокумента - это переменная. А значение нужно передать в реквизит Итого?
Т.е что-то типа
ЭтотОбъект.Итого = СуммаДокумента
   runoff_runoff
 
14 - 25.04.19 - 14:41
(11) должно работать.. если все имена правильные.. и СуммаДокумента - реквизит документа
еще нужно смотреть подписки на события.. которые могут изменять сумму документа
   lada0807
 
15 - 25.04.19 - 14:42
(12) Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Итого = ТабличнаяЧасть1.Итог("Оклад") + ТабличнаяЧасть1.Итог("Начисление") + ТабличнаяЧасть1.Итог("Премия");
КонецПроцедуры
   lada0807
 
16 - 25.04.19 - 14:42
(13) Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Итого = ТабличнаяЧасть1.Итог("Оклад") + ТабличнаяЧасть1.Итог("Начисление") + ТабличнаяЧасть1.Итог("Премия");
КонецПроцедуры
   runoff_runoff
 
17 - 25.04.19 - 14:43
(16) всё чётко
   runoff_runoff
 
18 - 25.04.19 - 14:44
ставьте точку останова тут..
а вторую в процедуре ПриЗаписи.. ловите значение Итого

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.