Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как сравнить по разным методам

Как сравнить по разным методам
Я
   serkorvin1
 
24.04.19 - 10:12
Если Тип = 1 тогда нужно сравнивать на знак равенства
Иначе на знак неравенства.
Подскажите как сделать

Функция Тест(Тип)

Если Тип = 1 Тогда

Если СокрЛП(тТовар.IDНаСайте) = "" Тогда

Иначе

Если СокрЛП(тТовар.IDНаСайте) <> "" Тогда

КонецЕсли;


.....
КонецФункции
 
 
   1Сергей
 
1 - 24.04.19 - 10:14
Если Тип = 1 Тогда 
    Если СокрЛП(тТовар.IDНаСайте) = "" Тогда

    КонецЕсли;
Иначе 
    Если СокрЛП(тТовар.IDНаСайте) <> "" Тогда 

    КонецЕсли;
КонецЕсли;
   serkorvin1
 
2 - 24.04.19 - 10:16
Для Каждого тТовар ИЗ МассивТовара Цикл
        
        Если СокрЛП(тТовар.IDНаСайте) = "" Тогда
            Продолжить;
        Иначе
            НС = Объект.ТоварДляСинхронизации.Добавить();
            НС.Товар = тТовар;
            НС.Наименование = СтрЗаменить(тТовар.НаименованиеДляСайта, """", "");
            НС.Описание = СтрЗаменить(тТовар.ОписаниеДляСайта, """", "");
                       и тут еще много кода


В другом случае надо


Для Каждого тТовар ИЗ МассивТовара Цикл
        
        Если СокрЛП(тТовар.IDНаСайте) <> "" Тогда
            Продолжить;
        Иначе
            НС = Объект.ТоварДляСинхронизации.Добавить();
            НС.Товар = тТовар;
            НС.Наименование = СтрЗаменить(тТовар.НаименованиеДляСайта, """", "");
            НС.Описание = СтрЗаменить(тТовар.ОписаниеДляСайта, """", "");
                         и тут еще много Такого же кода
   serkorvin1
 
3 - 24.04.19 - 10:16
(1) просто в таком случае будет простой дубляж кода
   1Сергей
 
4 - 24.04.19 - 10:17
(3) блин, сразу бы сказал чо тебе надо. А то мой стеклянный шар на полировке :)
   Йохохо
 
5 - 24.04.19 - 10:18
в функцию оберни
   serkorvin1
 
6 - 24.04.19 - 10:18
(4) извиняюсь - хотел проще написать - но как всегда получилось :(((
   1Сергей
 
7 - 24.04.19 - 10:18
Если (Тип = 1) И (СокрЛП(тТовар.IDНаСайте) = "") Тогда
            Продолжить;
        ИначеЕсли (Тип <> 1) И (СокрЛП(тТовар.IDНаСайте) <> "") Тогда
            Продолжить;
        Иначе
...
   serkorvin1
 
8 - 24.04.19 - 10:26
(7) Спс
   НЕА123
 
9 - 24.04.19 - 10:44
Если (Тип+(СокрЛП(тТовар.IDНаСайте) = "")) % 2 = 0 Тогда 

Продолжить;

Иначе

пятница начинается в среду (с)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.