Вход | Регистрация
 

Конвертация данных. Ручной поиск

Конвертация данных. Ручной поиск
Я
   Wefast
 
24.04.19 - 09:33
Есть ПКО (Строка -> Справочник)
В ПКС в источнике пусто, в приемнике Наименование
Стоит галка поиска. В обработчике стоит Значение = Источник;

В обработчике Поля поиска пишу:

Сообщить(СтрокаИменСвойствПоиска);                                  //пусто
Попытка Сообщить(СвойстваПоиска); Исключение КонецПопытки;          // соответсвие
Попытка Сообщить(СвойстваПоиска.Источник);Исключение КонецПопытки;  //пусто
Попытка Сообщить(СвойстваПОиска[0]);  Исключение КонецПопытки;      //пусто
Попытка Сообщить(СвойстваПОиска[1]);  Исключение КонецПопытки;      //пусто
Попытка Сообщить(СвойстваПОиска[2]);  Исключение КонецПопытки;      //пусто
ПрекратитьПоиск = Истина;


Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|    ТарифныеСетки.Ссылка КАК Ссылка,
|    ТарифныеСетки.Наименование КАК Наименование
|ИЗ
|    Справочник.ТарифныеСетки КАК РазрядыКатегорииДолжностей
|ГДЕ
|    ТарифныеСетки.Наименование ПОДОБНО &Наименование";
Запрос.УстановитьПараметр("Наименование", Лев(СвойстваПоиска.Наименование,3)+"%");    
РезультатЗапроса = Запрос.Выполнить();
Если НЕ РезультатЗапроса.Пустой() Тогда
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        Если Сред(Выборка.Наименование,4,1) <> " " Тогда
            Продолжить;
        КонецЕсли;
        СсылкаНаОбъект = Выборка.Ссылка;
        Прервать;
    КонецЦикла;    
КонецЕсли;


Ну и выдает ошибку:

Ошибка в обработчике события ПоследовательностьПолейПоиска
    ИмяПКО                 =  
    ТипОбъекта             =  Тарифная группа
    Обработчик             =  Последовательность полей поиска
    ОписаниеОшибки         =  Поле объекта не обнаружено (Наименование)
    ПозицияМодуля          =  (18)
    КодСообщения           =  73

Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1274)}: Ошибка в обработчике события ПоследовательностьПолейПоиска
    ИмяПКО                 =  
    ТипОбъекта             =  Тарифная группа
    Обработчик             =  Последовательность полей поиска
    ОписаниеОшибки         =  Поле объекта не обнаружено (Наименование)
    ПозицияМодуля          =  (18)
    КодСообщения           =  73
 
 
   MouHacTaBHuk
 
1 - 24.04.19 - 10:01
(0) Спасибо за инфу, так делать не будем
   MouHacTaBHuk
 
2 - 24.04.19 - 10:03
(0) 4 года почти прошло, а всё те же ошибки Конвертация данных ПКС
   mc lammer
 
3 - 24.04.19 - 10:04
измени  СвойстваПоиска.Наименование   на  СвойстваПоиска["Наименование"]
   Wefast
 
4 - 24.04.19 - 11:43
(3) спасибо. Да, нашел несколько "опечаток" и ошибок.

(1) а как вы будете делать?
(2) что должно было изменится? 1-2 раза в год с конвертацией сталкиваюсь, без отладки, возможностей платформы с подсказками при написании кода, конструкторов и прочего сложновато выходит отслеживать где и в чем проблема
   user-ok
 
5 - 24.04.19 - 12:01
(4) >>без отладки
не самая удобная отладка. но работает же
>> возможностей платформы с подсказками при написании кода, конструкторов и прочего
пиши в конфигураторе, потом переноси код в КД. Гилев на курсах так делает
   Ёпрст
 
6 - 24.04.19 - 12:24
(0)
ПараметрыОбъекта смотри, раз источник - пусто
   Ёпрст
 
7 - 24.04.19 - 12:27
хотя не, тыж в приёмник передаешь

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.