Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как добавить серии в Диаграмму ганта.

Как добавить серии в Диаграмму ганта.
Я
   светлана123
 
23.04.19 - 09:43
У меня в диаграмме Ганта нужно сделать несколько серий, а то они все сливаются в одну.
Как это сделать?
1с.8.3 Предприятие
 
 
   светлана123
 
1 - 23.04.19 - 09:44
Реквизит1.Очистить();
    Реквизит1.Обновление=Ложь;
    Реквизит1.ОтображатьЛегенду=Ложь;
    Реквизит1.ОтображатьЗаголовок=Ложь;
    Реквизит1.ОбластьПостроения.Право=1;
    Реквизит1.АвтоОпределениеПолногоИнтервала=Ложь;
    Реквизит1.УстановитьПолныйИнтервал(ТекущаяДата()-86400, ТекущаяДата()+1209600);
    Запрос1=Новый Запрос();
    Запрос1.Текст="ВЫБРАТЬ
                  |    Сотрудники.ФИО КАК ФИО
                  |ИЗ
                  |    Справочник.Сотрудники КАК Сотрудники
                  |ГДЕ
                  |    Сотрудники.ЭтоГруппа = Ложь";
    Выборка1=Запрос1.Выполнить().Выбрать();
    

    Пока Выборка1.Следующий() Цикл
        Точка=Реквизит1.УстановитьТочку(Строка(Выборка1.ФИО));
        Серия=Реквизит1.УстановитьСерию(Выборка.РаспределениеЗаявокОстатки);
        
    
        Запрос=Новый Запрос();
        
        Запрос.Текст="ВЫБРАТЬ
|            РаспределениеЗаявокОстатки.Клиент КАК Клиент,
|                РаспределениеЗаявокОстатки.Сотрудник КАК Сотрудник,
|                РаспределениеЗаявокОстатки.КоличествоОстаток КАК Количество,
|                РаспределениеЗаявокОстатки.Услуги КАК Услуги,
|                РаспределениеЗаявок.Адрес КАК Адрес,
|                РаспределениеЗаявок.Телефон КАК Телефон,
|               РаспределениеЗаявок.ДатаУслуги КАК ДатаУслуги,
|               РаспределениеЗаявок.КритическаяДата КАК КритическаяДата
|            ИЗ
|                РегистрНакопления.РаспределениеЗаявок.Остатки КАК РаспределениеЗаявокОстатки
|                    ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.РаспределениеЗаявок КАК РаспределениеЗаявок
|                    ПО (РаспределениеЗаявок.Клиент = РаспределениеЗаявокОстатки.Клиент)
|                        И (РаспределениеЗаявок.Услуги = РаспределениеЗаявокОстатки.Услуги)
|                        И (РаспределениеЗаявок.Сотрудник = РаспределениеЗаявокОстатки.Сотрудник)
|            ГДЕ
|                РаспределениеЗаявок.Сотрудник = &Сотрудник";
        Запрос.УстановитьПараметр("Сотрудник", Справочники.Сотрудники.НайтиПоНаименованию(Выборка1.ФИО));
         
        Выборка=Запрос.Выполнить().Выбрать();
         
        Если Выборка.Количество()>0 Тогда 
            
            Пока Выборка.Следующий() Цикл
                Значение=Реквизит1.ПолучитьЗначение(Точка, Серия);
                Интервал= Значение.Добавить();
                Интервал.Начало=Выборка.ДатаУслуги;
                Интервал.Конец=Выборка.КритическаяДата+86400;
                Интервал.Цвет=WebЦвета.Синий;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.