Вход | Регистрация
 

ОбработкаПолученияПредставления - проходит, но представление не меняет!

ОбработкаПолученияПредставления - проходит, но представление не меняет!
Я
   Dimaster
 
23.04.19 - 06:27
Платформа 8.3.13, УНФ 1.6.16
Для документа Отчет переработчика написал процедуру ОбработкаПолученияПредставления.
При входе в форму списка или докуменка отладчик туда заходит, вся процедура идет, в поле Представление записывается то, что надо, стандартная обработка стоит ложь.
А представление ссылки в итоге не изменяется!
Как быть? Проверил типовая процедура для заказа покупателя там же (на этой же базе) срабатывает и все отображает.
Что может мешать?
 
 
   PuhUfa
 
1 - 23.04.19 - 06:44
(0) а ОбработкаПолученияПолейПредставления ?
https://its.1c.ru/db/v8std/content/2149184395/hdoc
   Dimaster
 
2 - 23.04.19 - 07:34
(1) Так же задействована.

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    //Поля.Добавить("Ссылка");

    Поля.Добавить("Дата");
    Поля.Добавить("Номер");
    Поля.Добавить("ВозвратВПереработку");
    Поля.Добавить("Проведен");
    Поля.Добавить("ПометкаУдаления");
    
КонецПроцедуры// ОбработкаПолученияПолейПредставления()


Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    
    Если Данные.Номер = Null Тогда
        Возврат;
    КонецЕсли;
    
    СтандартнаяОбработка = Ложь;
    
    Если Данные.Проведен Тогда
        Состояние = "";
    Иначе
        Если Данные.ПометкаУдаления Тогда
            Состояние = " (удален)";
        ИначеЕсли Данные.Свойство("Проведен") И НЕ Данные.Проведен Тогда
            Состояние = " (не проведен)";
        КонецЕсли;
    КонецЕсли;
    
    Если Данные.ВозвратВПереработку Тогда
        ЗаголовокПредставление = "Возврат переработчику";
    Иначе
        ЗаголовокПредставление = "Отчет переработчика";
    КонецЕсли;
    
    Представление = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
        "%1 %2 от %3%4",
        ЗаголовокПредставление,
        ?(Данные.Свойство("Номер"), ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Данные.Номер, Истина, Истина), ""),
        Формат(Данные.Дата, "ДЛФ=D"),
        Состояние);
    
КонецПроцедуры// ОбработкаПолученияПредставления()
   Cyberhawk
 
3 - 23.04.19 - 07:39
"представление ссылки в итоге не изменяется" // Возможно из-за кэша представлений ссылок
   Cyberhawk
 
4 - 23.04.19 - 07:41
Фишка в том, что его сбросить / обновить по желанию не всегда можно.
Ты показываешь ссылку до, а потом меняется представление (даже запись объекта с новыми полями), а представление ссылки старенькое показывается.
Если у тебя дин. список, то попробуй ОповеститьОбИзменении вызвать
   Dimaster
 
5 - 23.04.19 - 07:43
Вопрос снят.. Все оказалось просто - есть подписка на событие в типовой, которая перебивает эти процедуры в модуле менеджера. Убрал из нее искомый документ - и все сработало.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.