Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ТЧ обработки в Тч документа

ТЧ обработки в Тч документа
Я
   Badman594
 
22.04.19 - 16:44
Добрый вечер, господа и дамы(если есть)!
Очень прошу помочь, подсказать, точнее молю о помощи!
Перейду к сути: Получил документы из JSONа в ТЧ обработки, хочу перенести помеченные доки в ТЧ документа. Создал в обработке реквизит СсылкаНаДокумент с ссылкой на документ)).
Создал реквизиты ТЧ документа и самом док-те и в форме списка. Помогите пожалуйста непутевому!

Процедура  Команда2НаСервере()
    Выборка=ЭтотОбъект.Объект.ТаблицаДокументов.Выгрузить(ЭтотОбъект.Объект.ТаблицаДокументов.НайтиСтроки(Новый Структура("Пометка",Истина)));
    ДокОбъект = ЭтотОбъект.Объект.СсылкаНаДокумент;  
ДокОбъект.СписокДокументов.Очистить();                                
Для каждого тСтрока из выборка Цикл
    попытка
НовСтрока = ДокОбъект.СписокДокументов.Добавить();
ЗаполнитьЗначенияСвойств(НовСтрока,тСтрока);
Исключение
                Сообщить("");
                КонецПопытки;

КонецЦикла;
        
КонецПроцедуры
 
 
   Ёпрст
 
1 - 22.04.19 - 16:48
(0) ПолучитьОбъект();
   Ёпрст
 
2 - 22.04.19 - 16:49
добавь
   Ёпрст
 
3 - 22.04.19 - 16:49
и запись документа потом
   Badman594
 
4 - 22.04.19 - 16:55
{Обработка.Обработка.Форма.Форма.Форма(236)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
    ДокОбъект = ЭтотОбъект.Объект.СсылкаНаДокумент.ПолучитьОбъект();  
по причине:
Элемент не выбран!
   Badman594
 
5 - 22.04.19 - 16:56
(3) Не получается
   Ёпрст
 
6 - 22.04.19 - 17:14
ЭтотОбъект выкинь из кода
   Badman594
 
7 - 22.04.19 - 17:20
(6) Все равно та же самая ошибка(( У меня там в документе нет ни одной записи, может изза этого? Но таков был замысел, чтоб туда попадали только доки из обработки...
   Badman594
 
8 - 22.04.19 - 17:22
(6)     Выборка=Объект.ТаблицаДокументов.Выгрузить(ЭтотОбъект.Объект.ТаблицаДокументов.НайтиСтроки(Новый Структура("Пометка",Истина)));
    ДокОбъект = Объект.СсылкаНаДокумент.ПолучитьОбъект();  
ДокОбъект.СписокДокументов.Очистить();                                
Для каждого тСтрока из Выборка Цикл
    попытка
НовСтрока = ДокОбъект.СписокДокументов.Добавить();
ЗаполнитьЗначенияСвойств(НовСтрока,тСтрока);
Исключение
                Сообщить("");
                КонецПопытки;

            КонецЦикла;
            ДокОбъект.Записать();
   Сергиус
 
9 - 22.04.19 - 18:00
(4)У тебя наверно в СсылкаНаДокумент пусто. Как заполняешь данный реквизит?
   Badman594
 
10 - 22.04.19 - 22:25
(9) ДокументСсылка.ИмяДокумента

С таким кодом через отладчик видно что данные присваивается, но в тч документа также пусто, метод записать() - ошибка, выгрузить() - ноль эмоций:
Выборка=Объект.ТаблицаДокументов.Выгрузить(ЭтотОбъект.Объект.ТаблицаДокументов.НайтиСтроки(Новый Структура("Пометка",Истина)));
    ДокОбъект = Этот Объект.Объект.СсылкаНаДокумент;  
ДокОбъект.СписокДокументов.Очистить();                                
Для каждого тСтрока из Выборка Цикл
    попытка
НовСтрока = ДокОбъект.СписокДокументов.Добавить();
ЗаполнитьЗначенияСвойств(НовСтрока,тСтрока);
Исключение
                Сообщить("");
                КонецПопытки;

            КонецЦикла;
   Сергиус
 
11 - 22.04.19 - 23:31
(10)[ДокОбъект = Этот Объект.Объект.СсылкаНаДокумент;  
     ДокОбъект.СписокДокументов.Очистить();]

Ну так здесь у тебя в ДокОбъект просто ссылка будет, естественно очистка и тп работать не будет. Надо пробовать ПолучитьОбъект(), но для этого в СсылкаНаДокумент должна быть реально ссылка
   Badman594
 
12 - 25.04.19 - 11:12
Решено!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.