Вход | Регистрация
 

ошибка итератор для значения не определен

ошибка итератор для значения не определен
Я
   wowas
 
22.04.19 - 14:00
На форме подбора после выбора элемента выскакивает ошибка
что не так?

&НаКлиенте
Процедура НоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
Для Каждого вЗнч из ВыбранноеЗначение Цикл
        нСтр = Элементы.Номенклатура.ТекущиеДАнные;
            нСтр.Количество= вЗнч.Значение;
    КонецЦикла;
        КонецПроцедуры
 
 
   Волшебник
 
1 - 22.04.19 - 14:03
у ВыбранноеЗначение нет итератора, его нельзя использовать в цикле Для Каждого
   Euguln
 
2 - 22.04.19 - 14:03
Опять что ли? Что сделать хочешь?
Вангую:
нСтр = Элементы.Номенклатура.ТекущиеДАнные; 
нСтр.Количество= ВыбранноеЗначение;
   wowas
 
3 - 22.04.19 - 14:06
(2) пробовал, вытаскивает не то поле которое нужно
   2S
 
4 - 22.04.19 - 14:07
В последнее время часто проскакивает данная ошибка. На каком релизе сидите?
   Волшебник
 
5 - 22.04.19 - 14:09
Возможно, элемент не выбран вообще или выбран один единственный элемент.
Перед циклом надо проверить ТипЗнч(ВыбранноеЗначение)
   wowas
 
6 - 22.04.19 - 14:09
(4) у меня учебная. 8.3.8.1933. Я вообще не понял прикола. Я сделал вот так как скинул. Все работало. Потом начал менять код, все сломалось. Вернул как было изначально и все равно не работает
   wowas
 
7 - 22.04.19 - 14:13
(5) У меня в ТЧ подбора есть поля ТС и вместимость. Мне нужно вместимость подставить в поле документа Количество. А он выбирает почему ТС и пытается подставить в количество.

&НаКлиенте
Процедура АвтоВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;
    парам_Авто=Элемент.ТекущиеДанные.Вместимость;
    ОповеститьОВыборе(Новый Структура("ВМестимость", парам_Авто));

КонецПроцедуры
   Волшебник
 
8 - 22.04.19 - 14:16
(7) Что говорит отладчик? Каков ТипЗнч(ВыбранноеЗначение)?
   wowas
 
9 - 22.04.19 - 14:17
(8) Транспортное средство
   shuhard
 
10 - 22.04.19 - 14:21
(9) и как ты видишь себе цикл по элементу справочника ?
у тебя отбор вернул одно значение, не массив
   wowas
 
11 - 22.04.19 - 14:23
(10) как сделать чтобы то что нужно возвращал?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.