Вход | Регистрация
 

Проверка заполнения теперь только при записи из формы элемента?

Проверка заполнения теперь только при записи из формы элемента?
Я
   RomaH
 
22.04.19 - 11:36
Справочник
ОГРН - Выдавать ошибку

запись из формы ругается
снятие пометки удаления из списка справочника - без вопросов
запись из кода - без вопросов
 
 
   Nuobu
 
1 - 22.04.19 - 11:36
Кнопка подменена.
   RomaH
 
2 - 22.04.19 - 11:47
(1) ты что несешь?
   Ботаник Гарден Меран
 
3 - 22.04.19 - 11:47
СП:
ОбработкаПроверкиЗаполнения
Вызывается расширением формы при необходимости проверки заполнения реквизитов при записи в форме, а также при выполнении метода ПроверитьЗаполнение
   RomaH
 
4 - 22.04.19 - 11:49
(3) и чего?

Модуль объекта:

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
    
    МассивНепроверяемыхРеквизитов = Новый Массив;
    
    Если Не СМО И Не СМО_ОМС И Не СМО_ДМС И Не МО И Не РЖД Тогда
        МассивНепроверяемыхРеквизитов.Добавить("ОГРН");
    КонецЕсли;
    
    МИС_ЗаполнениеДокументов.УдалитьНепроверяемыеРеквизитыИзМассива(ПроверяемыеРеквизиты,МассивНепроверяемыхРеквизитов);
    
КонецПроцедуры


код с ошибкой (забыл ОГРН)

            Контр = Справочники.Контрагенты.СоздатьЭлемент();
            
            Контр.НаименованиеПолное = НаименованиеПолное;
            
            Контр.СМО = Истина;
            Контр.СМО_ОМС = Истина;
            
            Если ПустаяСтрока(Контр.Наименование) Тогда
                Контр.Наименование = НаименованиеПолное;
            КонецЕсли;
            
            Контр.Регион = Справочники.АдминистративныеТерриторииРФИЗарубежья.НайтиПоКоду(Территория,Ложь);
            
            Контр.Записать();


и насоздавал дублей без ОГРН
   Cyberhawk
 
5 - 22.04.19 - 12:05
У тебя же прописано в коде "МассивНепроверяемыхРеквизитов.Добавить("ОГРН")", в чем вопрос?
   RomaH
 
6 - 22.04.19 - 12:27
(5) втом, что из формы этот элемент не записывается - пишет не заполнен ОГРН
   Cyberhawk
 
7 - 22.04.19 - 12:27
(6) Так форму и анализируй. Может там реквизит формы не в объекте и с проверкой заполнения, он и дает отлуп. Или элемент управления.
   ptiz
 
8 - 22.04.19 - 13:27
(6) Вопрос в чем?
Код из (4) - программно записывает элемент справочника, без проверок, как и гласит СП - см. (3).
   spiller26
 
9 - 22.04.19 - 15:13
(0) Что за конфа? Я тут с БП сражаюсь, клиент банк загрузка, как раз не хочет программно контрагентов создавать.
   igork1966
 
10 - 22.04.19 - 15:42
(0)(6) проверяется если установлено "Проведен" у дока, не?
   igork1966
 
11 - 22.04.19 - 15:43
(10) + сорри, пропустил что тебя справочник...
   RomaH
 
12 - 23.04.19 - 08:29
(3) спасибо - важная мелочь - "Вызывается расширением формы" - как-то я это упустил
а какой формы? а стандартная команда из какого-нибудь списка "провести" вызовет проверку заполнения?
   ptiz
 
13 - 23.04.19 - 08:48
(12) ОбработкаПроверкиЗаполнения - обработчик для типа СправочникОбъект, т.е. для формы, связанной с Объектом, а не списком.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.