Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отбор Контрагента-как сделать

Отбор Контрагента-как сделать
Я
   farrdo
 
20.04.19 - 19:49
Привет всем
не могу сделать отбор контрагента
Этот код где надо изменить..или пожалуйста напишите код сюда в ответе


Процедура ПриОткрытии()
    Если Открыта() Тогда
        //УстановитьСтандартныйИнтервалОтчета(ДатаНач,ДатаКон);
    КонецЕсли;
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);    
КонецПроцедуры


Процедура ДействияФормыПечать(Кнопка)
    табдок = ЭлементыФормы.Результат;
    табдок.Записать(КаталогВременныхФайлов()+"\TABLE.xls",ТипФайлаТабличногоДокумента.XLS97);
    ЗапуститьПриложение(КаталогВременныхФайлов()+"\TABLE.xls");
КонецПроцедуры

Процедура ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, Форма) Экспорт
    
    ЗначениеПараметраНачалоПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаНач"));
    ЗначениеПараметраКонецПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаКон"));
    ЗначениеПараметраСЧ = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("СЧ"));
    
    Если ЗначениеПараметраНачалоПериода <> Неопределено Тогда
        ЗначениеПараметраНачалоПериода.Значение = Форма.ДатаНач;
        ЗначениеПараметраНачалоПериода.Использование = (Форма.ДатаНач <> '0001-01-01');
    КонецЕсли;
    
    Если ЗначениеПараметраКонецПериода <> Неопределено Тогда
        ЗначениеПараметраКонецПериода.Значение = ?(Форма.ДатаКон = '0001-01-01', Форма.ДатаКон, КонецДня(Форма.ДатаКон));
        ЗначениеПараметраКонецПериода.Использование = (Форма.ДатаКон <> '0001-01-01');
    КонецЕсли;
    Сч = Новый Массив;
    Сч.Добавить("004");
    Сч.Добавить("29.10");
    
    Если ЗначениеПараметраСЧ <> Неопределено Тогда
        ЗначениеПараметраСЧ.Значение = Сч;
        ЗначениеПараметраСЧ.Использование = Истина;
    КонецЕсли;
    
КонецПроцедуры

Процедура НастройкаПериодаНажатие(Элемент)
    Если НП.Редактировать() Тогда
        ДатаНач = НП.ПолучитьДатуНачала();
        ДатаКон = НП.ПолучитьДатуОкончания();
        ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
    КонецЕсли;
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    НП = Новый НастройкаПериода;
    НП.ВариантНастройки = ВариантНастройкиПериода.Период;
    НП.УстановитьПериод(НачалоДня(ДатаНач), ?(ДатаКон = '00010101', ДатаКон, КонецДня(ДатаКон)));
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура КонтрагентПриИзмении(Элемент)
ОбновитьПараметрыКонтрагента(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура ОбновитьПараметрыКонтрагента(КомпоновщикНастроек, Форма) Экспорт

ЗначениеКонтрагент = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Контрагент"));
    
    Если ЗначениеКонтрагент <> Неопределено Тогда
        ЗначениеКонтрагент .Значение = Форма.Контрагент;
        ЗначениеКонтрагент .Использование = ЗначениеЗаполнено(Форма.Контрагент);
    КонецЕсли;
КонецПроцедуры
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.