Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Открыть окно ввода большого текста (1С 7.7) вместо поля ввода

v7: Открыть окно ввода большого текста (1С 7.7) вместо поля ввода
Я
   МимохожийОднако
 
19.04.19 - 08:08
На форме справочника есть поле Описание, в которое надо вносить достаточно большой текст.Несколько строк на форме видно. Как вызвать это поле развернуто на весь экран или в разумных пределах для удобства? Кнопку выбора значения добавил, но эффект нулевой
 
 
   Zmich
 
1 - 19.04.19 - 08:13
(0). ВвестиСтроку() не подойдет?
   HawkEye
 
2 - 19.04.19 - 08:14
(0) написать свою обработку
   МимохожийОднако
 
3 - 19.04.19 - 08:22
Рядом с текстовым полем добавил кнопочку
Функция ВвестиБольшойТекст()
    Если ВвестиСтроку(Большой,"Описание товара",,1)=1 Тогда
        
    КонецЕсли;
КонецФункции
..
Спасибо за подсказки
   Kigo_Kigo
 
4 - 19.04.19 - 08:49
Или поместить на отдельный слой и растянуть так как хочется, как сделано в ТИС в спр Номенклатура
   МимохожийОднако
 
5 - 19.04.19 - 08:55
(4) Отдельный слой был отвергнут изначально. На форме огромная куча реквизитов (привет из 90-х.) И базе куча лет. Зря не трясу.
   vladko
 
6 - 19.04.19 - 09:14
(5) и все эти реквизиты лежат на одном слое?
   Карст
 
7 - 19.04.19 - 09:16
жесть )))) работники наверное могут мышкой в пикселя по очереди попадать )))
   МимохожийОднако
 
8 - 19.04.19 - 09:24
(6) Да
(7) Не проверял)
...
Корова не моя.
   trad
 
9 - 19.04.19 - 09:31
(0) "Кнопку выбора значения добавил, но эффект нулевой"
Процедура ПриНачалеВыбораЗначения(Рекв, ФСО)

    Если Рекв = "ИмяРеквФормы" Тогда
        ВвестиСтроку(ИмяРеквФормы,"Описание товара",,1);
    КонецЕсли;

КонецПроцедуры
   МимохожийОднако
 
10 - 19.04.19 - 09:37
(9) Где эта процедура в семерке? Не нашёл
 
 Рекламное место пустует
   HawkEye
 
11 - 19.04.19 - 09:40
(9) строка же... если пользователи просто редактируют строку - то ПриНачалеВыбора не отработает...

(10)
Процедура ПриНачалеВыбораЗначения(<?>,)
КонецПроцедуры
Синтаксис:
ПриНачалеВыбораЗначения(<ИдентЭлемДиалога>,<ФлагСтандОбр>)
Назначение:
Предопределенная процедура после выбора значения в форме выбора (выбор может быть инициирован в немодальном режиме интерактивно, при помощи элемента диалога с ''педалькой'').
<ИдентЭлемДиалога> - идентификатор элемента диалога, которым инициализирован выбор значения.
<ФлагСтандОбр> - флаг, изначально, при вызове процедуры равен 1, если в теле процедуры значение этого параметра поменять на 0, то стандартный процесс выбора значения не будет происходить.
Замечание:
Данная процедура может располагаться только в программном модуле формы.
   Duke1C
 
12 - 19.04.19 - 09:47
(11) Всё нормально отработает. Надо просто в свойствах реквизита воткнуть галку "Имеет кнопку выбора".
Ну и запрет редактирования можно тоже поставить, чтоб прямо в поле не писали, а только через кнопку.
   trad
 
13 - 19.04.19 - 09:49
(10) в СП
   trad
 
14 - 19.04.19 - 09:49
(12) "Надо просто в свойствах реквизита воткнуть галку "Имеет кнопку выбора"
Автор ее воткнул
   МимохожийОднако
 
15 - 19.04.19 - 10:05
Мне хватило ВвестиСтроку(Описание,"Описание товара",,1) на отдельной кнопке.
Так получилось компактнее, т.к. кнопка из формы растянулась справа на несколько строк вместе с полем Описание. От кнопки выбора я отказался.
(12) в моём случае сохранилась возможность ввода в поле и по кнопке
   МимохожийОднако
 
16 - 19.04.19 - 10:10
Скорее всего дело закончится тем, что я на эту кнопку подвешу отдельную форму для реквизита, т.к. стандартное окно может надоесть.
   HawkEye
 
17 - 19.04.19 - 10:19
(12) читай внимательно что я написал, если реквизит Строка и пользователь редактирует строку НЕ прибегая к кнопке выбора, ПриНачалеВыбораЗначения - не отработает.

(16) так обычно и заканчивается...
   trad
 
18 - 19.04.19 - 10:40
(11) " строка же... если пользователи просто редактируют строку - то ПриНачалеВыбора не отработает... "
Читай внимательнее. Автору не надо при редактировании, автору надо по кнопке
))
   Злопчинский
 
19 - 19.04.19 - 10:42
я ликую.
прямо возрождение некроманта
семерка форева
   Злопчинский
 
20 - 19.04.19 - 10:42
тут контуровцф опросник прислали "насколько быстро работает база". смело написал "быстро"
   MWWRuza
 
21 - 19.04.19 - 21:09
+++(20) Повеселил, спасибо! :-)
   andrewalexk
 
22 - 20.04.19 - 00:52
(19) :) завидно? завидуй молча
   МимохожийОднако
 
23 - 20.04.19 - 09:55
Информация для болельщиков)
(4) Уговорил клиентов. Добавил слой и закладку Описание.
   Злопчинский
 
24 - 20.04.19 - 10:12
(23) ты прямо ас переговоров
   Kigo_Kigo
 
25 - 20.04.19 - 10:18
(4) ->(5) -> (23)  Бгггг
   МимохожийОднако
 
26 - 20.04.19 - 10:48
(25) Согласен. Бггг)
(24) Горжусь )))
   Mikeware
 
27 - 20.04.19 - 14:43
(20) у них штатный модуль для клюшек в 14-15 году работал весьма медленно. Пришлось переписывать. Ну и отдал тогла написанное их техподдержке.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует