Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не проводится заявка на склад в 7.7 складской подрядчик

v7: Не проводится заявка на склад в 7.7 складской подрядчик
Я
   Роспатнюк Сергей Сер
 
18.04.19 - 17:31
до этого документа есть еще 2, Предварительная заявка, и заявка на склад.
Ошибка Количество по накладной > неотпущенного материала по заявке .Документ не будет проведен: Накладная-перемещение 00001075 (01.04.19), строка: 1, требуется: 1, по заявке: 0
кто знает что делать в таком случае ?
 
 
   Роспатнюк Сергей Сер
 
1 - 18.04.19 - 17:32
+ (0) Ошибся в теме не заявка на склад а Документ Накладная-перемещение
   hhhh
 
2 - 18.04.19 - 17:33
(0) ну, вручную убедиться. посмотреть, сколько отпущенного товара, сколько неотпущенного
   Euguln
 
3 - 18.04.19 - 17:34
Ну вроде документ прямо сообщает, что не хватает материала по заявке. Смотрите по остаткам.
   Роспатнюк Сергей Сер
 
4 - 18.04.19 - 17:37
(3) по заявке 1 и даже если я в заявке сделаю 999 и проведу ошибка будет та же
   Роспатнюк Сергей Сер
 
5 - 18.04.19 - 17:38
в остатке как показывает отчет тоже есть 1 шт
   Darych
 
6 - 18.04.19 - 17:38
(5) " > неотпущенного материала по заявке"
   Darych
 
7 - 18.04.19 - 17:39
Материала?
   Darych
 
8 - 18.04.19 - 17:40
материал в штуках? ??
   hhhh
 
9 - 18.04.19 - 17:40
(4) покажите текст программы, где вычисляется неотпущенный материал по заявке.
   hhhh
 
10 - 18.04.19 - 17:41
да, вообще-то вы проставили 999 товара. а не хватает материала.
   Роспатнюк Сергей Сер
 
11 - 18.04.19 - 17:42
в этом то и проблема с 7ой вообще не работал и не знаю ни чего ни отчеты какие смотреть ни куда лазать текст смотреть
   Роспатнюк Сергей Сер
 
12 - 18.04.19 - 17:45
и так 1й док Размешение материала по адресам хранения там 3 строки на 2 из них уже все сделано то есть предварительная заявка потом заявка на склад и потом Накладная-перемещение кол-во в строка у всех 1
   Роспатнюк Сергей Сер
 
13 - 18.04.19 - 17:47
(10) товара - материала какя разница ?
   Роспатнюк Сергей Сер
 
14 - 18.04.19 - 17:48
в 7.7 вообще есть товар как таковой там вроде бы все как материал идет
   hhhh
 
15 - 18.04.19 - 17:52
(11) в 7.7 абсолютно то же самое, что и в 8. Что вы прибедняетесь? ищете поиском по конфе фразу "неотпущенного материала по заявке" и сразу попадаете в нужный кусок программы.
   Роспатнюк Сергей Сер
 
16 - 18.04.19 - 17:52
вроде бы вот 

Пока ТЧ.ПолучитьСтроку() = 1 Цикл
        _Материал = ТЧ.Материал;
        _ГУИД = ТЧ.СубГУИД; 
        Если _ГУИД.Выбран() = 0 Тогда 
            Продолжить;
        КонецЕсли;
        _Строка = 0;  
        _Флаг = Материалы.НайтиЗначение(_ГУИД,_Строка,"СубГУИД");  
        Если _Флаг = 0 Тогда
            Продолжить;
        КонецЕсли;
        Материалы.ПолучитьСтрокуПоНомеру(_Строка); 
        _Строка = 0;
        _Флаг = _ОстаткиВсего.НайтиЗначение(_ГУИД,_Строка,"СтрокаЗаявки"); 
        Если _Флаг = 0 Тогда  
            Сообщить("Нет невыполненной заявки к этой позиции ("+_ГУИД.Документ+").Документ не будет проведен: "+ТекущийДокумент()+", строка: "+ТЧ.НомерСтроки,"!");
            Отказ = 1;
            Продолжить;
        КонецЕсли; 
        _ОстаткиВсего.ПолучитьСтрокуПоНомеру(_Строка);
        Если _ОстаткиВсего.Количество < Материалы.Количество Тогда
            Сообщить("Количество по накладной > неотпущенного материала по заявке .Документ не будет проведен: "+ТекущийДокумент()+", строка: "+ТЧ.НомерСтроки+
            ", требуется: "+Материалы.Количество+", по заявке: "+_ОстаткиВсего.Количество,"!");
            Отказ = 1;
            Продолжить;
        КонецЕсли;
        _Строка = 0;
        _Флаг = _Остатки.НайтиЗначение(_ГУИД,_Строка,"СтрокаЗаявки"); 
        Если _Флаг = 0 Тогда  
            Сообщить("Нет невыполненной заявки к этой позиции ( "+_ГУИД.Документ+").Документ не будет проведен: "+ТекущийДокумент()+", строка: "+ТЧ.НомерСтроки,"!");
            Отказ = 1;
            Продолжить;
        КонецЕсли;
        _Остатки.ПолучитьСтрокуПоНомеру(_Строка);
        Если _Остатки.Количество >= ТЧ.Количество Тогда
            РегПартии.МестоХранения    = Склад; 
            РегПартии.Материал    = ТЧ.Материал; 
            РегПартии.Заказчик    = Заказчик;
            РегПартии.СтрокаЗаявки = _ГУИД;
            РегПартии.Количество    = ТЧ.Количество;
            РегПартии.Заявка = _Остатки.Заявка;
            РегПартии.Объект = _Остатки.Объект;
            РегПартии.ПривязыватьСтроку(ТЧ.НомерСтроки); 
            РегПартии.ДвижениеРасходВыполнить(); 
            _Остатки.Количество = _Остатки.Количество - ТЧ.Количество;
        Иначе
            Сообщить("Количество по накладной > неотпущенного материала по заявке .Документ не будет проведен: "+ТекущийДокумент()+", строка: "+ТЧ.НомерСтроки+
            ", требуется: "+ТЧ.Количество+", по заявке: "+_Остатки.Количество,"!");
            Отказ = 1;
            Продолжить;
        КонецЕсли;    
    КонецЦикла;
   Роспатнюк Сергей Сер
 
17 - 18.04.19 - 17:54
(15) цикла хватить или всю процедуру обработки проведения выложить ?
   hhhh
 
18 - 18.04.19 - 18:00
(17) не, это вам самому надо разбираться, это не типовая. Какие-то ГУИДы, связь по гуидам между строками, это ваши умельцы навояли. думаю где-то не тот гуид стоит в таблице, что-то нарушилось.
   Роспатнюк Сергей Сер
 
19 - 18.04.19 - 18:04
(18) о ну хоть что то ясно спасибо вам за помощь
   Роспатнюк Сергей Сер
 
20 - 18.04.19 - 18:05
(18) не подскажите где можно найти документацию по этой конфе ?
   Роспатнюк Сергей Сер
 
21 - 18.04.19 - 18:06
+ (20) интересует правильная последовательность проведения.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.