Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Итератор для значения не определен

Итератор для значения не определен
Я
   wowas
 
18.04.19 - 11:25
&НаКлиенте
Процедура ПоказатьСравненеие(Команда)
    Для Каждого вЗнч Из Авто Цикл
         нСтр = Элементы.Авто.ТекущиеДАнные;
    КонецЦикла;
      Сообщить(нСтр.Вместимость);
КонецПроцедуры

как исправить эту дичь
 
 
   Euguln
 
1 - 18.04.19 - 11:25
В ДНК попробуй.
   ДенисЧ
 
2 - 18.04.19 - 11:27
А что такое Авто?
   wowas
 
3 - 18.04.19 - 11:28
(2) Динамический список
   Mankubus
 
4 - 18.04.19 - 11:31
(0) закомментируй ее
   Fish
 
5 - 18.04.19 - 11:31
А что требуется сделать?
   Dimeric
 
6 - 18.04.19 - 11:31
Сто процентов поможем
   wowas
 
7 - 18.04.19 - 11:32
(5) Вытащить значение этой ТЧ. Не получается потому что выскакивает ошибка из названия темы
   Dimeric
 
8 - 18.04.19 - 11:33
Попробуй отладкой пройтись, там все прояснится
   VladZ
 
9 - 18.04.19 - 11:33
(0) Дичь нужно сразу удалять.
   Euguln
 
10 - 18.04.19 - 11:33
А в СП разве для динамического списка указана возможность обхода?
   Fish
 
11 - 18.04.19 - 11:34
(7) А ТЧ откуда нарисовалась? В (3) речь шла про динамический список.
   wowas
 
12 - 18.04.19 - 11:36
(11) хорошо, пусть будет динамичсекий список
   Fish
 
13 - 18.04.19 - 11:38
(12) Что значит, хорошо? Ты понимаешь, что чем полнее ты опишешь нам задачу, тем быстрее тебе смогут помочь.
   СтепаDS
 
14 - 18.04.19 - 11:39
(12) Ну, хорошо... пусть будет.
   catena
 
15 - 18.04.19 - 11:40
(12)Начни с того, что объясни себе, зачем в этом коде цикл? Вслух объясняй, чтоб мы тоже послушали.
   wowas
 
16 - 18.04.19 - 11:40
(13) Есть форма выбора справочника. В нем произвольным запросом создан динамический список. В этом динамическом списке есть поле Вместимость. Нужно сообщить значение поля (выбранной строки) по нажатию кнопки. написал код. ругается
   Euguln
 
17 - 18.04.19 - 11:41
(16) Вместимость это реквизит справочника, которого нет в списке?
   wowas
 
18 - 18.04.19 - 11:42
(17) да реквизит, в списке есть. просто нужно его сообщить
   Mankubus
 
19 - 18.04.19 - 11:43
(16) динамический список нельзя обходить циклом
&НаКлиенте 
Процедура ПоказатьСравненеие(Команда) 
         нСтр = Элементы.Авто.ТекущиеДАнные; 
      Сообщить(нСтр.Вместимость); 
КонецПроцедуры
   wowas
 
20 - 18.04.19 - 11:43
(19) Что делать тогда?
   Fish
 
21 - 18.04.19 - 11:44
ОМГ :))
   Euguln
 
22 - 18.04.19 - 11:44
(20) Идите лучше на завод.
   wowas
 
23 - 18.04.19 - 11:45
(22) ТАК Я УЖЕ НА НЕМ)))))))
   wowas
 
24 - 18.04.19 - 11:45
(19) не заметил сразу решение. Дай Бог тебе здоровья
   wowas
 
25 - 18.04.19 - 11:46
(21) я тупой просто


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.