Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Метод объекта не обнаружен (ПолучитьОбъект)

Метод объекта не обнаружен (ПолучитьОбъект)
Я
   zver925
 
18.04.19 - 10:07
Здравствуйте, я новиок в этом, можете подсказать и обьяснить что я делаю не так, внешняя обработка, 2 реквизита в форме: Номенклатура и перечисления.ставкиНдс, с помощию команды пытаюсь установить НДС во всей номенклатуре.

&НаКлиенте
Процедура УстановитьСтавкуНдс(Команда)
    УстановитьСтавкуНДСНаСервере();
КонецПроцедуры
&НаСервере
Процедура установитьСтавкуНДСНаСервере();
      Запрос = новый запрос();
      Запрос.Текст =
         "ВЫБРАТЬ
         |    Номенклатура.СтавкаНДС КАК СтавкаНДС
         |ИЗ
         |    Справочник.Номенклатура КАК Номенклатура
         |ГДЕ
         |    Номенклатура.СтавкаНДС = &СтавкаНДС";
Запрос.УстановитьПараметр("СтавкаНДС",СтавкаНДС);
//РезЗапроса = Запрос.Выполнить;
Номенклатура.СтавкаНДС.ПолучитьОбъект();
Перечисления.СтавкиНдс.ПолучитьОбъект();
Объект.СтавкаНДС = объект.СтавкиНдс;
Объект.СтавкаНДС.записать();

    Сообщить ("Ставка ндс изменена на" + ЭтаФорма.Номенклатура.СтавкаНДС)
      
    
КонецПроцедуры
 
 
   shuhard
 
1 - 18.04.19 - 10:08
(0) "ВЫБРАТЬ 
         |    Номенклатура.ссылка  КАК ТМЦ 
         |ИЗ 
         |    Справочник.Номенклатура КАК Номенклатура 
         |ГДЕ 
         |    Номенклатура.СтавкаНДС = &СтавкаНДС";
   vdeemer
 
2 - 18.04.19 - 10:14
(0) может групповой обработки справочников будет вполне достаточно, чтобы не ваять нетленку?
   SSSSS_AAAAA
 
3 - 18.04.19 - 10:14
(0) Делаешь не так всё.
Зачем выбирать значения ставок, если таки надо обработать номенклатуру?
Зачем выбирать то, на что хочешь заменить? Может таки что-то другое, на равное тому, на что хочешь менять?
Результат запроса надо обрабатывать.
Для изменения ставки НДС в номенклатуре надо получать объект номенклатуры, а не ставки НДС.
Метод записать есть ку объекта, а не его реквизитов..
   ДенисЧ
 
4 - 18.04.19 - 10:15
Где выполнение запроса, где выборка из него?
   НЕА123
 
5 - 18.04.19 - 10:22
ТС шутит что-ли так?
   piter3
 
6 - 18.04.19 - 10:23
(5) новый подаван франчей)
   Darych
 
7 - 18.04.19 - 10:24
(5) ага, выбирает ставку ндс, которую параметром передает))
   Eg0rkas
 
8 - 18.04.19 - 10:57
как-то так наверное

Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Номенклатура.Ссылка
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.СтавкаНДС <> &СтавкаНДС";
    
    Запрос.УстановитьПараметр("СтавкаНДС", Объект.СтавкаНДС);    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбъектНоменклатура = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
        ОбъектНоменклатура.СтавкаНДС = Объект.СтавкаНДС;//либо Перечисления.СтавкиНДС.Ставка20

        ОбъектНоменклатура.Записать();
    КонецЦикла;
   piter3
 
9 - 18.04.19 - 10:58
И еще пропускаете,что может быть пустаяссылка
   ДенисЧ
 
10 - 18.04.19 - 11:00
(8) Работаете на бисерной фабрике?
   Eg0rkas
 
11 - 18.04.19 - 11:07
(10) нет, накидал в учебной базе по быстрому. я и сам стажер еще в общем-то
   Йохохо
 
12 - 18.04.19 - 11:17
(11) санкта симплиситас против дабл пенетрейшен, раз уж сегодня пятница пронеслась
   VladZ
 
13 - 18.04.19 - 11:28
(0) Совет на будущее:  ошибка вида "Метод объекта не обнаружен (ПолучитьОбъект)" означает, что ты написал бред. Открываешь букварь и читаешь описание.
   AlvlSpb
 
14 - 18.04.19 - 13:04
(0) Самый дельный совет в (2). Все давно придумано до нас. В любой типовой есть обработка Групповое изменение справочников и документов. Это то что тебе надо
   catena
 
15 - 18.04.19 - 13:09
(14)Особенно при решении тестовых задач))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.