Вход | Регистрация
 

Как программно поменять проводки в документе?

Как программно поменять проводки в документе?
Я
   Shecurok
 
17.04.19 - 14:01
Надо чтобы в документе ПередачаМатериалаВЭксплуатацию у Номенклатуры Шины автоматически ставился номер счета МЦ5 вместо МЦ4. Есть код как это делается с базы БП 2.0 (я работаю в БП 3.0). Но что куда прописывать не пойму.
 
 
   Sasha_1CK
 
1 - 17.04.19 - 14:14
(0) Делаешь обработку подписки на событие проведения
Процедура ОбработкаПроведения_ОприходованиеТоваров(Источник, Отказ, РежимПроведения) Экспорт
    
    ВидСубконтоПрочиеДоходыИРасходы = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПрочиеДоходыИРасходы;
    Для каждого Движение Из Источник.Движения.Хозрасчетный Цикл
        Если Движение.СчетКт = ПланыСчетов.Хозрасчетный.ПрочиеДоходы тогда
            Движение.СчетКт = Источник.СчетЗатрат;
            Движение.СубконтоКт.очистить();
            БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, 1, ИСточник.Субконто1);
            БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, 2, ИСточник.Субконто2);
            БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, 3, ИСточник.Субконто3);
            Движение.ПодразделениеКт =  Источник.ПодразделениеЗатрат;
        КонецЕсли;
    КонецЦикла; 
    Источник.Движения.Хозрасчетный.Записывать = Истина;

КонецПроцедуры


Аналитику изменять не обязательно
   kzot
 
2 - 17.04.19 - 14:47
МЦ05 это у вас что там или зачем ?
   Shecurok
 
3 - 17.04.19 - 14:48
(2) Честно и не скажу. Так бухам надо.
   kzot
 
4 - 17.04.19 - 14:49
(3) сами ввели сами пусть и мозг себе выносят, скажи это только через доработку.
   kzot
 
5 - 17.04.19 - 15:25
(4)+ там всё через запрос, и там "ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации) КАК СчетМЦ,"
смотри Функция ПодготовитьПараметрыПроведения(ДокументСсылка, Отказ) +Функция ТекстЗапросаПередачаИнвентаря(НомераТаблиц) модуль менеджера документа.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.