Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с документом РегистрацияЦенНоменклатурыПоставщика

Проблема с документом РегистрацияЦенНоменклатурыПоставщика
Я
   НачинающийВ1С
 
16.04.19 - 13:41
Добрый день.

Конфигурация 1С:Комплексная автоматизация 2 (2.4.7.109)
В моей обработке на одном из этапов мне нужно в регистре ЦеныНоменклатурыПоставщиков создать записи с новыми ценами.
Для этого я создаю программно документ РегистрацияЦенНоменклатурыПоставщика, заполняю табличную часть и провожу его.
Все работает, в регистре записи появляются. Однако, если открывать интерактивно документ ЦеныНоменклатурыПоставщиков, он почему-то пустой. Открываю другие документы - там все правильно заполнено.

При этом если в консоли запросов открывать оба документа (правильно заполненный и мой), разницы никакой нет. Все те же самые поля заполнены, та же самая табличная часть заполнена.
Что я делаю не так?

Ниже привожу алгоритм создания документа (до выполнения этой процедуры в обработке я в Объект.Товары загрузил все товары с ценами, по которым нужны записи в регистре) :

&НаСервере
Процедура    ПроводимДокументНаСервере();
        
    Если Объект.Док = Документы.РегистрацияЦенНоменклатурыПоставщика.ПустаяСсылка() тогда
        Документ = Документы.РегистрацияЦенНоменклатурыПоставщика.СоздатьДокумент();
        Документ.Комментарий = "Создано с помощью внешней обработки ""Загрузка прайса закупочных цен из Excel""";
        Документ.Ответственный = Пользователи.ТекущийПользователь();
        Документ.Дата = ТекущаяДатаСеанса();
        Документ.Партнер = Объект.Партнер;
        Объект.Док = Документ.Ссылка;
    КонецЕсли;
    ДокументОбъект = Объект.Док.ПолучитьОбъект();
    Для Каждого СтрокаТЧ из Объект.Товары Цикл
    Строка = ДокументОбъект.Товары.Добавить();
    Строка.ВидЦеныПоставщика = СтрокаТЧ.ТипЦен;
    Строка.Номенклатура = СтрокаТЧ.Номенклатура;
    Строка.Цена = СтрокаТЧ.Цена;
    КонецЦикла;
    ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
    
КонецПроцедуры
 
 
   НачинающийВ1С
 
1 - 16.04.19 - 14:21
Совсем никто не сталкивался с подобным?
   bolero
 
2 - 16.04.19 - 14:30
выгрузи правильный и неправильный документы в XML или через OData, и сравни глазами

желательно неправильный создать с точно такими же данными, как правильный - проще будет
   НачинающийВ1С
 
3 - 16.04.19 - 17:14
(2) Спасибо.


Короче разобрался, я создавал документ на основании данных, которые в обработке выбирал интерактивно. Оказалось что справочник ВидыЦенПоставщика подчинен справочнику Партнеры, а я выбирал не связанные друг с другом элементы. В этом была проблема. Накинул отбор по владельцу на форму выбора вида цен, сразу все заработало как надо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.