Вход | Регистрация
 

Как программно сформиров движения в регистре накопления? Не пойму в чем ошибка?

Как программно сформиров движения в регистре накопления? Не пойму в чем ошибка?
Я
   gabd_marat
 
14.04.19 - 16:49
&НаСервере
Процедура СформироватьДвиженияРегистраНакпленияТоварыНаСкладах(Параметры) Экспорт
    
    ВыбранныйРегистраторСсылка = Параметры.ДокументСсылка;
    
    НаборЗаписей = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();      

    НаборЗаписей.Отбор.Регистратор.Установить(ВыбранныйРегистраторСсылка);
    
    Для Каждого ТекСтрокаТовары Из Параметры.тзТовары  Цикл    

        НоваяЗапись = НаборЗаписей.Добавить();  
        
        Если ТипЗнч(ВыбранныйРегистраторСсылка) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
        
            НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Расход;
        
        ИначеЕсли ТипЗнч(ВыбранныйРегистраторСсылка) = Тип("ДокументСсылка.ПоступлениеТовара") Тогда
            
            НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Приход;
            
        КонецЕсли;        

        НоваяЗапись.Регистратор = ВыбранныйРегистраторСсылка;      

        НоваяЗапись.Период         = Параметры.Дата;      

        НоваяЗапись.Номенклатура = ТекСтрокаТовары.Номенклатура;
        
        НоваяЗапись.Количество = ТекСтрокаТовары.Количество;        

        НоваяЗапись.Сумма = ТекСтрокаТовары.Сумма;      
        
    КонецЦикла;
    
    НаборЗаписей.Записать();
    
КонецПроцедуры
 
 
   gabd_marat
 
1 - 14.04.19 - 16:51
НаборЗаписей.Записать(); 
по причине:
Ошибка записи! Не установлен отбор по регистратору (Регистр накопления: Товары на складах)
   gabd_marat
 
2 - 14.04.19 - 16:51
Регистр накопления остаточный
   palsergeich
 
3 - 14.04.19 - 17:11
ВыбранныйРегистраторСсылка точно не пустая ссылка?
   palsergeich
 
4 - 14.04.19 - 17:11
НоваяЗапись.Регистратор = ВыбранныйРегистраторСсылка;       
Вот эта строка лишняя
   palsergeich
 
5 - 14.04.19 - 17:12
Ты уже задал регистратора, когда установил отбор
   gabd_marat
 
6 - 14.04.19 - 17:17
(5) для оборотного регистра норм для остаточного ошибку выдает
   palsergeich
 
7 - 14.04.19 - 17:24
Этот регистратор является регистратором для этого регистра в метаданных?
   palsergeich
 
8 - 14.04.19 - 17:26
С точки зрения набора записей разница между остаточным и оборотным регисторм только в этом. НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Приход; 
Точно не забыли галку поставить в документах, которые являются оегистраторами для этого регистра?
   nicxxx
 
9 - 14.04.19 - 17:29
Параметры.ДокументСсылка - здесь передали документ, который не является регистратором для регистра.
   gabd_marat
 
10 - 14.04.19 - 17:36
(9) хорошо, посмотрю
   gabd_marat
 
11 - 14.04.19 - 17:37
(9) (8) да ошибка в это, галочку не поставил

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.