Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как правильно откорректировать записи регистра сведений

Как правильно откорректировать записи регистра сведений
Я
   1сЮлия
 
11.04.19 - 11:38
Добрый день! Создала свой документ Сторнирование, у которого регистраторы мои добавленные нетиповые регистры РегистрНакопления ОперацииКВЛ и РегистрСведений РезультатыСертификацииНоменклатуры, у которого я добавила измерение Актуальность и при сторнировке должна Актоуальность стать равна Ложь . Как сдесь мне проиписать это?
Процедура ЗаполнитьДвижениеСторно(Движение, Строка, МетаданныеОбъект)
    
     // измерения
    Для Каждого МДОбъект из МетаданныеОбъект.Измерения Цикл
        Движение[МДОбъект.Имя] = Строка[МДОбъект.Имя];
    КонецЦикла;

    // ресурсы
    Для Каждого МДОбъект из МетаданныеОбъект.Ресурсы Цикл
        Движение[МДОбъект.Имя] = - Строка[МДОбъект.Имя];
    КонецЦикла;
        
    // реквизиты
    Для Каждого МДОбъект из МетаданныеОбъект.Реквизиты Цикл
        Движение[МДОбъект.Имя] = Строка[МДОбъект.Имя];
    КонецЦикла;
КАК ПО РегиструСведение прописать  

КонецПроцедуры // ЗаполнитьДвижениеСторно
 
 
   1сЮлия
 
1 - 11.04.19 - 11:53
НаборЗаписей=РегистрыСведений.РезультатыСертификацииНоменклатуры.СоздатьНаборЗаписей();
    Если Движение=НаборЗаписей Тогда
        // измерения

        Для Каждого МДОбъект из МетаданныеОбъект.Измерения Цикл
            Если Строка[МДОбъект.Имя]=Строка(МДОбъект.Имя) Тогда
            КонецЕсли;    
        КонецЦикла;
        // реквизиты

        Для Каждого МДОбъект из МетаданныеОбъект.Реквизиты Цикл
            Движение[МДОбъект.Имя] = Строка[МДОбъект.Имя];
        КонецЦикла;
 КонецЕсли;Мне нужно,чтобы значение Актуальность поменялось на Ложь
   1сЮлия
 
2 - 11.04.19 - 11:53
Акуальность это измерение

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.