Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при записи в рег. контактная информация.

Ошибка при записи в рег. контактная информация.
Я
   SkillUp
 
11.04.19 - 11:32
Пардон ребят, не мой сегодня день, подскажите из-за чего ошибка?
КОД:

            //СОЗДАЕМ КОНТРАГЕНТА
            
            СпрКонтрагент              = Справочники.Контрагенты.СоздатьЭлемент();
            СпрКонтрагент.Наименование = стр.ФИО;
            СпрКонтрагент.ОсновнойМенеджерПокупателя = ПолеВвода3;
            СпрКонтрагент.НаименованиеПолное = стр.ФИО;
            СпрКонтрагент.ЮрФизЛицо    = Перечисления.ЮрФизЛицо.ФизЛицо;
            СпрКонтрагент.Покупатель   = Истина;
            СпрКонтрагент.Родитель = Выбрано;
            СпрКонтрагент.Записать();
            
            //ЗАПОЛНЯЕМ ИНФОРМАЦИЮ О КОНТРАГЕНТЕ
            //ТЕЛЕФОН
            НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Объект.Установить(СпрКонтрагент);
            НаборЗаписей.Отбор.Тип.Установить(Перечисления.ТипыКонтактнойИнформации.Телефон);
            НаборЗаписей.Отбор.Вид.Установить(Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);
            НаборЗаписей.Прочитать();
            Если НаборЗаписей.Количество() > 0 Тогда
                Для каждого Запись из НаборЗаписей Цикл
                    Если Запись.Вид = Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Телефон контрагента") Тогда
                        Запись.Представление = стр.телефон;    
                    КонецЕсли;
                КонецЦикла;                
            Иначе
                НовСтр = НаборЗаписей.Добавить();
                НовСтр.Объект = СпрКонтрагент;
                НовСтр.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
                НовСтр.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента;
                НовСтр.Представление = стр.телефон;
            КонецЕсли;  
            НаборЗаписей.Записать();


Ошибка:

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(151)}: Ошибка при вызове метода контекста (Записать)
            НаборЗаписей.Записать();
по причине:
Не удалось записать: "Контактная информация"!
 
 
   SkillUp
 
1 - 11.04.19 - 11:37
Ошибка когда  Если НаборЗаписей.Количество() = 0 Тогда , т.е. пытаюсь добавить запись в регистр, по ветке

 Иначе 
                НовСтр = НаборЗаписей.Добавить(); 
                НовСтр.Объект = СпрКонтрагент; 
                НовСтр.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон; 
                НовСтр.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента; 
                НовСтр.Представление = стр.телефон; 
            КонецЕсли;   
            НаборЗаписей.Записать();
   ГдеСобакаЗарыта
 
2 - 11.04.19 - 11:43
Наверно надо отладчиком смотреть в модуле набора записей
   SkillUp
 
3 - 11.04.19 - 12:05
(2) Мда... НовСтр.Объект = СпрКонтрагент; Объект, вместо ссылки. НЕ МОЙ ДЕНЬ! Пардон ребят за глупый вопрос...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.