Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

передача значения на форму подбора

передача значения на форму подбора
Я
   wowas
 
09.04.19 - 21:06
В документе с ТЧ Номенклатура есть кнопка подбора по которой открывается форма с реквизитами Адрес и Выручка. Адрес является одним из условий отбора в ТЧ (это сделал все хорошо), а Выручка просто вспомогательный реквизит (не важно для чего). Как сделать чтобы Выручка заполнялась из документа поля Цена ТЧ Номенклатура?

&НаКлиенте
Процедура Подбор(Команда)

        ПараметрыПередачи = Новый Структура;
         СтруктураОтбора = Новый Структура;
         СтруктураОтбора.Вставить("Адрес",Объект.Адрес);
         ПараметрыПередачи.Вставить("Отбор",СтруктураОтбора);
      
       ОткрытьФорму("Справочник.ТранспортныеСредства.ФормаВыбора",ПараметрыПередачи, Элементы.Номенклатура);
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
        Авто.Параметры.УстановитьЗначениеПараметра("Адрес", Параметры.Отбор.Адрес);
        Адрес=Параметры.Отбор.Адрес;
    
КонецПроцедуры
 
 
   Жан Пердежон
 
1 - 10.04.19 - 06:30
ПараметрыПередачи.Вставить("Выручка",Выручка); 

далее, догадаешься
   wowas
 
2 - 10.04.19 - 08:11
(1) я тупой((( не догадаюсь((( расскажи плес
   dexter_86
 
3 - 10.04.19 - 08:54
&НаКлиенте 
Процедура Подбор(Команда) 

        ПараметрыПередачи = Новый Структура;
 ПараметрыПередачи.Вставить("Выручка",Выручка); 
         СтруктураОтбора = Новый Структура; 
         СтруктураОтбора.Вставить("Адрес",Объект.Адрес); 
         ПараметрыПередачи.Вставить("Отбор",СтруктураОтбора); 
       
       ОткрытьФорму("Справочник.ТранспортныеСредства.ФормаВыбора",ПараметрыПередачи, Элементы.Номенклатура); 
КонецПроцедуры 


&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) 
     
        Авто.Параметры.УстановитьЗначениеПараметра("Адрес", Параметры.Отбор.Адрес); 
        Адрес=Параметры.Отбор.Адрес; 
     Выручка = Параметры.Выручка;
КонецПроцедуры
   wowas
 
4 - 10.04.19 - 11:48
(3) Дай Бог тебе здоровья

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.