Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ошибка в внешней печатной форме -Не соответствие типов (пареметр 1)

ошибка в внешней печатной форме -Не соответствие типов (пареметр 1)
Я
   lite777
 
09.04.19 - 11:47
Внешняя печатная форма , для зуп3,1 с формой для отладки , ошибка при работе через форму обработки

&НаКлиенте
Процедура Печать(Команда)
    
    Если ЗначениеЗаполнено(Объект.Документ) Тогда
        ПолучитьСтруктуруДляПечатиНаСервере();
    Иначе
        Сообщить("Не выбран документ!",СтатусСообщения.Важное);
    КонецЕсли;
    
КонецПроцедуры

//**********************************************************
&НаСервере
Процедура ПолучитьСтруктуруДляПечатиНаСервере()
    
    //Массив объектов
    МассивОбъектов = Новый Массив;
    МассивОбъектов.Добавить(Объект.Документ);
    
    //Параметры печати
    ПараметрыПечати = Новый Структура;
    ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами",Ложь);
    ПараметрыПечати.Вставить("ТребуетсяЧтениеБезОграничений",Истина);
    
    //Объекты печати
    ОбъектыПечати = Новый Массив;
    
    //Коллекция печатных форм
    КоллекцияПечатныхФорм = Новый ТаблицаЗначений;
    КоллекцияПечатныхФорм.Колонки.Добавить("ИмяМакета");
    КоллекцияПечатныхФорм.Колонки.Добавить("ИмяВРЕГ");
    КоллекцияПечатныхФорм.Колонки.Добавить("СинонимМакета");
    КоллекцияПечатныхФорм.Колонки.Добавить("ТабличныйДокумент");
    КоллекцияПечатныхФорм.Колонки.Добавить("Экземпляров");
    КоллекцияПечатныхФорм.Колонки.Добавить("Картинка");
    КоллекцияПечатныхФорм.Колонки.Добавить("ПолныйПутьКМакету");
    КоллекцияПечатныхФорм.Колонки.Добавить("ИмяФайлаПечатнойФормы");    
    НоваяСтрока = КоллекцияПечатныхФорм.Добавить();
    НоваяСтрока.ИмяМакета = "Договор2";
    НоваяСтрока.ИмяВРЕГ = "Договор2";
    НоваяСтрока.Экземпляров = 1;
    
    ТекОбъект = РеквизитФормыВЗначение("Объект");
    ТекОбъект.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати);
    
    //Вернем первый дкоумент коллекции
    ЭтаФорма.Результат.Очистить();
    ЭтаФорма.Результат.Вывести(КоллекцияПечатныхФорм[0].ТабличныйДокумент);  //ОШИБКА на этой СТРОКЕ -НЕ СООТВЕТСВИЕ ТИПОВ (ПАРАМЕТР 1)
    
КонецПроцедуры
 
 
   1Сергей
 
1 - 09.04.19 - 11:49
смотри что в ТекОбъект.Печать( делается
   Ёпрст
 
2 - 09.04.19 - 11:50
(0)КоллекцияПечатныхФорм[0].ТабличныйДокумент не является табличным документом
   yzimin
 
3 - 09.04.19 - 11:50
видимо забыл это
НоваяСтрока.ТабличныйДокумент = Новый ТабличныйДокумент;
   lite777
 
4 - 09.04.19 - 11:52
да это строка документа
   lite777
 
5 - 09.04.19 - 12:04
у кого нить есть пример обработки печати с формой для выбора дока ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует