Вход | Регистрация
 

XMLPath. РезультатXPath перебор атрибутов

XMLPath. РезультатXPath перебор атрибутов
Я
   nAPACEHAK
 
08.04.19 - 13:06
Доброго

есть ХМЛка
            ПрицепВесТовара="0"
            ПунктРазгрузки="ДМС"/>
    <Фото КартинкаФотоПустой1="Отгрузка_00МИ-003828_КартинкаФотоПустой1_01112018-074202.jpeg"
            КартинкаФотоПустой2="Отгрузка_00МИ-003828_КартинкаФотоПустой2_01112018-074202.jpeg"
            КартинкаФотоСГрузом1="Отгрузка_00МИ-003828_КартинкаФотоСГрузом1_01112018-074202.jpeg"
            КартинкаФотоСГрузом2="Отгрузка_00МИ-003828_КартинкаФотоСГрузом2_01112018-074202.jpeg"/>
    <Служебные Состояние="Выгружено"/>
</ROOT>


Как перебрать атрибуты элемента "Фото"? 

Об.ВесТовара = Число (РезультатXPath(ДокументDOM, "//ROOT/Документ/@ВесТовара")); // ну тут все понятно


ДобавитьКартинкиКДокументу (Об.Ссылка, РезультатXPath(ДокументDOM, "//ROOT/Фото", Ложь));


&НаСервере
Процедура ДобавитьКартинкиКДокументу (ДокСсылка, Знач ФотоXPath)
    Добавлено = Ложь;
    Пока ФотоXPath.ПолучитьСледующий () <> Неопределено Цикл
        Добавлено = Истина;    
        ///     как вот тут пробежаться по атрибутам? Нужно получить пару имя-значение

    КонецЦикла;     
КонецПроцедуры



Спасибо
 
 
   nAPACEHAK
 
1 - 08.04.19 - 13:20
а, ладно, вроде сделал.
Всеравно, может подскажете с xpath как можно было?

&НаСервере
Процедура ДобавитьКартинкиКДокументу (ДокСсылка, ДокументDOM)
    Элемент = ДокументDOM.ПолучитьЭлементыПоИмени("Фото");
    Если Элемент.Количество() = 0 Тогда
        Возврат;    
    КонецЕсли; 
    
    Для каждого Атрибут Из Элемент[0].Атрибуты Цикл
        А = Атрибут.Имя;//блаблабла    

    КонецЦикла;     
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.