Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Виды оплаты в БП 3

Виды оплаты в БП 3
Я
   isa2net
 
06.04.19 - 00:30
Доброго!

В БП 3.0.69.35 в справочнике Виды оплат организации убран тип оплаты наличными. Из каких методологических соображений?
Есть мысль, что поскольку наличные фискализируются, то тип оплат идет из перечисления ТипОплаты.ккт  

[/1c]
Функция ПолучитьДоступныеЗначенияТипаОплаты()

    ТипОплатыДоступныеЗначения = Новый Массив;
    
    Для каждого ЭлементОтбора Из Список.Отбор.Элементы Цикл
    
        Если НЕ ЭлементОтбора.Использование Тогда
            Продолжить;
        КонецЕсли;
        
        Если Строка(ЭлементОтбора.ЛевоеЗначение) <> "ТипОплаты" Тогда
            Продолжить;
        КонецЕсли;
        
        Если ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно Тогда
            ТипОплатыДоступныеЗначения.Добавить(ЭлементОтбора.ПравоеЗначение);
        КонецЕсли;
        
        Если ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке Тогда
            Для каждого ЭлементСпискаЗначений Из ЭлементОтбора.ПравоеЗначение Цикл
                ТипОплатыДоступныеЗначения.Добавить(ЭлементСпискаЗначений.Значение);
            КонецЦикла;
        КонецЕсли;

    КонецЦикла;
    
    Если ТипОплатыДоступныеЗначения.Количество() = 0 Тогда
        
        ТипОплатыДоступныеЗначения.Добавить(ПредопределенноеЗначение("Перечисление.ТипыОплат.ПлатежнаяКарта"));
        ТипОплатыДоступныеЗначения.Добавить(ПредопределенноеЗначение("Перечисление.ТипыОплат.БанковскийКредит"));
        
        Если ИспользуютсяПодарочныеСертификаты Тогда
            
            ТипОплатыДоступныеЗначения.Добавить(ПредопределенноеЗначение("Перечисление.ТипыОплат.ПодарочныйСертификатСобственный"));
            
            Если ИспользуетсяКомиссияНаПродажу Тогда
                ТипОплатыДоступныеЗначения.Добавить(ПредопределенноеЗначение("Перечисление.ТипыОплат.ПодарочныйСертификатСторонний"));
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЕсли;

    Возврат ТипОплатыДоступныеЗначения;

КонецФункции

[/1c]
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.