Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Переподставление товара

Переподставление товара
Я
   AbyGail
 
04.04.19 - 12:16
В модуле документа нужно создать экспортную процедуру, которая бы переподставляла бы цену покупки. Цены берутся из регистра сведений в соответствии с контрагентом документа.  
Проблема в том что я все сделала, но ничего не работает. И даже ошибку не выдает.
ПОМОГИТЕЕЕ!!!

Вот код:
//(Форма Документа)
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
    ПересчитатьНаСервере();
КонецПроцедуры


&НаСервере
Процедура ПересчитатьНаСервере()
     Документ=РеквизитФормыВЗначение("Объект");
     Документ.Пересчитать();
     ЗначениеВРеквизитФормы(Документ,"Объект");
КонецПроцедуры

//(Модуль объекта)
Процедура Пересчитать()Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|    ПоступлениеТоваровТовары.Номенклатура,
|    ПоступлениеТоваровТовары.Количество,
|    ПоступлениеТоваровТовары.Серия
|ПОМЕСТИТЬ ТЧР
|ИЗ
|    Документ.ПоступлениеТоваров.Товары КАК ПоступлениеТоваровТовары
|ГДЕ
|    ПоступлениеТоваровТовары.Ссылка = &Ссылка
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
|    ТЧР.Номенклатура,
|    ТЧР.Количество,
|    ТЧР.Серия,
|    ЦеныПоставщиковСрезПоследних.Цена,
|    ЦеныПоставщиковСрезПоследних.Цена * ТЧР.Количество КАК Цена1
|ИЗ
|    ТЧР КАК ТЧР
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныПоставщиков.СрезПоследних(
|                &Дата,
|                Контрагент = &Контрагент
|                    И Номенклатура В
|                        (ВЫБРАТЬ РАЗЛИЧНЫЕ
|                            ТЧР.Номенклатура
|                        ИЗ
|                            ТЧР)) КАК ЦеныПоставщиковСрезПоследних
|        ПО (ТЧР.Номенклатура = ЦеныПоставщиковСрезПоследних.Номенклатура)";

Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Ссылка",Ссылка);
Запрос.УстановитьПараметр("Контрагент",Контрагент);

ТЗ=Запрос.Выполнить().Выгрузить();
Товары.Очистить();
Товары.Загрузить(ТЗ);
    

КонецПроцедуры
 
 
   Про100Филя
 
1 - 04.04.19 - 12:18
Без фотки не взлетит.
Форму надо обновлять
   AbyGail
 
2 - 04.04.19 - 12:22
Я новичок в 1с, и не очень понимаю что и как делать (((
   mikecool
 
3 - 04.04.19 - 12:23
"я все сделала, но ничего не работает." 
шикарно, продолжайте в том же духе )))
   AbyGail
 
4 - 04.04.19 - 12:26
mikecool, не надо так ))) Я учусь по методичке. я все сделала как сказано в методичке, но не работает. ))
   Про100Филя
 
5 - 04.04.19 - 12:29
&НаКлиенте 
Процедура КонтрагентПриИзменении(Элемент) 
    ПересчитатьНаСервере(); 
    Элементы.Товары.Обновить();
КонецПроцедуры 

&НаСервере 
Процедура ПересчитатьНаСервере() 
     РеквизитФормыВЗначение("Объект").Пересчитать(РеквизитФормыВЗначение("Объект.Товары")); 
КонецПроцедуры 

//(Модуль объекта) 

Процедура Пересчитать(ТзТовары)Экспорт 
...
ТзТовары=Запрос.Выполнить().Выгрузить(); 
КонецПроцедуры
   Про100Филя
 
6 - 04.04.19 - 12:30
+(5) Ну при условии что в запросе колонки с тем же типом и так же называются.
   AbyGail
 
7 - 04.04.19 - 12:41
(6) Спасибо большое... Там те же колонки, с тем же типом, но, увы, не работает (((
   МимохожийОднако
 
8 - 04.04.19 - 12:45
Для начала возьми консоль и проверь запрос.
   Митяйский
 
9 - 04.04.19 - 12:48
Перед всей подобной свистопляской надо сделать Объект.записать()
   AbyGail
 
10 - 04.04.19 - 14:15
(8) в консоли появляется Пустая ТЧР...
(9) Сделала, Не помогло.

Код точь в точь как у моих коллег, у них работает, у меня нет (((
   sqr4
 
11 - 04.04.19 - 14:46
Я не понял, фото в профиль будет или нет?!
Типы поля "Номенклатура" у документа и регистра одинаковые?
Цена вообще заполнена? Дата документа больше или меньше даты заполненной цены?
   sqr4
 
12 - 04.04.19 - 14:48
(2) Т.к вы новичок в 1с, прошу обратить внимание что многие 1с помогают с годом по фотографии, это много сильно ускоряет процесс выдачи решения.
   AbyGail
 
13 - 04.04.19 - 15:24
(11) Да, с этим все в порядке... другие процедуры  с теми же полями работают, но вот именно эта нет.
(12) Причем тут фото?
   sqr4
 
14 - 04.04.19 - 15:27
(13) Не верю
при том)
   AbyGail
 
15 - 04.04.19 - 15:33
(14) упс, я не поняла что там опечатка. Где скинуть этот чертов код ?
   sqr4
 
16 - 04.04.19 - 15:37
(15) Сначала фото, потом код.
   AbyGail
 
17 - 04.04.19 - 15:37
(16) о Господи, что за фотка? :D
   sqr4
 
18 - 04.04.19 - 15:40
(17) я сдаюсь, давай код
   sqr4
 
19 - 04.04.19 - 15:40
Куда хочешь скидывай
   sqr4
 
20 - 04.04.19 - 15:42
https://dropmefiles.com/
сюда например
   AbyGail
 
21 - 04.04.19 - 15:46
   sqr4
 
22 - 04.04.19 - 15:48
(21) Базу давай
   Chameleon1980
 
23 - 04.04.19 - 15:48
и пин код
   AbyGail
 
24 - 04.04.19 - 15:51
(22) Загрузила
(23) нету
   dezss
 
25 - 04.04.19 - 15:52
(17) Фотка в профиле)))
   sqr4
 
26 - 04.04.19 - 16:07
Фотка уже в профиле?)
   sqr4
 
27 - 04.04.19 - 16:07
Ну и ладно, событию при изменении контрагента не назначен обработчик.
   Про100Филя
 
28 - 04.04.19 - 16:11
(27) Это 10 из 10.
   МимохожийОднако
 
29 - 04.04.19 - 16:14
(10) Пока не добьешься в консоли нужной таблице дальше идти бесполезно. Проверь предварительно заполнение выбранного документа, регистра сведений Цены поставщиков, соответствие выбранного контрагента и списка товаров.
   _Дайвер_
 
30 - 04.04.19 - 16:17
Не мешайте ей делать фото
 
 Рекламное место пустует
   Про100Филя
 
31 - 04.04.19 - 16:23
(17) Можно сразу ссылку на инстаграм.
   AbyGail
 
32 - 04.04.19 - 18:36
(31) скинь скайп, Пожалуйста
   МимохожийОднако
 
33 - 04.04.19 - 18:58
(32) Девушка, вышлите ему фото на конец )
   AbyGail
 
34 - 04.04.19 - 20:47
(33) я не понимаю что за фото ... надеюсь что я тупая и не дагоняю, а не имеется в веду мое личное фото на аватарке ...  :D XD
   МимохожийОднако
 
35 - 04.04.19 - 21:03
(34) Поясню. На этом форуме традиция. Некоторые лица мужского пола помогают дамам только после лицезрения фото. ))
   МимохожийОднако
 
36 - 04.04.19 - 21:03
...в личной карточке
   dezss
 
37 - 05.04.19 - 09:38
(34) Именно оно и имеется в виду)))
   Eg0rkas
 
38 - 05.04.19 - 09:59
(5) Вот здесь же вроде все правильно написали.
В процедуре Пересчитать не хватает параметров, которые внутри нее есть.
то есть нужно как-то так "Процедура Пересчитать(Дата, Ссылка, Контрагент) Экспорт" и при вызове этой процедуры передавать эти параметры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.