Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Доступ на форме отдельных реквизитам

Доступ на форме отдельных реквизитам
Я
   ac13
 
04.04.19 - 11:40
[1C]&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
     Если Объект.Рассчитан = Истина Тогда
          ТолькоПросмотр = Истина;
     КонецЕсли;

КонецПроцедуры[/1C]

Мне нужно, чтобы для отдельной роли были доступны отдельные реквизиты, например

[1C]Если РольДоступна("Привилегии") Тогда
     ДатаРасчета.ТолькоПросмотр = Ложь;
КонецЕсли;[/1C]

Как это правильно сделать?
 
 
   YaFedor
 
1 - 04.04.19 - 11:42
Запретить все, кроме нужных
   ac13
 
2 - 04.04.19 - 11:46
(1) как это правильно сделать?
   OldCondom
 
3 - 04.04.19 - 11:51
Для начала:
ТолькоПросмотр = Объект.Рассчитан;
ДатаРасчета.ТолькоПросмотр = РольДоступна("Привилегии");

>> Как это правильно сделать?
Как в типовых. Посмотри номенклатуру. Там описывают каждый реквизит отдельно и не парятся. 
        ЕстьПравоРедактированияКартинки    = ПравоДоступа("Редактирование", Метаданные.Справочники.Номенклатура.Реквизиты.ФайлКартинки);
        Элементы.ФайлКартинки.Доступность = ЕстьПравоРедактированияКартинки;
        Элементы.ДобавитьИзображение.Доступность = ЕстьПравоРедактированияКартинки;
        Элементы.ИзменитьИзображение.Доступность = ЕстьПравоРедактированияКартинки;
        Элементы.ОчиститьИзображение.Доступность = ЕстьПравоРедактированияКартинки;
        Элементы.ВыбратьКартинкуИзПрисоединенныхФайлов.Видимость = ЕстьПравоРедактированияКартинки;
   ac13
 
4 - 04.04.19 - 12:04
(3) У меня есть типовая процедура формы ПриСозданииНаСервере где и прописан 
ТолькоПросмотр = Истина;
Эту процедуру трогать не хотел, нужно только приписать типа

Если РольДоступна("Привилегии") Тогда 
     Элементы.ДатаРасчета.ТолькоПросмотр = Ложь; 
КонецЕсли;

Но Элементы доступны только &НаКлиенте
   OldCondom
 
5 - 04.04.19 - 12:08
Аккуратнее с ТолькоПросмотр для формы. Там есть нюансы.

>> Но Элементы доступны только &НаКлиенте
Так передай форму на сервер в параметре.
   Cyberhawk
 
6 - 04.04.19 - 12:10
С установленным у формы свойством "ТолькоПросмотр" в истину далеко не уедешь
   ac13
 
7 - 04.04.19 - 12:15
(6) ну вот мне и надо, когда доступна роль, то на пару реквизитов этот ТолькоПросмотр не устанавливать
   OldCondom
 
8 - 04.04.19 - 12:25
(7) ты в курсе, что только просмотр скрывает кнопки "провести" "записать" и т.д.?
   OldCondom
 
9 - 04.04.19 - 12:26
к тому, что это не панацея и в целом неправильный вариант.
   ac13
 
10 - 04.04.19 - 13:31
(8) да, в курсе, эти кнопки мне тоже открыть надо. решил проблему перебором реквизитов
   Cyberhawk
 
11 - 04.04.19 - 13:56
(7) Ну только перебор, а у формы свойство не ставить

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.