Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Прайс-лист с картинками

Прайс-лист с картинками
Я
   yurik85
 
04.04.19 - 11:23
Добрый день.
В конфигурации УНФ 1.5 пытаюсь написать отчет прайс-лист с картинками. Изучил достаточно много форумов.
Но не получается реализовать. Сделал отчет СКД. Получаю в запросе ссылки на номенклатуру и на элемент справочника НоменклатураПрисоединенныеФайлы.
В модуле отчета вставил процедуру ПриКомпоновкеРезультата и там заполняю область полученной картинкой. Текст модуля ниже. Но в итоге в отчете только список номенклатур, а в колонке Картинка пусто.
Подскажите, в чем может быть проблема?
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    НастройкиКомпоновки = КомпоновщикНастроек.ПолучитьНастройки();
    
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиКомпоновки, ДанныеРасшифровки);
    
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки);
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    
    КоличествоСтрок = ДокументРезультат.ВысотаТаблицы ;
    КоличествоКолонок = ДокументРезультат.ШиринаТаблицы;
    
    Для СтрокаДокумента = 1 По КоличествоСтрок Цикл
        
        Для КолонкаДокумента = 1 По КоличествоКолонок Цикл
            
            Область = ДокументРезультат.Область(СтрокаДокумента, КолонкаДокумента);
            
            Расшифровка = Область.Расшифровка;
            
            Если ТипЗнч(Расшифровка) = Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда
                
                ПоляРасшифровки = ДанныеРасшифровки.Элементы.Получить(Расшифровка).ПолучитьПоля();
                
                НайденноеПоле = ПоляРасшифровки.Найти("Картинка");
                
                Если НайденноеПоле <> Неопределено Тогда
                    
                    ХранимыйФайл = НайденноеПоле.Значение;
                    
                    Если ТипЗнч(ХранимыйФайл) = Тип("СправочникСсылка.НоменклатураПрисоединенныеФайлы") И ЗначениеЗаполнено(ХранимыйФайл) Тогда
                        
                        Картинка = Новый Картинка(ХранимыйФайл.ФайлХранилище.Получить());
                        
                        КартинаВДокументе = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                        
                        КартинаВДокументе.Картинка = Картинка;
                        КартинаВДокументе.РазмерКартинки = РазмерКартинки.АвтоРазмер;
                        КартинаВДокументе.Расположить(Область);
                        
                    КонецЕсли;
                    
                КонецЕсли;
                
            КонецЕсли;
            
        КонецЦикла;
        
    КонецЦикла;
    
КонецПроцедуры
 
 
   yurik85
 
1 - 04.04.19 - 11:46
up
   yurik85
 
2 - 04.04.19 - 15:44
up
   sqr4
 
3 - 04.04.19 - 15:46
НУ и че) КартинаВДокументе.Расположить(Область);  точку тыкайешь, встает?
   sqr4
 
4 - 04.04.19 - 15:47
Новый Картинка(ХранимыйФайл.ФайлХранилище.Получить()); 
Какого типа?
   sqr4
 
5 - 04.04.19 - 15:47
Даже не так
   sqr4
 
6 - 04.04.19 - 15:47
ХранимыйФайл.ФайлХранилище.Получить() какого типа?
   yurik85
 
7 - 05.04.19 - 09:58
(6) Тип Неопределено... Но при этом у значения ХранимыйФайл.ФайлХранилище тип "ХранилищеЗначения"
   Chameleon1980
 
8 - 05.04.19 - 10:00
не там картинка
   Chameleon1980
 
9 - 05.04.19 - 10:01
в разных конфах пересматривалось хранение картинок с одного места на другое
смотри как оно выводится на форме номенклатуры
   Chameleon1980
 
10 - 05.04.19 - 10:02
возьми ИР (интсрументы разработчика) - там есть "исследовать объект" - полазь по данным
   yurik85
 
11 - 05.04.19 - 10:37
(10) Спасибо за совет. В итоге разобрался. Получаю двоичные данные файла, а потом создаю переменную типа Картинка(СсылкаНаДвоичныеДанные)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.