Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Идентификация Таб Части и МассиваСсылок

Идентификация Таб Части и МассиваСсылок
Я
   Germak
 
02.04.19 - 15:27
При Добавления массива документов в таб часть другого документа нужно проверить документы массива на идентичность документов таб части.

Процедура ПередатьданныеВДокумент(МассивСсылок) Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |    ЗаказПоставщику.Дата КАК Дата,
        |    ЗаказПоставщику.Ссылка
        |ИЗ
        |    Документ.ЗаказПоставщику КАК ЗаказПоставщику
        |
        |УПОРЯДОЧИТЬ ПО
        |    Дата УБЫВ
        |АВТОУПОРЯДОЧИВАНИЕ";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Если  ВыборкаДетальныеЗаписи.Количество() = 0  тогда
        Сообщить("Немає документа");
        возврат;
    ИНаче
        ВыборкаДетальныеЗаписи.Следующий();
        Документ =  ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
    КонецЕсли;
    Для Каждого Стр Из МассивСсылок Цикл
        СтрСчет = Документ.Счета.Добавить();
        СтрСчет.Счета = Стр;
        
        Попытка
        Документ.Записать(РежимЗаписиДокумента.Запись);
    Исключение
        Сообщить("Документ не вдалося Провести!!!" + ОписаниеОшибки());
    КонецПопытки;
    КонецЦикла;            
КонецПроцедуры
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.