Вход | Регистрация
 

индекс находится за границами массива

индекс находится за границами массива
Я
   КтоНоНикто
 
02.04.19 - 14:33
При добавлении новых данных выдается ошибка. Прошу помочь с ее решением.
Конфигурация -управление торговым предприятием для Казахстана, редакция 2.0


{ОбщаяФорма.ма_ФормаВыдачиПодарка_v81.Форма(7)}: Индекс находится за границами массива
текСтрокаТЧ = ДокументОбъект.ма_ПодаркиВыданные[текИндексСтроки];

текСтрокаТЧ = ДокументОбъект.ма_ПодаркиВыданные[текИндексСтроки];
     Сообщить(текСтрокаТЧ);
    
    Если ЗначениеЗаполнено(текСтрокаТЧ.Подарок) Тогда
    
        Если текСтрокаТЧ.МаркетинговаяАкция.СхемаПроведенияАкции.мчт_ЭтоНоваяСхема Тогда
            текИндексСтроки = текИндексСтроки + 1;    
            ПолучитьТекущиеДанные();
            Возврат;
        КонецЕсли;
        
        // пропускаем уже введенные
        Если (текИндексСтроки + 1) = ДокументОбъект.ма_ПодаркиВыданные.Количество() Тогда
            Если ЭтаФорма.Открыта() Тогда
                Закрыть();
            Иначе
                Отказ = Истина;
                Возврат;
            КонецЕсли;
                
        Иначе
            
            текИндексСтроки = текИндексСтроки + 1;    
            ПолучитьТекущиеДанные();
            Возврат;
            
        КонецЕсли;
        
    КонецЕсли;
 
 
   sqr4
 
1 - 02.04.19 - 14:48
ма_ПодаркиВыданные - пустая либо там мало строк)
   КтоНоНикто
 
2 - 03.04.19 - 10:38
(1) Спасибо, оно так и оказалось

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.