Вход | Регистрация
 

Не получается записать, как сделать лучше?

Не получается записать, как сделать лучше?
Я
   iznvi
 
02.04.19 - 13:32
Ребят, выдает ошибку, что Поле объекта недоступно для записи выдает на строке "СтрокиДок.НоменклатурнаяГруппа.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;" , как лучше сделать ?

Если  ДокументОснование.Дата > Дата("20190101") Тогда
        Для Каждого Строка Из ДокументОснование.Товары Цикл
            Если Строка.СтавкаНДС = Перечисления.СтавкиНДС.НДС20 Тогда
                Для Каждого СтрокиДок Из Материалы Цикл
                    Если СтрокиДок.НоменклатурнаяГруппа.СтавкаНДС = Перечисления.СтавкиНДС.НДС18 Тогда
                        
                    СтрокиДок.НоменклатурнаяГруппа.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;    
                    
                КонецЕсли;
                КонецЦикла;
            КонецЕсли;    
            
        КонецЦикла;
    
    КонецЕсли;
 
 
   jsmith82
 
1 - 02.04.19 - 13:32
СтрокиДок.СтавкаНДС =
   jsmith82
 
2 - 02.04.19 - 13:34
или тебе надо именно ном. группу изменить?
тогда
Обт = СтрокиДок.НоменклатурнаяГруппа.ПолучитьОбъект();
Обт.СтавкаНДС = Перечисления.СтавкиНДС.НДС20; 
Обт.ОбменДанными.Загрузка = Истина;
Обт.Записать();
   DmVl76
 
3 - 02.04.19 - 13:35
У ссылки меняешь поле, нужно  Группа=СтрокиДок.НоменклатурнаяГруппа.ПолучитьОбъект(), потом уже меняешь
   Beduin
 
4 - 02.04.19 - 13:37
Вангую, изначальная цель заменить в документах номенклатурную группу со ставкой 18% на номенклатурную группу со ставкой 20%
   iznvi
 
5 - 02.04.19 - 13:39
(4) дааа, правильно:D
   marty0701
 
6 - 02.04.19 - 13:41
Цикл пройдет много раз, ты по каждой строке меняешь все строки тч материалов и ответ в (1)
   catena
 
7 - 02.04.19 - 13:41
(6)Судя по (4) до ответа еще далеко.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.