Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как получить данные из другой формы начальной страницы?

Как получить данные из другой формы начальной страницы?
Я
   АСанСаныч
 
02.04.19 - 09:59
Доброго дня.
На начальной странице управляемого приложения размещено несколько форм.
Хотелось бы при обработке события ТЧ одной из форм получить текущие данные из ТЧ другой формы. Как к этим данным обратиться?
 
 
   Вафель
 
1 - 02.04.19 - 10:16
можно все открытые окна перебрать
   Вафель
 
2 - 02.04.19 - 10:17
см ОкнаКлиентскогоПриложения
   АСанСаныч
 
3 - 02.04.19 - 11:29
Спасибо. Нашёл решение. Оптимально ли оно?

Окна = ПолучитьОкна();
Для ио = 0 по Окна.Количество()-1 Цикл 
   текОкно = Окна[ио];
   Если текОкно.НачальнаяСтраница Тогда 
      масФорм = текОкно.Содержимое;
      Для иф = 0 по масФорм.Количество()-1 Цикл 
     Если масФорм[иф].Заголовок = "Уплата" Тогда
        Попытка
           т = масФорм[иф].Элементы.Список.ТекущиеДанные.Ч;
        Исключение
            КонецПопытки;
            Прервать;
    КонецЕсли; 
      КонецЦикла
   КонецЕсли;    
 КонецЦикла;
   Василий Алибабаевич
 
4 - 02.04.19 - 11:35
(3) Фигня какая-то (ЦЫ).
Данные же в "масФорм[иф].Элементы.Список.ТекущиеДанные.Ч;" откуда-то берутся. Почему бы не взять их еще раз для "т"?
ЗЫ. А если масФорм[иф].Заголовок = "Уплата" не найдется7
зы. А если в "масФорм[иф].Элементы.Список.ТекущиеДанные" не будет ТекущиеДанные?
   АСанСаныч
 
5 - 02.04.19 - 11:48
(4) всенормально. При копипасте начальное обнуление т не скопировалось перед Окна = ПолучитьОкна();

Перед последним КонецЕсли; надо ещё одну Прервать; влепить.
   Василий Алибабаевич
 
6 - 02.04.19 - 11:52
(5) Я совсем не за качество копи-пасте распинался.
   АСанСаныч
 
7 - 02.04.19 - 12:01
(6) Извини. Тогда не понял смысла в твоих замечаниях.
   Fish
 
8 - 02.04.19 - 12:16
(7) Смысл таков: зачем брать данные из формы, когда можно их взять из данных?
   АСанСаныч
 
9 - 02.04.19 - 12:22
(8) Как из среза последних РС узнать какая запись выбрана в другой форме в качестве текущей?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует