Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ЗУП 3.1 типовая обработка документооборот с КО

ЗУП 3.1 типовая обработка документооборот с КО
Я
   Роспатнюк Сергей Сер
 
01.04.19 - 16:05
вылетает когда запускаю а обычном приложении, Релиз 3.1.9.159
{Обработка.ДокументооборотСКонтролирующимиОрганами.Форма.КонтейнерКлиентскихМетодов.Форма(32125)}: Итератор для значения не определен
    Для Каждого ОткрытоеОкно Из ПолучитьОкна() Цикл
 
 
   Роспатнюк Сергей Сер
 
1 - 01.04.19 - 16:09
+(0) можно как то без добавления кода в типовой модуль исправить это, например регламентные задания не запускать в обычном приложении ?
   runoff_runoff
 
2 - 01.04.19 - 16:13
а зачем нужна резиновая кукла.. ой.. обычное приложение?..
   Роспатнюк Сергей Сер
 
3 - 01.04.19 - 16:15
(2) хороший вопрос но на него у меня нет ответа, начальник(ведущий программист) дал задание убрать ошибку желательно без доработки кода.
   runoff_runoff
 
4 - 01.04.19 - 16:25
не получится без доработки.. ПолучитьОкна() нет такой функции в обычном приложении..
   Роспатнюк Сергей Сер
 
5 - 01.04.19 - 16:32
(4) ясн, а если с доработкой как посоветуете я вот думаю можно #Если УправляемоеПриложение Тогда, или это не самый лучший способ?
   runoff_runoff
 
6 - 01.04.19 - 17:32
Вычислить("ПолучитьОкна()")
   Роспатнюк Сергей Сер
 
7 - 01.04.19 - 17:50
(6) а по точнее, не совсем понимаю что он вычислит если функции нет
   Роспатнюк Сергей Сер
 
8 - 01.04.19 - 17:55
сделал так, начальник сказал главное что бы управляемое не пострадало от моей доработки

&НаКлиенте
Функция ФормаРасшифровкиСообщенийОткрыта()
    
    //--- imp RSS 01.04.2019 

    //--- (исправление ошибки: интератор для значения не определен, функции ПолучитьОкна() нет в обычном приложении, прерываем выполнение кода и возвращаем ложь)

    #Если ТолстыйКлиентОбычноеПриложение Тогда

        Возврат Ложь;    
    #КонецЕсли    

    //--- imp RSS 01.04.2019 (Конец)

    
    ИмяФормыСообщенийТребующихРасшифровки = ПутьКОбъекту + ".Форма.ПоказСообщенийТребующихРасшифровки";
    ИмяФормыОшибкиОтправки         = ПутьКОбъекту + ".Форма.ОшибкиОтправки";
    ИмяФормыРезультатОбмена     = ПутьКОбъекту + ".Форма.РезультатОбмена";
    ИмяФормыДлительноеДействие     = ПутьКОбъекту + ".Форма.ДлительноеДействие";
            
    // Для формы, открытой в режиме "РежимОткрытияОкнаФормы.БлокироватьОкноВладельца",

    // не выполняется поиск по уникальному идентификатору, поэтому приходится искать самим.

    Для Каждого ОткрытоеОкно Из ПолучитьОкна() Цикл
        Если ТипЗнч(ОткрытоеОкно) = Тип("ОкноКлиентскогоПриложения") 
            И ОткрытоеОкно.Содержимое.Количество() = 1
            И (ОткрытоеОкно.Содержимое[0].ИмяФормы  = ИмяФормыСообщенийТребующихРасшифровки
            ИЛИ ОткрытоеОкно.Содержимое[0].ИмяФормы = ИмяФормыОшибкиОтправки
            ИЛИ ОткрытоеОкно.Содержимое[0].ИмяФормы = ИмяФормыРезультатОбмена
            ИЛИ ОткрытоеОкно.Содержимое[0].ИмяФормы = ИмяФормыДлительноеДействие) Тогда
            
            Возврат ОткрытоеОкно.Содержимое[0].Открыта();
            
        КонецЕсли;
    КонецЦикла;
    
    Возврат Ложь;
    
КонецФункции
   runoff_runoff
 
9 - 01.04.19 - 19:04
функция Вычислить() есть везде

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.