Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Нарушение прав доступа при записи в РС Версии объектов

Нарушение прав доступа при записи в РС Версии объектов
Я
   Ilqarupup
 
29.03.19 - 15:35
Добрый день! При попытке записать документ Поступление товаров и услуг выдает ошибку "Нарушение прав доступа" в строке 547 модуля ВерсионированиеОбъетов

Код такой

Процедура ЗаписатьДанныеТекущейВерсии(Ссылка)
    Перем НомерПоследнейВерсии;
    
    УстановитьПривилегированныйРежим(Истина);
    
    Если Не ОбъектВерсионируется(Ссылка, НомерПоследнейВерсии) Тогда
        Возврат;
    КонецЕсли;
    
    ПоследняяВерсия = РегистрыСведений.ВерсииОбъектов.СоздатьМенеджерЗаписи();
    ПоследняяВерсия.Объект = Ссылка;
    ПоследняяВерсия.НомерВерсии = НомерПоследнейВерсии;
    ПоследняяВерсия.Прочитать();
    Если Не ПоследняяВерсия.ЕстьДанныеВерсии Тогда
        ПоследняяВерсия.ВерсияОбъекта = Новый ХранилищеЗначения(ДанныеДляХранения(Ссылка), Новый СжатиеДанных(9));
        ПоследняяВерсия.Записать();   // строка 547
    КонецЕсли;
КонецПроцедуры


Дал все права на этот РС, все равно не получается, выдает ту же ошибку? Права на поступления товаров услуг тоже есть у пользователя
 
 
   Вафель
 
1 - 29.03.19 - 15:36
скорее всего идет запись документов из внешней обработки в безопасном режиме (нужно в опасном)
   Ilqarupup
 
2 - 29.03.19 - 15:37
про безопасный режим выходило сообщение, "Установлен безопасный режим"
   Ilqarupup
 
3 - 29.03.19 - 15:38
через обработку ЗагрузкаИзТабличногодокумента делает загружает поступление
   Ilqarupup
 
4 - 29.03.19 - 15:38
и как перевести в опасный режим?
   TormozIT
 
5 - 29.03.19 - 17:24
Попробуй ИР загрузку табличных данных http://devtool1c.ucoz.ru/index/zagruzka_tablichnykh_dannykh/0-54 в варианте Расширение http://devtool1c.ucoz.ru/index/rasshirenie_variant/0-52 . Проще всего подключить это расширение через установщик расширения (ссылка сверху страницы). Там полная поддержка любых конфигураций (управляемых и обычных) опасный режим и привилегированный режим есть.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.