Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Проверка документа на наличие движений по регистрам

Проверка документа на наличие движений по регистрам
Я
   ac13
 
28.03.19 - 09:37
Как понять сделал ли документ какие-нибудь движения?

Для каждого Док из СписокДокументов Цикл
     ДокСсылка = Док.СсылкаНаДок.ПолучитьОбъект();
     ДокСсылка.Движения// что делать с движениями? Как понять есть они или пусто? 

КонецЦикла;

 
 
   Галахад
 
1 - 28.03.19 - 09:38
Запросом.
   ac13
 
2 - 28.03.19 - 10:15
(1) спс

Для каждого Док из СписокДокументов Цикл
    Для каждого ДвижениеДока Из Док.СсылкаНаДок.Метаданные().Движения Цикл
        Запрос = Новый Запрос();
        Запрос.Текст = "ВЫБРАТЬ
        |      Док.Ссылка КАК Ссылка
        |ИЗ
        |      Документ." + Док.СсылкаНаДок.Метаданные().Имя + " КАК Док
        |ГДЕ
        |      (НЕ Док.Ссылка В
        |            (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |                  ДвиженияДока.Регистратор КАК Ссылка
        |                  ИЗ
        |                  " + Движение.ПолноеИмя() + " КАК ДвиженияДока))";
        Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка .Следующий() Цикл
            Сообщить("Для " + Док.Ссылка + " есть движения");
        КонецЦикла;
    КонецЦикла;

КонецЦикла;

   ac13
 
3 - 28.03.19 - 10:19
(2) конечно лучше переделать, чтоб запрос не в цикле был, лень было заморачиваться
   1Сергей
 
4 - 28.03.19 - 10:25
Одному лень, другому переделывать. Все при делах, все при бабках. Только заказчик плачет :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.