Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Внешняя печатная форма, ошибка параметра запроса. обычные формы

Внешняя печатная форма, ошибка параметра запроса. обычные формы
Я
   SkillUp
 
27.03.19 - 18:15
Здр, в модуле объекта (процедуры печать) есть запрос с параметром:

Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);

После копирования процедуры "печать" по внешнюю, меняю ЭтотОбъект.Ссылка на ЭтаОбработка.СсылкаНаОбъект, делаю так:

Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект);

И там и там, ссылка на нужный документ, но во внешней печатной форме ошибка:

{ВнешняяОбработка.СписаниеТоваровВнешн.Форма.ФормаДляПроцедурМодуляДокумента.Форма(94)}: Ошибка при вызове метода контекста (Выполнить)
    Шапка = Запрос.Выполнить().Выбрать();
по причине:
{(17, 25)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
СписаниеТоваров.Ссылка <<?>>= &ТекущийДокумент


Кто подскажет, как правильно?
 
 
   ДенисЧ
 
1 - 27.03.19 - 18:16
посмотреть в отладчике, что у тебя ЭтаОбработка.СсылкаНаОбъект ?
   SkillUp
 
2 - 27.03.19 - 18:19
(1) ДокументСсылка.СписаниеТоваров
   azernot
 
3 - 27.03.19 - 18:22
(2) Попробуй так:
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект.Ссылка); 

Есть подозрение, что у тебя там не ссылка, а объект
   SkillUp
 
4 - 27.03.19 - 18:25
(3) Пробовал и так... тоже самое...
   Nuobu
 
5 - 27.03.19 - 18:25
(4) Ну показывай уже свой код.
   SkillUp
 
6 - 27.03.19 - 18:30
(5) пож.

// Функция формирует табличный документ унифицированной формы М-15

//
// Параметры: 

//  Нет.
//

// Возвращаемое значение:
//  Табличный документ по форме М-15.

//
Функция ПечатьНакладной()
    Склад = ЭтаОбработка.СсылкаНаобъект.склад;    
    ВидПечати = "Регл";
      
    БУ = ПланыСчетов.Хозрасчетный.ТоварыНаСкладе.ПолучитьОбъект();
    ВестиУчетПоДопРазрезамРегл  = ?(БУ.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеПозиции, "ВидСубконто") = Неопределено, Ложь, Истина);

    ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
        ВыводитьКоды    = Истина;
        Колонка         = "Артикул";
        ТекстКодАртикул = "Артикул";
    ИначеЕсли ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
        ВыводитьКоды    = Истина;
        Колонка         = "Код";
        ТекстКодАртикул = "Код";
    Иначе
        ВыводитьКоды    = Ложь;
        Колонка         = "";
        ТекстКодАртикул = "Код";
    КонецЕсли;

    Если ВыводитьКоды Тогда
        ОбластьШапки  = "ШапкаСКодом";
        ОбластьСтроки = "СтрокаСКодом";
    Иначе
        ОбластьШапки  = "ШапкаТаблицы";
        ОбластьСтроки = "Строка";
    Конецесли;

    Если Товары.Итог("КоличествоМест") > 0 Тогда
        ОбластьШапки  = ОбластьШапки  + "Мест";
        ОбластьСтроки = ОбластьСтроки + "Мест";
    Конецесли;
    
    ЭтоСкладНТТ = (Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ);
    
    Если ЭтоСкладНТТ Тогда
        ОбластьШапки  = ОбластьШапки  + "НТТ";
        ОбластьСтроки = ОбластьСтроки + "НТТ";
    ИначеЕсли Не ВидПечати = "Регл" Тогда
        ТаблицаСтоимости = ПолучитьТаблицуСтоимостиТоваров();
    КонецЕсли; 
    
    Если ВидПечати = "Регл"    Тогда
        ТаблицаСуммСписания = БухгалтерскийУчет.ПолучитьСуммуСписанияАктивов(ЭтаОбработка.СсылкаНаОбъект.ПолучитьОбъект(),ВестиУчетПоДопРазрезамРегл);
        ТаблицаСуммСписанияБланков = ПолучитьСуммуСписанияБланков();
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект.ПолучитьОбъект());
    Если ЭтоСкладНТТ ИЛИ ВидПечати = "Регл" Тогда
        ВалютаПечати = мВалютаРегламентированногоУчета;
    Иначе
        ВалютаПечати = глЗначениеПеременной("ВалютаУправленческогоУчета");
    КонецЕсли;
    
    Запрос.Текст =
    "ВЫБРАТЬ
    |    СписаниеТоваров.Номер,
    |    СписаниеТоваров.Дата,
    |    СписаниеТоваров.Организация,
    |    СписаниеТоваров.Организация КАК Поставщик,
    |    СписаниеТоваров.Склад,
    |    Подразделение,
    |    Основание,
    |    ПредседательКомиссии.Наименование    КАК ПредседательКомиссии,
    |    ПервыйЧленКомиссии.Наименование        КАК ПервыйЧленКомиссии,
    |    ВторойЧленКомиссии.Наименование        КАК ВторойЧленКомиссии,
    |    ТретийЧленКомиссии.Наименование     КАК ТретийЧленКомиссии,
    |    СписаниеТоваров.Ответственный.ФизЛицо.Наименование КАК Выписал
    |ИЗ
    |    Документ.СписаниеТоваров КАК СписаниеТоваров
    |ГДЕ
    |    СписаниеТоваров.Ссылка = &ТекущийДокумент";
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект.Ссылка); 
    Запрос.УстановитьПараметр("КачествоНовый", Справочники.Качество.Новый);

    Запрос.Текст =
    "ВЫБРАТЬ
    |    1 КАК НомерТЧ,
    |    Ложь КАК БланкСтрогогоУчета,
    |    НомерСтроки,
    |    Номенклатура,
    |    ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК СТРОКА(1000))  КАК Товар,
    |    КоличествоМест,
    |    Количество,
    |    ЕдиницаИзмерения.Представление       КАК ЕдиницаЦены,
    |    Коэффициент                           КАК Коэффициент,
    |    ЕдиницаИзмеренияМест.Представление  КАК ЕдиницаМест,
    |    Номенклатура.Код     КАК Код,
    |    Номенклатура."+ ТекстКодАртикул + " КАК КодАртикул,
    |    Номенклатура.ВестиПартионныйУчетПоСериям КАК ВестиПартионныйУчетПоСериям,
    |    Цена                             КАК Цена,
    |    Сумма                             КАК Сумма,
    |    ХарактеристикаНоменклатуры       КАК Характеристика,
    |    СерияНоменклатуры                КАК Серия,
    |    Качество                         КАК Качество
    |    
    |ИЗ
    |    Документ.СписаниеТоваров.Товары КАК СписаниеТоваров
    |ГДЕ
    |    СписаниеТоваров.Ссылка = &ТекущийДокумент
    |
    | ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    2 КАК НомерТЧ,
    |    Истина КАК БланкСтрогогоУчета,
    |    НомерСтроки,
    |    Номенклатура,
    |    ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК СТРОКА(1000))  КАК Товар,
    |    КоличествоМест,
    |    Количество,
    |    ЕдиницаИзмерения.Представление       КАК ЕдиницаЦены,
    |    Коэффициент                           КАК Коэффициент,
    |    ЕдиницаИзмеренияМест.Представление  КАК ЕдиницаМест,
    |    Номенклатура.Код     КАК Код,
    |    Номенклатура."+ ТекстКодАртикул + " КАК КодАртикул,
    |    Номенклатура.ВестиПартионныйУчетПоСериям КАК ВестиПартионныйУчетПоСериям,
    |    0                             КАК Цена,
    |    0                             КАК Сумма,
    |    ХарактеристикаНоменклатуры       КАК Характеристика,
    |    СерияНоменклатуры                КАК Серия,
    |    &КачествоНовый                     КАК Качество
    |    
    |ИЗ
    |    Документ.СписаниеТоваров.БланкиСтрогогоУчета КАК СписаниеТоваров
    |ГДЕ
    |    СписаниеТоваров.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО
    |    НомерТЧ, НомерСтроки
    |";

    ЗапросТовары = Запрос.Выполнить().Выгрузить();

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект);
    Запрос.УстановитьПараметр("ПустаяХарактеристика", Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка());
    Запрос.УстановитьПараметр("ПустаяСерия", Справочники.СерииНоменклатуры.ПустаяСсылка());
    Запрос.УстановитьПараметр("КачествоНовый", Справочники.Качество.Новый);
    
    Запрос.Текст = "
    |ВЫБРАТЬ
    |    НомерСтроки,
    |    Номенклатура,
    |    ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК СТРОКА(1000))  КАК Товар,
    |    Номенклатура.Код                КАК Код,
    |    Номенклатура."+ ТекстКодАртикул + " КАК КодАртикул,
    |    Номенклатура.ВестиПартионныйУчетПоСериям КАК ВестиПартионныйУчетПоСериям,
    |    Количество,
    |    &ПустаяХарактеристика КАК Характеристика,
    |    &ПустаяСерия КАК Серия,
    |    &КачествоНовый КАК Качество,
    |    Номенклатура.ЕдиницаХраненияОстатков.Представление КАК ЕдиницаЦены,
    |   0 КАК Цена,
    |   0 КАК Сумма
    |ИЗ
    |    Документ.СписаниеТоваров.ВозвратнаяТара КАК СписаниеТоваров
    |
    |ГДЕ
    |    СписаниеТоваров.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО
    |    НомерСтроки
    |";
    
    ЗапросТара = Запрос.Выполнить().Выгрузить();
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СписаниеТоваров_Накладная";
    Макет       = ЭтаОбработка.ПолучитьМакет("Накладная");
    
    // печать производится на языке, указанном в настройках пользователя

    КодЯзыкаПечать = Локализация.ПолучитьЯзыкФормированияПечатныхФорм(УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "РежимФормированияПечатныхФорм"));
    Макет.КодЯзыкаМакета = КодЯзыкаПечать;
    
    // шапка акта "УТВЕРЖДАЮ"

    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияООрганизации     = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата,,,КодЯзыкаПечать);
    РуководителиОрганизации = ОбщегоНазначения.ОтветственныеЛица(Шапка.Организация, Шапка.Дата);
    
    ОбластьМакета.Параметры.ДолжностьРуководителяОрганизации    = РуководителиОрганизации.РуководительДолжность;
    ОбластьМакета.Параметры.ПредставлениеОрганизации             = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияООрганизации, "ПолноеНаименование,",,КодЯзыкаПечать);
    ОбластьМакета.Параметры.РуководительОрганизации             = РуководителиОрганизации.РуководительПредставление;
    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, НСтр("ru='Акт списания товаров';uk='Акт про списання товарів'",КодЯзыкаПечать),КодЯзыкаПечать);
    ТабДокумент.Вывести(ОбластьМакета);

    СведенияОПоставщике = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Поставщик, Шапка.Дата,,,КодЯзыкаПечать);
    
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,",,КодЯзыкаПечать);
    ОбластьМакета.Параметры.РеквизитыПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ЮридическийАдрес,Телефоны,/,КодПоЕДРПОУ,КодПоДРФО,ИНН,НомерСвидетельства,",,КодЯзыкаПечать);
    ТабДокумент.Вывести(ОбластьМакета);

    // Выводим дополнительно информацию о складе

    СписокДополнительныхПараметров = "Склад,Подразделение,Основание,";
    МассивСтруктурСтрок = ФормированиеПечатныхФорм.ДополнительнаяИнформация(Шапка,СписокДополнительныхПараметров,КодЯзыкаПечать);
    ОбластьМакета = Макет.ПолучитьОбласть("ДопИнформация");
    Для каждого СтруктураСтроки Из МассивСтруктурСтрок Цикл
        ОбластьМакета.Параметры.Заполнить(СтруктураСтроки);
        ТабДокумент.Вывести(ОбластьМакета);
    КонецЦикла;        
    
    // Вывести табличную часть

    ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
    Если ВыводитьКоды Тогда
        ОбластьМакета.Параметры.Колонка = Колонка;
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьМакета);

    СуммаИтого = 0;

    ОбластьМакета = Макет.ПолучитьОбласть(ОбластьСтроки);
    
    // Товары

    Для каждого ВыборкаСтрокТовары из ЗапросТовары Цикл 
        
        Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
            Сообщить("В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.", СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;
        
        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
        ОбластьМакета.Параметры.НомерСтроки = ЗапросТовары.Индекс(ВыборкаСтрокТовары) + 1;
        ОбластьМакета.Параметры.Товар = СокрП(ВыборкаСтрокТовары.Товар) + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары);
        
        Если ВыводитьКоды Тогда
            ОбластьМакета.Параметры.КодАртикул = ВыборкаСтрокТовары.КодАртикул;
        КонецЕсли;
        
        Сумма = 0;
        
        Если ВидПечати = "Регл"    Тогда
            Если ЭтоСкладНТТ И Склад.СуммовойУчет И Не ВыборкаСтрокТовары.БланкСтрогогоУчета Тогда
                 Сумма = ВыборкаСтрокТовары.Сумма;
            Иначе    
                
                Если ВыборкаСтрокТовары.БланкСтрогогоУчета Тогда
                    СтрокаСуммСписания =  ТаблицаСуммСписанияБланков.Найти(ВыборкаСтрокТовары.Номенклатура, "Номенклатура");
                Иначе    
                    Если ВестиУчетПоДопРазрезамРегл Тогда
                        
                        СтруктураДляПоиска = Новый Структура;
                        
                        СтруктураДляПоиска.Вставить("Номенклатура",ВыборкаСтрокТовары.Номенклатура);
                        СтруктураДляПоиска.Вставить("Характеристика",ВыборкаСтрокТовары.Характеристика);
                        СтруктураДляПоиска.Вставить("Серия",ВыборкаСтрокТовары.Серия);
            
                        Строки = ТаблицаСуммСписания.НайтиСтроки(СтруктураДляПоиска);
            
                        Если Строки.Количество() > 0 Тогда            
                            СтрокаСуммСписания =  Строки[0];
                        Иначе 
                            СтрокаСуммСписания = Неопределено;
                        КонецЕсли;

                    Иначе
                    
                        СтрокаСуммСписания =  ТаблицаСуммСписания.Найти(ВыборкаСтрокТовары.Номенклатура, "Номенклатура");
                        
                    КонецЕсли;
                КонецЕсли;
                
                Если СтрокаСуммСписания = Неопределено Тогда
                     ОбластьМакета.Параметры.Цена = 0;
                     ОбластьМакета.Параметры.Сумма = 0; 
                 Иначе
                    Цена = ?(СтрокаСуммСписания.Количество = 0, 0, СтрокаСуммСписания.Сумма / СтрокаСуммСписания.Количество/ВыборкаСтрокТовары.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент)*ВыборкаСтрокТовары.Коэффициент;
                    Сумма = Цена*ВыборкаСтрокТовары.Количество;
                    ОбластьМакета.Параметры.Цена = Цена;
                    ОбластьМакета.Параметры.Сумма = ОбщегоНазначения.ОкруглитьСУчетомПогрешности(Сумма, 2,, ПогрешностьСуммы,ВыборкаСтрокТовары.Номенклатура);
                 КонецЕсли;
                 
             КонецЕсли;     
        Иначе                         
            
            Если ЭтоСкладНТТ  И Не ВыборкаСтрокТовары.БланкСтрогогоУчета Тогда
                Сумма = ВыборкаСтрокТовары.Сумма;
            Иначе
                Сумма = ПолучитьСтоимостьТовара(ТаблицаСтоимости, ВыборкаСтрокТовары);
                Цена = ?(ВыборкаСтрокТовары.Количество = 0, 0, Сумма/ВыборкаСтрокТовары.Количество);
                ОбластьМакета.Параметры.Цена = Цена;    
                ОбластьМакета.Параметры.Сумма = Сумма;
            КонецЕсли;
            
        КонецЕсли;

        ТабДокумент.Вывести(ОбластьМакета);

        СуммаИтого = СуммаИтого + Сумма;

    КонецЦикла;
    
    // Вывести Итого

    ОбластьМакета                 = Макет.ПолучитьОбласть("Итого");
    ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(СуммаИтого);
    ТабДокумент.Вывести(ОбластьМакета);
    
    // Вывести таблицу с возвратной тарой

    ОбластьШапки  = СтрЗаменить(ОбластьШапки,"Мест","");
    ОбластьСтроки = СтрЗаменить(ОбластьСтроки,"Мест","");
    ОбластьШапки  = СтрЗаменить(ОбластьШапки,"НТТ","")+"Тара";
    ОбластьСтроки = СтрЗаменить(ОбластьСтроки,"НТТ","")+"Тара";
    
    Если ЗапросТара.Количество() > 0 Тогда
        
        // сделаем отступ от основной таблицы

        ОбластьПробел = Макет.ПолучитьОбласть("Пробел");
        ТабДокумент.Вывести(ОбластьПробел);
        
        ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
        Если ВыводитьКоды Тогда
            ОбластьМакета.Параметры.Колонка = Колонка;
        КонецЕсли;

        ТабДокумент.Вывести(ОбластьМакета);

        СуммаТара    = 0;
        КоличествоТоваров = Товары.Количество();
        
        ОбластьМакета = Макет.ПолучитьОбласть(ОбластьСтроки);
        
        Для каждого ВыборкаСтрокТара Из ЗапросТара Цикл 
        
            ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТара);
            ОбластьМакета.Параметры.НомерСтроки = ЗапросТара.Индекс(ВыборкаСтрокТара) + 1;
            ОбластьМакета.Параметры.Товар       = СокрЛП(ВыборкаСтрокТара.Номенклатура);
            
            
            Если ВидПечати = "Регл"    Тогда
                
                СтрокаСуммСписания =  ТаблицаСуммСписания.Найти(ВыборкаСтрокТара.Номенклатура, "Номенклатура");
                Если СтрокаСуммСписания = Неопределено Тогда
                     ОбластьМакета.Параметры.Цена = 0;
                     ОбластьМакета.Параметры.Сумма = 0; 
                 Иначе
                     Цена = ?(СтрокаСуммСписания.Количество = 0, 0, СтрокаСуммСписания.Сумма / СтрокаСуммСписания.Количество);
                     ОбластьМакета.Параметры.Цена = Цена;
                     Сумма = СтрокаСуммСписания.Сумма;
                 КонецЕсли;
                
            Иначе    
                
                Если ЭтоСкладНТТ Тогда
                    Сумма = ВыборкаСтрокТара.Сумма;
                Иначе
                    Сумма = ПолучитьСтоимостьТовара(ТаблицаСтоимости, ВыборкаСтрокТара);
                    ОбластьМакета.Параметры.Сумма = Сумма;
                КонецЕсли;
                Цена = ?(ВыборкаСтрокТара.Количество = 0, 0, Сумма/ВыборкаСтрокТара.Количество);
                ОбластьМакета.Параметры.Цена  = Цена;    
                
                Если ВыводитьКоды Тогда
                    ОбластьМакета.Параметры.КодАртикул = ВыборкаСтрокТара.КодАртикул;
                КонецЕсли;
                
            КонецЕсли;    
                
            ТабДокумент.Вывести(ОбластьМакета);
            
            СуммаТара = СуммаТара + Сумма;
        
        КонецЦикла; 
        
        // Вывести Итого

        ОбластьИтого = "ИтогоТара";
        ОбластьМакета                 = Макет.ПолучитьОбласть(ОбластьИтого);
        ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(СуммаТара);
        ТабДокумент.Вывести(ОбластьМакета);        
        
        // сделаем отступ

        ТабДокумент.Вывести(ОбластьПробел);
    КонецЕсли;
    
    // Вывести Сумму прописью

    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    СуммаКПрописи = СуммаИтого;
    ОбластьМакета.Параметры.ИтоговаяСтрока = НСтр("ru='Всего наименований ';uk='Всього найменувань '",КодЯзыкаПечать) + ЗапросТовары.Количество() + "," +
                                             НСтр("ru=' на сумму ';uk=' на суму '",КодЯзыкаПечать)  + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, ВалютаПечати)
                                             + ?(ЗапросТара.Количество() = 0, "",  НСтр("ru='; возвратная тара ';uk='; зворотна тара '",КодЯзыкаПечать) + ЗапросТара.Количество() + НСтр("ru=', на сумму ';uk=', на суму '",КодЯзыкаПечать) + ОбщегоНазначения.ФорматСумм(СуммаТара, ВалютаПечати)) + ".";
                                             
    ОбластьМакета.Параметры.СуммаПрописью  = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, ВалютаПечати,КодЯзыкаПечать);
    ТабДокумент.Вывести(ОбластьМакета);

    // Вывести подписи

    // Вывести подписи

    ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
    ВыборкаПоКомиссии = РаботаСДиалогами.ПолучитьСведенияОКомиссии(ЭтаОбработка.СсылкаНаОбъект.ПолучитьОбъект());
    ОбластьМакета.Параметры.Заполнить(ВыборкаПоКомиссии);
    ТабДокумент.Вывести(ОбластьМакета);

    Возврат ТабДокумент;

КонецФункции 

/////////////////////////////////////////////////////////////////////

// ПРОЦЕДУРЫ И ФУНКЦИИ ШАБЛОНА
   SkillUp
 
7 - 27.03.19 - 18:30
(5) Функция ПечатьНакладной()
   SkillUp
 
8 - 27.03.19 - 18:31
(5) Самый первый запрос...
   Nuobu
 
9 - 27.03.19 - 18:34
Я один вижу "ПолучитьОбъект()"?
   SkillUp
 
10 - 27.03.19 - 18:38
(9) Где именно, то не везде надо ссылка, где-то нужен объект?!
   azernot
 
11 - 27.03.19 - 18:39
Запрос.Текст =
    "ВЫБРАТЬ
    |    СписаниеТоваров.Номер,
    |    СписаниеТоваров.Дата,
    |    СписаниеТоваров.Организация,
    |    СписаниеТоваров.Организация КАК Поставщик,
    |    СписаниеТоваров.Склад,
    |    Подразделение,
    |    Основание,
    |    ПредседательКомиссии.Наименование    КАК ПредседательКомиссии,
    |    ПервыйЧленКомиссии.Наименование        КАК ПервыйЧленКомиссии,
    |    ВторойЧленКомиссии.Наименование        КАК ВторойЧленКомиссии,
    |    ТретийЧленКомиссии.Наименование     КАК ТретийЧленКомиссии,
    |    СписаниеТоваров.Ответственный.ФизЛицо.Наименование КАК Выписал
    |ИЗ
    |    Документ.СписаниеТоваров КАК СписаниеТоваров
    |ГДЕ
    |    СписаниеТоваров.Ссылка = &ТекущийДокумент";
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    

Ну и где тут 
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект.Ссылка); 

?
   Вафель
 
12 - 27.03.19 - 18:39
тут массив скорее всего. ибо в бсп передается массив
   azernot
 
13 - 27.03.19 - 18:39
а, ну да

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаОбработка.СсылкаНаОбъект.ПолучитьОбъект());

Убери "ПолучитьОбъект()"
   Nuobu
 
14 - 27.03.19 - 18:40
(10) Везде оно не нужно.
   SkillUp
 
15 - 27.03.19 - 18:41
(13) Тю, блин!!!
   SkillUp
 
16 - 27.03.19 - 18:41
(14) Пардон, ребят, просмотрел...
   SkillUp
 
17 - 27.03.19 - 18:41
СПАСИБО ВАМ!!!
   runoff_runoff
 
18 - 27.03.19 - 19:52
а если поменять на ЭтоОбработко?..

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.