Вход | Регистрация
 

какую выбрать процедуру для изменения доступности на УФ документа

какую выбрать процедуру для изменения доступности  на УФ документа
Я
   Филипп Остырко
 
27.03.19 - 11:09
я хотел заблокировать реквизит2 табл части при заполнении значения реквизита1 . работает,но когда я удаляю значение реквизита1, то реквизит 2 всё равно не доступен. как сделать, что он ставал доступным?

&НаКлиенте
Процедура Реквизит1ПриИзменении(Элемент)
    Если Не ПустаяСтрока(Элементы.Реквизит1) Тогда
        Элементы.Реквизит2.Доступность = Ложь;
    Иначе
        Элементы.Реквизит2.Доступность = Истина;
    КонецЕсли;
КонецПроцедуры
    
КонецПроцедуры
 
 
   ДенисЧ
 
1 - 27.03.19 - 11:12
А условие-то срабатывает? Может, там не строка? Может, Проверить ЗначениеЗаполнено() ?
   Филипп Остырко
 
2 - 27.03.19 - 11:16
(1) Сначала делал так, но вышла ошибка :Проверка мутабельных значений на заполненность не поддерживается
   palsergeich
 
3 - 27.03.19 - 11:18
Элементы.табличнаячасть.подчиненныеэлементы.найти(имяреквизмта).толькопросмотр
   vdss
 
4 - 27.03.19 - 11:19
Ошибка тут: ПустаяСтрока(Элементы.Реквизит1)

Проверять на пустую строку надо не элемент формы, а значение реквизита ТЧ.
   palsergeich
 
5 - 27.03.19 - 11:20
Хотя не, это немного про другое, приношу извинения
   palsergeich
 
6 - 27.03.19 - 11:21
Какого типа значения возможны в этом реквизите ТЧ?
   vdss
 
7 - 27.03.19 - 11:24
Причем у тебя может быть в первой строке реквизит1 заполнен (реквизит2 должен быть недоступен), а во второй строке реквизит1 пустой (реквизит2 должен быть доступен). Таким образом, доступность должна определяться не только при изменении реквизита1, но и при активизации строки (при переключении между строками ТЧ).

ТекущиеДанные = Элементы.ИмяТЧ.ТекущиеДанные;
Если ТекущиеДанные <> Неопределено Тогда
    Элементы.Реквизит2.Доступность = ЗначениеЗаполнено(ТекущиеДанные.Реквизит1);
КонецЕсли;

Этот код поместить в отдельную процедуру и вызывать ее при изменении, и при активизации строки
   Филипп Остырко
 
8 - 27.03.19 - 11:25
(6) тип реквизита СправочникСсылка.Справочник
   Филипп Остырко
 
9 - 27.03.19 - 11:25
(7) Попробую.Спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует