Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация - проверить уже загруженный объект перед повторной загрузкой

Конвертация - проверить уже загруженный объект перед повторной загрузкой
Я
   fgaabbb
 
27.03.19 - 09:23
Мне надо проверить курс в уже загруженном документе, и, если он отличается, то не грузить документ.
Прочитал про событие "После загрузки", что оно возникает до записи объекта.

делаю

Если ОбъектНайден Тогда
    
        Курс =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Ссылка, "КурсВзаиморасчетов");
    Если Курс <> Объект.КурсВзаиморасчетов Тогда
        Отказ = Истина;
    КонецЕсли;
    
КонецЕсли;

объект все равно загружается - видимо, я неверно обращаюсь к ранее загруженному объекту. что я делаю не так?
 
 
   Йохохо
 
1 - 27.03.19 - 09:29
мб НеЗамещатьОбъект = Истина
   fgaabbb
 
2 - 27.03.19 - 09:39
(1) этот параметр в При загрузке есть, в После загрузки - нет.
   fgaabbb
 
3 - 27.03.19 - 09:40
я пробовал в При Загрузке, с НеЗамещатьОбъект = Истина; но тоже не работает:
Если ОбъектНайден Тогда
    Курс =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Объект.Ссылка, "КурсВзаиморасчетов");
    Если Курс <> Объект.КурсВзаиморасчетов Тогда
        
        НеЗамещатьОбъект = Истина;
    
    КонецЕсли;
    
КонецЕсли;
   Йохохо
 
4 - 27.03.19 - 09:51
там что то с модифицированностью афаир, надо в Ложь установить

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.