Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа с OpenOffice/LibreOffice

Работа с OpenOffice/LibreOffice
Я
   NUser
 
27.03.19 - 05:41
Доброго времени суток. Создаю документ:

        ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
    Desktop = ServiceManager.CreateInstance("com.sun.star.frame.Desktop");
    ПараметрыОО = Новый COMSafeArray("VT_DISPATCH", 1);
    Document = Desktop.LoadComponentFromURL("private:factory/swriter", "_blank", 0, ПараметрыОО);

Далее мне нужно задать размер полей. Стиль страницы (формат/Страница) определяется нормально:

        СтилиСтраницы=Документ.StyleFamilies.getByName("PageStyles");

Но листы не получает, пишет "Метод не обнаружен getSheets()":

        Листы = Document.getSheets();

Подскажите, что неверно делаю? Или может как-то по другому можно задать размер полей? Заранее спасибо за ответ
 
 
   NUser
 
1 - 27.03.19 - 06:24
Хотя тут листы в обще не нужны)
   NUser
 
2 - 27.03.19 - 07:22
Через стили страницы не могу найти. Подскажите кто сталкивался?
   Автор
 
3 - 27.03.19 - 08:39
        КоличествоСтилей = СтилиСтраницы.getCount();
    
    Если КоличествоСтилей > 0 Тогда
        Для i = 0 По КоличествоСтилей -1 Цикл
            defPage = СтилиСтраницы.GetByIndex(i);
            defPage.TopMargin = 500;
            defPage.LeftMargin = 500;            
        КонецЦикла;
    КонецЕсли;

   NUser
 
4 - 27.03.19 - 14:23
(3)Спасибо Вам большое. Мастерски.

  ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
    Desktop = ServiceManager.CreateInstance("com.sun.star.frame.Desktop");
    ПараметрыОО = Новый COMSafeArray("VT_DISPATCH", 1);
    Document = Desktop.LoadComponentFromURL("private:factory/swriter", "_blank", 0, ПараметрыОО);
    СтилиСтраницы=Document.StyleFamilies.getByName("PageStyles"); 
    КоличествоСтилей = СтилиСтраницы.getCount();
    
    Если КоличествоСтилей > 0 Тогда
        Для i = 0 По КоличествоСтилей -1 Цикл
            defPage = СтилиСтраницы.GetByIndex(i);
            defPage.TopMargin = 500;
            defPage.LeftMargin = 500;            
        КонецЦикла;
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.