Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Адрес без лишних символов

Адрес без лишних символов
Я
   88g88
 
26.03.19 - 17:00
Приветствую форумчане.
Столкнулся с строкой адреса заполненного не полностью но представление хранится как полное. В результате запроса не получилось получить адрес в виде представления, только полный вариант с кучей запятых.
Готовых решений тоже не нашел для решения данного вопроса.

Получить адрес без лишних символов удалось вот таким кодом. (Вдруг кому пригодится)

Функция КорректировкаАдреса(Адрес)
    
    Длина = СтрДлина(Адрес);
    Символ = 1;
    
    Пока Сред(Адрес,Символ,1) <> "" цикл
        Если Сред(Адрес,Символ,1) = ","  или Сред(Адрес,Символ,1) = " " тогда
            ПоследнийСимвол = Сред(Адрес,Символ,1);
            Символ = Символ + 1;
            Продолжить;
        Иначе    
            Если ПоследнийСимвол = " " и (не Сред(Адрес,Символ,1) = ","  или не Сред(Адрес,Символ,1) = " " ) тогда
                СобранныйАдрес = Строка(СобранныйАдрес) + ", " + Строка(Сред(Адрес,Символ,1));
                ПоследнийСимвол = Сред(Адрес,Символ,1);
                Символ = Символ + 1;
            Иначе    
                СобранныйАдрес = Строка(СобранныйАдрес) + Строка(Сред(Адрес,Символ,1));
                ПоследнийСимвол = Сред(Адрес,Символ,1);
                Символ = Символ + 1;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    
    Возврат СобранныйАдрес;
КонецФункции
 
 
   88g88
 
1 - 26.03.19 - 17:00
Строка 
Длина = СтрДлина(Адрес); 
не функциональна. забыл Удалить)
   ads55
 
2 - 27.03.19 - 07:56
(0) Да, да. Только если зайдет ПустаяСтрока(Адрес), то программа выпадет в ошибку :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.