Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД2 замена счета по условию

КД2 замена счета по условию
Я
   bacamba49
 
26.03.19 - 11:45
Добрый день,уважаемые гуру .подскажите плз...нужно в ТАб.части дока по условию сменить счет при загрузке дока..
пишу так ПКС,перед выгрузкой..:

Если ОбъектКоллекции.СчетУчетаПолучательБУ = "10.М4" Тогда
    
    Значение = "МЦ.04";
    
КонецЕсли;

док загружается с пустым полем счет,что не так делаю...?
 
 
   Cyberhawk
 
1 - 26.03.19 - 11:48
Сначала проверь что в файле
   Ёпрст
 
2 - 26.03.19 - 11:51
СчетУчетаПолучательБУ  - це не строка
   bacamba49
 
3 - 26.03.19 - 11:54
(2) а как проверить условие на счет?
   Ёпрст
 
4 - 26.03.19 - 11:54
(3) сравнивать или с предопределенными данными счета или искать счет по коду
   bacamba49
 
5 - 26.03.19 - 11:56
(4) а как это выглядит в синтаксисе?
   Ёпрст
 
6 - 26.03.19 - 11:58
(5)

<условие> = ПланыСчетов.Хозрасчетный.РасчетыПоПретензиям
   Ёпрст
 
7 - 26.03.19 - 12:00
ну или через менеджер счета и метод НайтиПоКоду
   savaB
 
8 - 26.03.19 - 12:00
Если ОбъектКоллекции.СчетУчетаПолучательБУ.Код = "10.М4" Тогда
   Ёпрст
 
9 - 26.03.19 - 12:00
если счет не предопределенный
   Cyberhawk
 
10 - 26.03.19 - 12:08
(9) А если предопределенный тогда что, по коду уже и поискать нельзя? :)
 
 Рекламное место пустует
   bacamba49
 
11 - 26.03.19 - 12:11
(8) так не работает тоже
   Вафель
 
12 - 26.03.19 - 12:12
я всегда по коду делаю, ибо та задержка выполнения не стоит той задержки при чтении кода
   Cyberhawk
 
13 - 26.03.19 - 12:13
(12) Только вот чтоб по коду найти это обязательно серверный вызов _каждый раз_, в отличие от однократно выполняемого ПредопределенноеЗначение
   bacamba49
 
14 - 26.03.19 - 12:16
в источнике счет не предопределенный 10.М4...в приемнике - предопределенный МЦ.04...подскажите синтаксис..плз...не соображу никак..(
   savaB
 
15 - 26.03.19 - 12:30
(8) так не работает тоже

что значит не работает ? не выгружает / не загружает ?
   savaB
 
16 - 26.03.19 - 12:32
Значение = "МЦ.04"; 

а так
Выражение = "ПланыСчетов.Хозрасчетный.НайтиПоКоду""МЦ.04""";
   Вафель
 
17 - 26.03.19 - 12:35
(13) ПредопределенноеЗначение тоже дает серверный вызов
   Вафель
 
18 - 26.03.19 - 12:35
да и вообще найтипокоду в клиенет сделать нельзя
   Cyberhawk
 
19 - 26.03.19 - 12:44
Хз о чем ты
   bacamba49
 
20 - 26.03.19 - 13:03
ппц...
извратился даже так 
Если ПланыСчетов.Хозрасчетный.НайтиПоКоду(ОбъектКоллекции.СчетУчетаБУ.Код).Наименование = "Инвентарь и хозяйственные принадлежности в эксплуатации"  Тогда
    
    Значение = "МЦ.04";
    
КонецЕсли;
   bacamba49
 
21 - 26.03.19 - 13:03
при выгрузке пишет 

шибка при выгрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1694)}: Ошибка получения значения свойства объекта (по имени свойства источника)
    ПКО                    =  Хозрасчетный  (План счетов: План счетов бухгалтерского учета)
    ПКС                    =  2  (Код --> Код)
    Объект                 =  МЦ.04  (Строка)
    СвойствоПриемника      =  Код  (Строка)
    ОписаниеОшибки         =  Получение элемента по индексу для значения не определено
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8283)
    КодСообщения           =  13
   bacamba49
 
22 - 26.03.19 - 13:04
господа,ну подскажите КАК проверить условие на 10.М4 ,он НЕ предопределенный...весь день бьюсь
   bacamba49
 
23 - 26.03.19 - 13:11
никто не знает
   bacamba49
 
24 - 26.03.19 - 13:12
заимпись(((
   Cyberhawk
 
25 - 26.03.19 - 13:18
А что означает "49" в нике?
   bacamba49
 
26 - 26.03.19 - 13:26
4+9=13
1+3=4
2004 год рождения
   Cyberhawk
 
27 - 26.03.19 - 13:32
Тебе надо в ПКС нужное ПКО указать. Оно не умеет из строки в счет конвертнуть.
   bacamba49
 
28 - 26.03.19 - 13:33
вот так условие работает...
Если Строка(ОбъектКоллекции.СчетУчетаПолучательБУ) = "104"  Тогда
    
    Сообщить("Да ...сь ОНО КОНЕМ11111");
    
КонецЕсли;
   bacamba49
 
29 - 26.03.19 - 13:35
как теперь заменить 10.М4 на МЦ.04?
МЦ.04 в источнике в плане счетов нет..он предопределенный в приемнике
   Cyberhawk
 
30 - 26.03.19 - 13:36
Ну так это потому что ты не подменяешь Значение. Оно ведь потом передается в ПКО (указанное в ПКС), которое на входе ожидает ссылку на счет получить, а не строку
   bacamba49
 
31 - 26.03.19 - 13:36
Значение = "МЦ.04" не работает
   Cyberhawk
 
32 - 26.03.19 - 13:37
Подсовывай в значение структуру со всеми необходимыми полями, чтобы сработало ПКО в приемнике по полям поиска, и в источнике ошибок не было при получении реквизитов.
Ну либо на стороне приемника разруливай.
   bacamba49
 
33 - 26.03.19 - 13:40
(32) да,попробую на стороне приемника..спс
 
 
   Cyberhawk
 
34 - 26.03.19 - 13:47
Про год рождения только что-то ты походу знатно посмеялся надо мной )
   bacamba49
 
35 - 26.03.19 - 13:56
(34) не
   bacamba49
 
36 - 26.03.19 - 13:57
не смеялся
   Cyberhawk
 
37 - 26.03.19 - 13:57
А чей это год рождения тогда?
   bacamba49
 
38 - 26.03.19 - 13:58
мой
   Cyberhawk
 
39 - 26.03.19 - 13:59
Тебе 15 лет?
   bacamba49
 
40 - 26.03.19 - 14:00
да
   Cyberhawk
 
41 - 26.03.19 - 14:00
Как ты до 1С докатился в таком возрасте? В школе что ли преподают?
   bacamba49
 
42 - 26.03.19 - 14:01
не,..интересно..да и деньги уже платят
   bacamba49
 
43 - 26.03.19 - 14:02
с кд не работал никогда
   Cyberhawk
 
44 - 26.03.19 - 14:02
Стажер что ли?
   Cyberhawk
 
45 - 26.03.19 - 14:03
(43) Как это не работал - у тебя темы 8-месячной давности про КД
   bacamba49
 
46 - 26.03.19 - 14:04
ога..выгрузки на три два... дока..ппц работа с кд
   bacamba49
 
47 - 26.03.19 - 14:05
а щас тема серьезная,плюс обмен еще нужен будет..сразу куча вопросов
   bacamba49
 
48 - 26.03.19 - 14:22
решена проблема..
   bacamba49
 
49 - 26.03.19 - 14:23
выгружаю как есть,при загрузке поля со счетами соответственно пустые..ну и
ПОССЛЕ ЗАГРУЗКИ в приемнике

Для Каждого Стр Из Объект.Спецодежда  Цикл
    
    Если НЕ ЗначениеЗаполнено(Стр.СчетУчета) Тогда
        
        Стр.СчетУчета = ПланыСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации;
            
    КонецЕсли;    
        
        
    
КонецЦикла;
 
 Рекламное место пустует
   Cyberhawk
 
50 - 26.03.19 - 14:27
Молодец. Сколько платят?
   bacamba49
 
51 - 26.03.19 - 14:28
(32) а про структуру,да..интересная мысля..нало будет потестить..это щас,частный случай ,костыльно проконало...а потом может и не помочь такой костыль
   bacamba49
 
52 - 26.03.19 - 14:28
(50) копейки
   bacamba49
 
53 - 26.03.19 - 14:28
экономят
   Cyberhawk
 
54 - 26.03.19 - 14:28
А кто платит, одна какая-то контора или ты то тут, то там?
   bacamba49
 
55 - 26.03.19 - 14:30
контора
   bacamba49
 
56 - 26.03.19 - 14:31
я и не претендую,опыта реально мало..хочу сертификаты получать,но там после 18 ти лет


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует