Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Управляемые формы: как вернуть параметры из дочерней формы в основную.

Управляемые формы: как вернуть параметры из дочерней формы в основную.
Я
   Dmitry_333
 
26.03.19 - 11:18
Доброго всем дня.

Передать из основной в открываемую форму достаточно просто, но вот как вернуть в основную форму, толком не могу разобраться.
Например, из формы подбора в форму документа.

Направьте пожалуйста-)
 
 
   sqr4
 
1 - 26.03.19 - 11:28
Оповестить?
   Жан Пердежон
 
2 - 26.03.19 - 11:32
ОткрытьФорму() - там куча полезных параметров есть
   Dmitry_333
 
3 - 26.03.19 - 11:39
(2) Действительно, там есть параметр ОписаниеОповещенияОЗакрытии, но как его пользовать? Не могу вменяемую инфу найти.
   polosov
 
4 - 26.03.19 - 11:40
(3) Посмотри как возвращает данные подбор в типовых.
   Ошибка1С
 
5 - 26.03.19 - 11:46
в дочерней форме можно в метод Закрыть() передать нужный параметр и потом его прочитать в обработке выбора
   Cyberhawk
 
6 - 26.03.19 - 11:47
Смотря когда
   Garykom
 
7 - 26.03.19 - 11:48
Нескоко разных способов есть
   Dmitry_333
 
8 - 26.03.19 - 12:08
(5) (7) Можно чуть более подробнее?-)
   sqr4
 
9 - 26.03.19 - 12:11
   Ошибка1С
 
10 - 26.03.19 - 12:12
(8) Закрыть(ТвойПараметр) в дочерней
ОбработкаВыбора(ВыбранноеЗначение) в основной
 
 Рекламное место пустует
   Ошибка1С
 
11 - 26.03.19 - 12:12
(9) офф документация только за бабки?
   sqr4
 
12 - 26.03.19 - 12:20
(11) Понятия не имею, у нас есть подписка
   Dmitry_333
 
13 - 26.03.19 - 12:24
(9) (10) Благодарю!
   polosov
 
14 - 26.03.19 - 12:26
(11) Это не документация. Это книга по разработке интерфейсов, выложенная онлайн.
   Garykom
 
15 - 26.03.19 - 12:57
(13) А еще можно передать в подчиненную форму параметром текущую форму (Владелец или новый) и оттуда вызвать экспортные процедуры или еще как.
Ну и учитываем что параметры передаются без "Знач" и их можно с любого конца менять.

Короче способов несколько
   Dmitry_333
 
16 - 26.03.19 - 13:02
(15) Спасибо
   Dmitry_333
 
17 - 27.03.19 - 10:04
Действительно, все не так сложно оказалось.

Для тех, кого поисковик закинет сюда с аналогичным вопросом, выкладываю простейший пример, как из дочки передать значение в основную.

В модуле основной формы:


&НаКлиенте
Процедура Вперед(Команда)
       
       ОписаниеОповещенияОЗакрытии = Новый ОписаниеОповещения("ОбработкаКомандыЗавершения", ЭтотОбъект);
    
       Форма = ОткрытьФорму("ВнешняяОбработка.ТестФормЗакрытьОткрыть.Форма.ДочерняяФорма",,,,,, ОписаниеОповещенияОЗакрытии);
       
КонецПроцедуры


Процедура ОбработкаКомандыЗавершения(Результат, ДополнительныеПараметры) Экспорт 
    
             Объект.Данная = Результат;
    
КонецПроцедуры 


В модуле дочерней формы:


&НаКлиенте
Процедура ПеренестиВОсновнуюФорму(Команда)
    
    Закрыть(Объект.ДанныеНаДочФорме);
    
КонецПроцедуры


Таким образом, значения из поля реквизита ДанныеНаДочФорме перенесутся в поле реквизита Данные основной формы.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует