Вход | Регистрация
 

Не подгружается изображение в существующую номенклатуру

Не подгружается изображение в существующую номенклатуру
Я
   falselight
 
26.03.19 - 11:10
Идет загрузка номенклатуры с изображениями.
При загрузке и создании нового элемента, изображение появляется в справочнике.
Но когда элемент находится, почему то изображение не появляется.
Хотя по коду проходит все одинаково.

Загрузка изображения в создаваемый элемент. Когда все работает.

        // КАРТИНКА
        Если НомерКартинка <> "-" Тогда
            НужныеДанныеКартинки = "<Pic>";
            НомерСтроки_Стр      = Формат(ИндексСтроки, "ЧН=0; ЧГ=0");
            АдресОбластиРисунка  = "R" + НомерСтроки_Стр + "C" + (ЧИСЛО(НомерКартинка)+1) + ":R" + НомерСтроки_Стр + "C" + (ЧИСЛО(НомерКартинка)+1);
            Для Каждого РисунокТД ИЗ ЭлементыФормы.ПолеТабличногоДокумента.ПолучитьОбласть(АдресОбластиРисунка).Рисунки Цикл
                НужныеДанныеКартинки                          = РисунокТД.Картинка;
                НовыйОбъект              = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
                НовыйОбъект.Наименование = СпрНоменклатура.Наименование;
                НовыйОбъект.Хранилище    = Новый ХранилищеЗначения(НужныеДанныеКартинки, Новый СжатиеДанных);
                НовыйОбъект.ВидДанных      = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
                НовыйОбъект.Объект          = СпрНоменклатура.Ссылка;
                НовыйОбъект.Записать();
                СпрНоменклатура.ОсновноеИзображение           = НовыйОбъект.Ссылка;
                // ----
                //
                Прервать;
            КонецЦикла;
        КонецЕсли;



Загрузка изображения в найденный элемент в справочнике по артикулу. Изображение не появляется.

            // КАРТИНКА
            Если НомерКартинка <> "-" Тогда
                НужныеДанныеКартинки = "<Pic>";
                НомерСтроки_Стр      = Формат(ИндексСтроки, "ЧН=0; ЧГ=0");
                АдресОбластиРисунка  = "R" + НомерСтроки_Стр + "C" + (ЧИСЛО(НомерКартинка)+1) + ":R" + НомерСтроки_Стр + "C" + (ЧИСЛО(НомерКартинка)+1);
                Для Каждого РисунокТД ИЗ ЭлементыФормы.ПолеТабличногоДокумента.ПолучитьОбласть(АдресОбластиРисунка).Рисунки Цикл
                    НужныеДанныеКартинки     = РисунокТД.Картинка;
                    НовыйОбъект              = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
                    НовыйОбъект.Наименование = НоменклатураПоАртикулу.Наименование;
                    НовыйОбъект.Хранилище    = Новый ХранилищеЗначения(НужныеДанныеКартинки, Новый СжатиеДанных);
                    НовыйОбъект.ВидДанных      = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
                    НовыйОбъект.Объект          = НоменклатураПоАртикулу.Ссылка;
                    НовыйОбъект.Записать();
                    //
                    НоменклатураПоАртикулуОбъект                     = НоменклатураПоАртикулу.ПолучитьОбъект();
                    НоменклатураПоАртикулуОбъект.ОсновноеИзображение = НовыйОбъект.Ссылка;
                    НоменклатураПоАртикулуОбъект.Записать();
                    Сообщить("Найденной номенклатуре с артиклом " + СокрЛП(Артикул) + " установленно изображение!", СтатусСообщения.Информация);
                    // ----
                    //
                    Прервать;
                КонецЦикла;
            КонецЕсли;
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.