Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Синхронизация подразделений ЗУП и БП

Синхронизация подразделений ЗУП и БП
Я
   lg2marvel
 
25.03.19 - 15:09
»
 
 
   lg2marvel
 
1 - 25.03.19 - 15:21
Обмен делается из БП, если делать обмен из ЗУП - выдает ошибку:

{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(17403)}: Ошибка при отправке данных: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(4043)}: Ошибка в базе-корреспонденте: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(10158)}: Ошибка при записи документа: Отражение зарплаты в бухучете 00П2-000006 от 31.03.2019. Описание ошибки: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1807)}: Ошибка записи объекта
    ТипОбъекта             =  Отражение зарплаты в бухучете
    Объект                 =  Отражение зарплаты в бухучете 00П2-000006 от 31.03.2019
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать)
        Объект.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода СверткаПодразделенийЗУППередЗаписью ().
    ПозицияМодуля          =  Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1785)
    КСообщенияОбОшибках    =  26
                        ВызватьИсключение СтрокаСообщения;
        ВызватьИсключение(НСтр("ru = 'Ошибка при отправке данных'") + ": " + ОписаниеОшибки());
   lg2marvel
 
2 - 25.03.19 - 15:34
ПКО подразделений:
Перед выгрузкой: НеЗамещатьОбъектПриЗагрузке = Истина;



Поля поиска:
Если НомерВариантаПоиска = 1 Тогда
    Если ЗначениеЗаполнено(СвойстваПоиска["Родитель"]) Тогда
        СтрокаИменСвойствПоиска = "Владелец,Наименование,Родитель";
    Иначе
        СтрокаИменСвойствПоиска = "Владелец,Наименование";
    КонецЕсли;
Иначе
    Если ЗначениеЗаполнено(СвойстваПоиска["Родитель"]) Тогда
        // в первой попытке поиск выполняли с учетом родителя

        СтрокаИменСвойствПоиска = "Владелец,Наименование";
    Иначе
        // в первой попытке поиск выполняли без учета родителя

        ПрекратитьПоиск = Истина;
    КонецЕсли;
КонецЕсли;


После загрузки:
Если ПараметрыОбъекта <> Неопределено Тогда
    
    Если Найти(ВРег(Метаданные.Имя), "КОРП") <> 0 Тогда
        Объект.ГоловнаяОрганизация = ПараметрыОбъекта["ГоловнаяОрганизация"];
        Объект.ОбособленноеПодразделение = ПараметрыОбъекта["ОбособленноеПодразделение"];
    КонецЕсли;
    
КонецЕсли;
   lg2marvel
 
3 - 25.03.19 - 15:41
Может как-то сумбурно описал проблему, попробую на пальцах:
Есть подразделение ААА в ЗУП и ААА в БП.
Когда зарегистрировал на узле ЗУП ААА к выгрузке оно выгружается на ААА.
Создаю документ отражение зп в бухучете со строкой с подразделением ААА в БП документ выгружается с подразделением БББ
   Фрэнки
 
4 - 25.03.19 - 15:43
и чем выложенные простыни должны нас здесь развлечь? или озадачить?
   lg2marvel
 
5 - 25.03.19 - 15:46
(4) Может вы увидите того что я не заметил
   lg2marvel
 
6 - 25.03.19 - 16:55
Что может давать такую ошибку?

Ошибка в базе-корреспонденте: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(10158)}: Ошибка при записи документа: Отражение зарплаты в бухучете 00П2-000006 от 31.03.2019. Описание ошибки: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1807)}: Ошибка записи объекта
    ТипОбъекта             =  Отражение зарплаты в бухучете
    Объект                 =  Отражение зарплаты в бухучете 00П2-000006 от 31.03.2019
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать)
        Объект.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода СверткаПодразделенийЗУППередЗаписью ().
    ПозицияМодуля          =  Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1785)
    КСообщенияОбОшибках    =  26
                        ВызватьИсключение СтрокаСообщения;
   hhhh
 
7 - 25.03.19 - 17:12
(6) может вы в толстом клиенте запустили? А надо в тонком.
   lg2marvel
 
8 - 25.03.19 - 17:24
(7) тонкий клиент
   lg2marvel
 
9 - 25.03.19 - 17:36
(0) (2) (3) нашел причину. Хочу вернуть все к штатным средствам обмена. Для этого нужно найти почему получается (6)
   DrZombi
 
10 - 27.03.19 - 12:36
(0) Как вариант, исключите подразделение из обмена, от слова совсем.
Либо структура в ЗУП и БП, должна быть 1 к 1 :)
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует