Вход | Регистрация
 

автозаполнение реквизита в управляемой форме

автозаполнение реквизита в управляемой форме
Я
   dezomorf1c
 
25.03.19 - 11:35
Подскажите, если не затруднит, как автоматически заполнить второй реквизит при выборе значения  первого реквизита (реквизиты из разных справочников). Второй реквизит является владельцем первого.
 
 
   sqr4
 
1 - 25.03.19 - 11:36
Запросом получаешь. Если возвращает больше одной строки, то как быть?
   dezomorf1c
 
2 - 25.03.19 - 11:40
(1) такого не будет
   dezomorf1c
 
3 - 25.03.19 - 11:41
можно ли делать по такой формуле? нет ли ошибок

&НаКлиенте
Процедура Реквизит1ПриИзменеии(Элемент)
   Реквизит2 = ЗначениеВладельцаРеквизита1(Реквизит1);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗначениеВладельцаРеквизита1(Реквизит1)
Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Реквизит1, "Владелец");
КонецФункции
   sqr4
 
4 - 25.03.19 - 11:45
плохо прочитал, и запрос не нужен, вроде должно сработать
   Жан Пердежон
 
5 - 25.03.19 - 11:50
(3) обычно, так и делается;
ещё можно вообще без реквизита: поле надписи с ПутьКДынным="Реквизит1.Владелец"
   dezomorf1c
 
6 - 25.03.19 - 13:22
подскажите, как обратиться к Реквизит1 ? это реквизит документа 

&НаКлиенте
Процедура ПодрПолучательПриИзменении(Элемент)
    Объект.ОрганизацияПолучатель = ЗначениеВладельцаПодрПолучатель(Реквизит1);
 КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ЗначениеВладельцаПодрПолучатель()
   Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Реквизит1);
КонецФункции
//
   hhhh
 
7 - 25.03.19 - 13:53
(6) как обычно

Объект.Реквизит1
   dezomorf1c
 
8 - 25.03.19 - 14:09
(7) я пробовал. переменная не определена в итоге
   Жан Пердежон
 
9 - 25.03.19 - 14:47
(8) У тебя как минимум параметров не хватает в (6) в вызове функции общего модуля.
А вообще, проще и быстрее в отладчике смотреть, что у тебя в коде происходит.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.