Вход | Регистрация
 

Как записать изменение в справочнике ?

Как записать изменение в справочнике ?
Я
   iznvi
 
21.03.19 - 17:35
Процедура НачатьНажатие(Элемент)
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Артикул,
        |    Номенклатура.Ссылка
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Артикул) Тогда
            Если Найти(ВыборкаДетальныеЗаписи.Артикул, " ") Тогда
                СократитьПробелы=СокрЛП(ВыборкаДетальныеЗаписи.Артикул);
                                   
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Вот код, но не понимаю как записать изменения которые ввожу
Можете накинуть кодом ?
 
 
   Rico_1C
 
1 - 21.03.19 - 17:41
ТекОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
СократитьПробелы=СокрЛП(ТекОбъект.Артикул); 
ТекОбъект.Удалить();
   aleks_default
 
2 - 21.03.19 - 17:45
(1) тока проверь сначала на тестовой базе:)
   iznvi
 
3 - 21.03.19 - 17:46
(2) Нене, мне удалять не нужно) Мне нужно просто сократить пробелы в строке, а потом записать
   Rico_1C
 
4 - 21.03.19 - 17:47
(2) Тыщу раз так делал !..  ))
   Очевидно
 
5 - 21.03.19 - 17:55
(1) Это "5" ! xD
   iznvi
 
6 - 21.03.19 - 17:58
(4) Спасибо тебе за пример, но все равно почему то не удаляет пробелы
И да, шутка была бы опасная, если бы на живой базе сразу тестил:D
   RomanYS
 
7 - 21.03.19 - 17:58
(1) Если каждой обезьяне выдавать гранату, на вас обезьян не напасешься)))
   iznvi
 
8 - 21.03.19 - 18:00
(7) Родной, я готов с тобой потом над шутками пошутить, но плееез
Давай сначала проблему решим, а потом будем хохотушку ловить
   RomanYS
 
9 - 21.03.19 - 18:03
(8)
ТекОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
ТекОбъект.Артикул = ....;
ТекОбъект.Записать()
   iznvi
 
10 - 21.03.19 - 18:28
(9) Я все исправил, все норм спасибо большое за помощь
В итоге была проблема не в пробелах, а в том что очень умный человек по имени пользователь взял и написал заместо Х русская Х английский..
У меня все.
 
 Рекламное место пустует
   Builder
 
11 - 21.03.19 - 18:33
(10) Вот это точно "5" :)
   iznvi
 
12 - 21.03.19 - 18:38
(11) +
   iznvi
 
13 - 21.03.19 - 18:39
(11) Так и спиться можно....

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует