Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Разузлование номенклатуры в УПП

Разузлование номенклатуры в УПП
Я
   Босечка
 
21.03.19 - 14:45
Есть стандартная процедура в УПП
        МассивОшибок = РазузлованиеНоменклатуры.РазузловатьНоменклатуру(СтруктураИсточник, РезультатРазузлования, Параметры);
        
        Если МассивОшибок.Количество() > 0 Тогда
            
            Для каждого Ошибка из МассивОшибок Цикл
                
                ОбщегоНазначения.Сообщение("Ошибка: " + Ошибка.Причина, Ошибка.СтатусОшибки);
                ОбщегоНазначения.Сообщение(" Спецификация: " + Ошибка.Спецификация);
                ОбщегоНазначения.Сообщение(" Номер строки: " + Ошибка.НомерСтроки);
                ОбщегоНазначения.Сообщение(" Описание ошибки: " + Ошибка.ОписаниеОшибки);
            
            КонецЦикла;
            
        КонецЕсли;
        
        Если РезультатРазузлования.ИсходныеКомплектующие = Неопределено Тогда
            Продолжить;
        КонецЕсли;
        
        ИсходныеКомплектующие = РезультатРазузлования.ИсходныеКомплектующие;
        
        ИсходныеКомплектующие.ЗаполнитьЗначения(Подразделение, "Подразделение");
        //заполним подразделение по основной спецификации полуфабрикатов
        Для каждого Строка из ИсходныеКомплектующие цикл
            ПодразделениеНоменклатуры = ЗаказыНаПроизводствоИПереработку.ПолучитьПодразделениеИзСпецификации(Строка.Спецификация,Строка.Номенклатура,Строка.ХарактеристикаНоменклатуры);
            Если ЗначениеЗаполнено(ПодразделениеНоменклатуры) Тогда
                Строка.Подразделение = ПодразделениеНоменклатуры;
            КонецЕсли;
        КонецЦикла;
 
 
   Босечка
 
1 - 21.03.19 - 14:46
Как с помощью нее получить дерево спецификации по конкретной номенклатуре и характеристике?
   Ахмадинежад
 
2 - 21.03.19 - 15:09
Обработка "Конструктор спецификаций", основная форма, метод "ПечатьДереваСпецификаций(ДеревоСпецификаций);"
   Ахмадинежад
 
3 - 21.03.19 - 15:09
вроде )
   aleks_default
 
4 - 21.03.19 - 17:38
Сделай свою. Там делов-то на пять минут с перекурами

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.