Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОБМЕН не типовой СЛОМАЛСЯ (Синхронизация УПП 1.3 с БП 3.0)

ОБМЕН не типовой СЛОМАЛСЯ (Синхронизация УПП 1.3 с БП 3.0)
Я
   Роман_Сергеевич
 
21.03.19 - 13:41
Добрый день!
Друзья, помогите пожалуйста решить проблему!
Обмен писанный  УПП 1.3 (необновляется) с БП 3.0... С обновлением БП на 3.0.67 изменился объект перечисления Имя="СтавкаНДС" Вид="Реквизит" Тип="ПеречислениеСсылка.СтавкиНДС на Имя="ВидСтавкиНДС" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыСтавокНДС и т.д. связаных доков и номенклатуры с СтавкаНДС.

При обмене БП выдаёт:
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(9726)}: Поле объекта не обнаружено (СтавкаНДС)
    ИначеЕсли НЕ ЭтоПараметрДляОбъекта

Т.е. стопорится на этой беде:
// Так м не смогли создать объект в событии - создаем его отдельно.
                Если Объект = Неопределено Тогда
                    
                    Если ИмяТипаОбъекта = "Константы" Тогда
                        
                        Объект = Неопределено;
                        РежимРаботыСКонстантами = Истина;
                                                
                    Иначе
                        
                        СоздатьНовыйОбъект(ТипОбъекта, СвойстваПоиска, Объект, Ложь, , ,НаборЗаписей);
                                                                    
                    КонецЕсли;
                    
                КонецЕсли;
                
            КонецЕсли;

            
            Имя                = одАтрибут(ФайлОбмена, ТипСтрока, "Имя");
            НеЗамещатьСвойство = одАтрибут(ФайлОбмена, ТипБулево, "НеЗамещать");
            ИмяПКО             = одАтрибут(ФайлОбмена, ТипСтрока, "ИмяПКО");
            
            Если РежимРаботыСКонстантами Тогда
                
                Объект = Константы[Имя].СоздатьМенеджерЗначения();    
                ИмяКонстанты = Имя;
                Имя = "Значение";
                
            ИначеЕсли НЕ ЭтоПараметрДляОбъекта
                И ((ОбъектНайден И НеЗамещатьСвойство)
                ИЛИ (Имя = "ЭтоГруппа")
                ИЛИ (Объект[Имя] = NULL)) Тогда


В провилах УПП в ПКО зименил в перечислениях и номенклатуре:
<Наименование>СтавкаНДС --&gt; ВидСтавкиНДС</Наименование>
        
        <Источник Имя="СтавкаНДС" Вид="Реквизит" Тип="ПеречислениеСсылка.СтавкиНДС"/>
        <Приемник Имя="ВидСтавкиНДС" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыСтавокНДС"/>
        <КодПравилаКонвертации>СтавкиНДС
По докам тоже пробежался, изменл.
В правилах корреспондента тоже поправил.


Ошибка осталась.
Может кто-то сталкивался с такой бедой?
 
 
   Жан Пердежон
 
1 - 21.03.19 - 15:38
обратись к прогу, который про КД хоть что-то слышал - всё быстро исправит
   d4rkmesa
 
2 - 21.03.19 - 15:43
(0) Включите вывод сообщений и посмотрите, к какому объекту это относится.
   d4rkmesa
 
3 - 21.03.19 - 15:44
(2) В режиме "толстый клиент обычные приложение".
   unbred
 
4 - 21.03.19 - 15:50
   unbred
 
5 - 21.03.19 - 15:52
+(4) у меня упп вдоль и поперек кастомная. давно в правила не лажу. прямо в макете всё исправляю. поэтому этот метод мне очень подошёл.
   Роман_Сергеевич
 
6 - 22.03.19 - 06:05
ОК.
Спасибо за советы!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.